aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-10-16 09:31:58 +0800
committerkris <kris@FreeBSD.org>2003-10-16 09:31:58 +0800
commitda8461ff2ec762292299f15fc11acb1c8964991e (patch)
treef89e331d5f2e08ecfea6d61ae8acc9965049b439 /net
parentaacf2ddd5568a006dd10f1707dbfc411828817ce (diff)
downloadfreebsd-ports-gnome-da8461ff2ec762292299f15fc11acb1c8964991e.tar.gz
freebsd-ports-gnome-da8461ff2ec762292299f15fc11acb1c8964991e.tar.zst
freebsd-ports-gnome-da8461ff2ec762292299f15fc11acb1c8964991e.zip
BROKEN on 5.x: does not compile
Diffstat (limited to 'net')
-rw-r--r--net/cap/Makefile8
-rw-r--r--net/l2tpd/Makefile8
-rw-r--r--net/rwhois/Makefile8
-rw-r--r--net/rwhoisd/Makefile8
-rw-r--r--net/ztelnet/Makefile8
5 files changed, 35 insertions, 5 deletions
diff --git a/net/cap/Makefile b/net/cap/Makefile
index 33f0a3467df6..0d669a1ce3f7 100644
--- a/net/cap/Makefile
+++ b/net/cap/Makefile
@@ -57,6 +57,12 @@ DOCS2= CAP.faq CAP60.README NOTICE README
READMES= applications/papif applications/lwsrv applications/aufs \
doc applications support/uab support/ethertalk
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
pre-patch:
@(cd ${WRKSRC}; \
for f in ../cap60.patch* ; do ${PATCH} -s -p < $$f ; done)
@@ -107,4 +113,4 @@ post-install:
@${LN} -fs ${PREFIX}/man/man8/papif.8${GZ} ${PREFIX}/man/man8/papof.8${GZ}
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include "bsd.port.mk"
+.include "bsd.port.post.mk"
diff --git a/net/l2tpd/Makefile b/net/l2tpd/Makefile
index 8ba1da7a2a39..98e10c1dc5fd 100644
--- a/net/l2tpd/Makefile
+++ b/net/l2tpd/Makefile
@@ -19,6 +19,12 @@ USE_REINPLACE= yes
MAN5= l2tp-secrets.5 l2tpd.conf.5
MAN8= l2tpd.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-configure:
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/doc/l2tpd.8 \
${WRKSRC}/doc/l2tpd.conf.sample ${WRKSRC}/doc/l2tp-secrets.5 \
@@ -35,4 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/l2tpd.conf.sample ${PREFIX}/etc/l2tp
${INSTALL_DATA} ${WRKSRC}/doc/l2tp-secrets.sample ${PREFIX}/etc/l2tp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/rwhois/Makefile b/net/rwhois/Makefile
index 6e238dc942a4..5ea261996ce7 100644
--- a/net/rwhois/Makefile
+++ b/net/rwhois/Makefile
@@ -30,6 +30,12 @@ MAN8= rwhois_indexer.8 rwhoisd.8
PORTDOCS= INSTALL.html TODO UPGRADE operations_guide.html \
operations_guide.txt rfc2167.txt security.html security.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/rwhois_indexer.8 ${PREFIX}/man/man8
${INSTALL_MAN} ${WRKSRC}/doc/rwhoisd.8 ${PREFIX}/man/man8
@@ -42,4 +48,4 @@ post-install:
@${ECHO_MSG} "Installing ${PREFIX}/etc/rc.d/rwhoisd.sh startup file..."
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/rwhoisd.sh ${PREFIX}/etc/rc.d/rwhoisd.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/rwhoisd/Makefile b/net/rwhoisd/Makefile
index 6e238dc942a4..5ea261996ce7 100644
--- a/net/rwhoisd/Makefile
+++ b/net/rwhoisd/Makefile
@@ -30,6 +30,12 @@ MAN8= rwhois_indexer.8 rwhoisd.8
PORTDOCS= INSTALL.html TODO UPGRADE operations_guide.html \
operations_guide.txt rfc2167.txt security.html security.txt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/rwhois_indexer.8 ${PREFIX}/man/man8
${INSTALL_MAN} ${WRKSRC}/doc/rwhoisd.8 ${PREFIX}/man/man8
@@ -42,4 +48,4 @@ post-install:
@${ECHO_MSG} "Installing ${PREFIX}/etc/rc.d/rwhoisd.sh startup file..."
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/rwhoisd.sh ${PREFIX}/etc/rc.d/rwhoisd.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/ztelnet/Makefile b/net/ztelnet/Makefile
index 7864573e4fe0..bf7b8fa0ce1b 100644
--- a/net/ztelnet/Makefile
+++ b/net/ztelnet/Makefile
@@ -27,6 +27,12 @@ NO_WRKSUBDIR= yes
PATCH_STRIP= -p1
MAN1= ztelnet.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
# we can ignore warnings
@( cd ${WRKSRC}/ztelnet && \
@@ -48,4 +54,4 @@ do-install:
${INSTALL_PROGRAM} telnet/telnet ${PREFIX}/bin/ztelnet
${INSTALL_MAN} ${WRKSRC}/ztelnet.1 ${PREFIX}/man/man1/ztelnet.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>