aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-08-16 02:35:05 +0800
committersobomax <sobomax@FreeBSD.org>2007-08-16 02:35:05 +0800
commite14d9dad41996d6c9d6aebab0015db4c47a589d6 (patch)
tree35376fbdf85cde17dbcb65d93b94c28f6ef0feff /net
parentbaf512daa2a751ff6581f74925f644ead74e318c (diff)
downloadfreebsd-ports-gnome-e14d9dad41996d6c9d6aebab0015db4c47a589d6.tar.gz
freebsd-ports-gnome-e14d9dad41996d6c9d6aebab0015db4c47a589d6.tar.zst
freebsd-ports-gnome-e14d9dad41996d6c9d6aebab0015db4c47a589d6.zip
Add startup script. Bump PORTREVISION.
Submitted by: Blaz Zupan
Diffstat (limited to 'net')
-rw-r--r--net/ser/Makefile3
-rw-r--r--net/ser/files/ser.in34
2 files changed, 36 insertions, 1 deletions
diff --git a/net/ser/Makefile b/net/ser/Makefile
index cf848f191352..eb3ed6ad0fee 100644
--- a/net/ser/Makefile
+++ b/net/ser/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ser
PORTVERSION= 0.9.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/ser/ \
http://download2.berlios.de/ser/
@@ -19,6 +19,7 @@ COMMENT= A very fast and configurable SIP proxy
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
+USE_RC_SUBR= ser
CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= "LDFLAGS=-L${LOCALBASE}/lib"
diff --git a/net/ser/files/ser.in b/net/ser/files/ser.in
new file mode 100644
index 000000000000..73c5f277ad77
--- /dev/null
+++ b/net/ser/files/ser.in
@@ -0,0 +1,34 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: ser
+# REQUIRE: DAEMON mysql postgresql
+#
+prefix=%%PREFIX%%
+
+# Add the following lines to /etc/rc.conf to enable ser:
+#
+# ser_enable="YES"
+
+. %%RC_SUBR%%
+
+name="ser"
+rcvar=`set_rcvar`
+command="${prefix}/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+command_args="-P ${pidfile} > /dev/null"
+
+load_rc_config $name
+
+: ${ser_enable="NO"}
+
+stop_postcmd=stop_postcmd
+
+stop_postcmd()
+{
+ rm -f $pidfile
+}
+
+run_rc_command "$1"