aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2013-11-07 06:50:21 +0800
committerdelphij <delphij@FreeBSD.org>2013-11-07 06:50:21 +0800
commite152fec3d3565ef13abcbeb42f37c47f2788e9ca (patch)
treef4ca39f0f94b1fc725562cca278474e325706ee3 /net
parent43af442547bb63fc6c7117fbc9d483374293c063 (diff)
downloadfreebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.tar.gz
freebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.tar.zst
freebsd-ports-gnome-e152fec3d3565ef13abcbeb42f37c47f2788e9ca.zip
Update to 0.57.
PR: ports/179390 Submitted by: nemysis Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/pure-sockets/Makefile27
-rw-r--r--net/pure-sockets/pkg-descr2
2 files changed, 26 insertions, 3 deletions
diff --git a/net/pure-sockets/Makefile b/net/pure-sockets/Makefile
index 9685ecf8c5a5..b6e162eea065 100644
--- a/net/pure-sockets/Makefile
+++ b/net/pure-sockets/Makefile
@@ -3,16 +3,39 @@
PORTNAME= pure-sockets
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= net
+MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+DIST_SUBDIR= pure
MAINTAINER= lichray@gmail.com
COMMENT= Pure language interface to the Berkeley socket functions
-USE_PURE= yes
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= dual
+
+USES= pure
PLIST_FILES= lib/pure/sockets.pure \
lib/pure/sockets.so
NO_STAGE= yes
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
+
+PORTDOCS= README
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/net/pure-sockets/pkg-descr b/net/pure-sockets/pkg-descr
index 4e873af0e78c..aac7269743d1 100644
--- a/net/pure-sockets/pkg-descr
+++ b/net/pure-sockets/pkg-descr
@@ -3,4 +3,4 @@ functionality, so you can create sockets for both stream and datagram based
protocols and use these to transmit messages. Unix-style file sockets are
also available if the host system supports them.
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-sockets.html
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-sockets.html