aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2005-10-29 07:07:50 +0800
committermi <mi@FreeBSD.org>2005-10-29 07:07:50 +0800
commite26810b423973bac6efc4fda026d4a6c4e0706db (patch)
tree06eb1a5ef86523c7bf3aa3a6d29d5740e4447d83 /net
parent5b2932b26f19a35c1fb86ff8eb33c90a2aa8f888 (diff)
downloadfreebsd-ports-gnome-e26810b423973bac6efc4fda026d4a6c4e0706db.tar.gz
freebsd-ports-gnome-e26810b423973bac6efc4fda026d4a6c4e0706db.tar.zst
freebsd-ports-gnome-e26810b423973bac6efc4fda026d4a6c4e0706db.zip
Fix patch-ae to compare the specified rsh-equivalent with "/usr/bin/rsh" instead
of the compiled in _PATH_REMSH, which is now ssh. This allows some users to still specify /usr/bin/rsh and (if they run as root) have the program use rcmd(), while solving the problems like that in the PR: 79093 Submitted by: Alex Deiter Bump PORTREVISION.
Diffstat (limited to 'net')
-rw-r--r--net/rdist6/Makefile2
-rw-r--r--net/rdist6/files/patch-ae2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/rdist6/Makefile b/net/rdist6/Makefile
index 4c7536cb347e..a80f407134ae 100644
--- a/net/rdist6/Makefile
+++ b/net/rdist6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rdist
PORTVERSION= 6.1.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.magnicomp.com/download/rdist/ \
ftp://ftp.sunet.se/pub/unix/admin/mirror-magnicomp/download/rdist/
diff --git a/net/rdist6/files/patch-ae b/net/rdist6/files/patch-ae
index 8a8766b5a4a7..bd3a1ba9b120 100644
--- a/net/rdist6/files/patch-ae
+++ b/net/rdist6/files/patch-ae
@@ -29,7 +29,7 @@
if (becomeuser() != 0)
exit(1);
#else /* !DIRECT_RCMD */
-! if (geteuid() == 0 && strcmp(path_remsh, _PATH_REMSH) == 0) {
+! if (geteuid() == 0 && strcmp(path_remsh, "/usr/bin/rsh") == 0) {
! debugmsg(DM_MISC, "I am root, using rsh, therefore direct rcmd\n");
(void) signal(SIGPIPE, sighandler);
+