aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-16 17:03:24 +0800
committermarcus <marcus@FreeBSD.org>2003-11-16 17:03:24 +0800
commite50034bbef3ea400ca56166c732791435cd6ee93 (patch)
tree7ad6045ca994adfed9d0b07e9cb0f37248035c4c /net
parent3768e85eb54be725e9b890a1974f086a26c6d346 (diff)
downloadfreebsd-ports-gnome-e50034bbef3ea400ca56166c732791435cd6ee93.tar.gz
freebsd-ports-gnome-e50034bbef3ea400ca56166c732791435cd6ee93.tar.zst
freebsd-ports-gnome-e50034bbef3ea400ca56166c732791435cd6ee93.zip
Fix a problem where straw wouldn't show any articles if the locale was set
to anything other than C. Also, make sure we persist articles across reboots. Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/straw/Makefile2
-rw-r--r--net/straw/files/patch-src::lib::Config.py11
-rw-r--r--net/straw/files/patch-src::lib::utils.py11
3 files changed, 23 insertions, 1 deletions
diff --git a/net/straw/Makefile b/net/straw/Makefile
index 75b86c0b0cc3..c09eca4164c4 100644
--- a/net/straw/Makefile
+++ b/net/straw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= straw
PORTVERSION= 0.21.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}.pkg/${PORTVERSION}/
diff --git a/net/straw/files/patch-src::lib::Config.py b/net/straw/files/patch-src::lib::Config.py
new file mode 100644
index 000000000000..227b7adbbdb0
--- /dev/null
+++ b/net/straw/files/patch-src::lib::Config.py
@@ -0,0 +1,11 @@
+--- src/lib/Config.py.orig Sun Nov 16 03:57:07 2003
++++ src/lib/Config.py Sun Nov 16 03:58:04 2003
+@@ -364,6 +364,8 @@
+ last_poll = property(get_last_poll, set_last_poll, None, "Last polled")
+
+ def get_number_of_items_stored(self):
++ if self._items_stored == 0:
++ return 30
+ return self._items_stored
+
+ def set_number_of_items_stored(self, num=30):
diff --git a/net/straw/files/patch-src::lib::utils.py b/net/straw/files/patch-src::lib::utils.py
new file mode 100644
index 000000000000..f516ea556b50
--- /dev/null
+++ b/net/straw/files/patch-src::lib::utils.py
@@ -0,0 +1,11 @@
+--- src/lib/utils.py.orig Sun Nov 16 03:58:11 2003
++++ src/lib/utils.py Sun Nov 16 03:58:32 2003
+@@ -22,7 +22,7 @@
+ previous = None
+ while res_len < chars and i < frag_len - 1:
+ i += 1
+- current = fragment[i]
++ current = fragment[i].encode('utf-8')
+ if in_tag:
+ if in_attr:
+ if current == '"':