aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-07-09 22:01:54 +0800
committerdinoex <dinoex@FreeBSD.org>2004-07-09 22:01:54 +0800
commitee815c4ef05a575d5f4025ec77921a11d069b909 (patch)
treecf401a079e657402eab6a422c93bd6c499c81dd3 /net
parent87fa15dfbd23dad4bbad93d6f8a417742df3496b (diff)
downloadfreebsd-ports-gnome-ee815c4ef05a575d5f4025ec77921a11d069b909.tar.gz
freebsd-ports-gnome-ee815c4ef05a575d5f4025ec77921a11d069b909.tar.zst
freebsd-ports-gnome-ee815c4ef05a575d5f4025ec77921a11d069b909.zip
- Fix memory leak with unknown clients
Diffstat (limited to 'net')
-rw-r--r--net/radiusd-cistron/Makefile2
-rw-r--r--net/radiusd-cistron/files/patch-radiusd.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/net/radiusd-cistron/Makefile b/net/radiusd-cistron/Makefile
index 965a231a345c..a110e5e443eb 100644
--- a/net/radiusd-cistron/Makefile
+++ b/net/radiusd-cistron/Makefile
@@ -7,7 +7,7 @@
PORTNAME= radiusd-cistron
PORTVERSION= 1.6.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ftp://ftp.cistron.nl/pub/people/miquels/radius/
diff --git a/net/radiusd-cistron/files/patch-radiusd.c b/net/radiusd-cistron/files/patch-radiusd.c
new file mode 100644
index 000000000000..7bafe4d3c2b1
--- /dev/null
+++ b/net/radiusd-cistron/files/patch-radiusd.c
@@ -0,0 +1,10 @@
+--- src/radiusd.c.orig Wed Jul 2 11:39:03 2003
++++ src/radiusd.c Fri Jul 9 15:57:46 2004
+@@ -612,6 +612,7 @@
+ if ((cl = client_find(authreq->ipaddr)) == NULL) {
+ log(L_ERR, "packet from unknown client/host: %s",
+ client_name(authreq->ipaddr));
++ authfree(authreq);
+ return -1;
+ }
+ strNcpy(authreq->secret, cl->secret, sizeof(authreq->secret));