aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-11-24 06:58:02 +0800
committerswills <swills@FreeBSD.org>2012-11-24 06:58:02 +0800
commitf21cf8d62994c2a0368c0ac1becf3a3b994d50be (patch)
treeffa342f9aeb1cefb3a3bd8ef8325c1f6a8dbba8e /net
parent15a24175f0f4c30c82e957a8b510bf74ca38fcb9 (diff)
downloadfreebsd-ports-gnome-f21cf8d62994c2a0368c0ac1becf3a3b994d50be.tar.gz
freebsd-ports-gnome-f21cf8d62994c2a0368c0ac1becf3a3b994d50be.tar.zst
freebsd-ports-gnome-f21cf8d62994c2a0368c0ac1becf3a3b994d50be.zip
Rye: Safely run SSH commands on a bunch of machines at the same time.
WWW: https://github.com/delano/rye/ Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-rye/Makefile22
-rw-r--r--net/rubygem-rye/distinfo2
-rw-r--r--net/rubygem-rye/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 07dc41bda708..12d346f76eb8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1021,6 +1021,7 @@
SUBDIR += rubygem-righthttpconnection
SUBDIR += rubygem-rightslicehost
SUBDIR += rubygem-rubytter
+ SUBDIR += rubygem-rye
SUBDIR += rubygem-simple_oauth
SUBDIR += rubygem-stompserver
SUBDIR += rubygem-tweetstream
diff --git a/net/rubygem-rye/Makefile b/net/rubygem-rye/Makefile
new file mode 100644
index 000000000000..f15b12478508
--- /dev/null
+++ b/net/rubygem-rye/Makefile
@@ -0,0 +1,22 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rye
+PORTVERSION= 0.9.7
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Safely run SSH commands on a bunch of machines at the same time
+
+RUN_DEPENDS= rubygem-annoy>=0:${PORTSDIR}/devel/rubygem-annoy \
+ rubygem-highline>=1.5.1:${PORTSDIR}/devel/rubygem-highline \
+ rubygem-net-scp>=1.0.2:${PORTSDIR}/security/rubygem-net-scp \
+ rubygem-net-ssh>=2.0.13:${PORTSDIR}/security/rubygem-net-ssh \
+ rubygem-sysinfo>=0.7.3:${PORTSDIR}/devel/rubygem-sysinfo
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-rye/distinfo b/net/rubygem-rye/distinfo
new file mode 100644
index 000000000000..2e8d870704cd
--- /dev/null
+++ b/net/rubygem-rye/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rye-0.9.7.gem) = ea98c7dd91a892cea477d55d1d7fff8cf0c4426b96da9e57311a5478ffd0ed3b
+SIZE (rubygem/rye-0.9.7.gem) = 47616
diff --git a/net/rubygem-rye/pkg-descr b/net/rubygem-rye/pkg-descr
new file mode 100644
index 000000000000..4953f1484481
--- /dev/null
+++ b/net/rubygem-rye/pkg-descr
@@ -0,0 +1,3 @@
+Rye: Safely run SSH commands on a bunch of machines at the same time.
+
+WWW: https://github.com/delano/rye/