aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-21 05:06:08 +0800
committerbapt <bapt@FreeBSD.org>2012-07-21 05:06:08 +0800
commitf57943b89eb4ec368370cfebb406d6b00f6bbcbc (patch)
treeb62e6e0d26bb19503d3ca6ac31b3a2ce1008f6e9 /net
parentea713a0313a6c08484746314f9da94af84200f82 (diff)
downloadfreebsd-ports-gnome-f57943b89eb4ec368370cfebb406d6b00f6bbcbc.tar.gz
freebsd-ports-gnome-f57943b89eb4ec368370cfebb406d6b00f6bbcbc.tar.zst
freebsd-ports-gnome-f57943b89eb4ec368370cfebb406d6b00f6bbcbc.zip
Convert to OptionsNG
Diffstat (limited to 'net')
-rw-r--r--net/netselect/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/net/netselect/Makefile b/net/netselect/Makefile
index 06f4d068623b..0131b0728daa 100644
--- a/net/netselect/Makefile
+++ b/net/netselect/Makefile
@@ -19,11 +19,12 @@ PLIST_FILES= bin/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}
-OPTIONS= SUID "Install with the sticky bit (mode 4110)" off
+OPTIONS_DEFINE= SUID
+SUID_DESC= Install with the sticky bit (mode 4110)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SUID)
+.if ${PORT_OPTIONS:MSUID}
BINMODE= 4110
.else
BINMODE= 0100
@@ -35,4 +36,4 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>