aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-12-28 13:50:58 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-12-28 13:50:58 +0800
commitf7663c3da4cbf84191d98fbb4f75eb5572296ae0 (patch)
tree430487134e64e9e9c26a51fb2efc38863a12e6b8 /net
parent4cb123503c3c5f5ce0439a1c11eabf748666f4df (diff)
downloadfreebsd-ports-gnome-f7663c3da4cbf84191d98fbb4f75eb5572296ae0.tar.gz
freebsd-ports-gnome-f7663c3da4cbf84191d98fbb4f75eb5572296ae0.tar.zst
freebsd-ports-gnome-f7663c3da4cbf84191d98fbb4f75eb5572296ae0.zip
This module provides a simple, straight-forward interface to the
Google Analytics Data Export API, using LWP::UserAgent and XML::LibXML for the heavy lifting. WWW: http://search.cpan.org/dist/Net-Google-Analytics/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Google-Analytics/Makefile41
-rw-r--r--net/p5-Net-Google-Analytics/distinfo2
-rw-r--r--net/p5-Net-Google-Analytics/pkg-descr5
-rw-r--r--net/p5-Net-Google-Analytics/pkg-plist19
5 files changed, 68 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 922b9292c62a..5a03849a5338 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -563,6 +563,7 @@
SUBDIR += p5-Net-GitHub
SUBDIR += p5-Net-Gnats
SUBDIR += p5-Net-Google
+ SUBDIR += p5-Net-Google-Analytics
SUBDIR += p5-Net-Google-AuthSub
SUBDIR += p5-Net-Google-Calendar
SUBDIR += p5-Net-Google-Code
diff --git a/net/p5-Net-Google-Analytics/Makefile b/net/p5-Net-Google-Analytics/Makefile
new file mode 100644
index 000000000000..7ff7d92120aa
--- /dev/null
+++ b/net/p5-Net-Google-Analytics/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Net::Google::Analytics
+# Date created: 28 Dec 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Google-Analytics
+PORTVERSION= 0.11003
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for Google Analytics Data Export API
+
+RUN_DEPENDS= \
+ p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Google::Analytics.3 \
+ Net::Google::Analytics::AccountFeed.3 \
+ Net::Google::Analytics::AccountFeedEntry.3 \
+ Net::Google::Analytics::AccountFeedResponse.3 \
+ Net::Google::Analytics::DataFeed.3 \
+ Net::Google::Analytics::DataFeedEntry.3 \
+ Net::Google::Analytics::DataFeedRequest.3 \
+ Net::Google::Analytics::DataFeedResponse.3 \
+ Net::Google::Analytics::Dimension.3 \
+ Net::Google::Analytics::Feed.3 \
+ Net::Google::Analytics::FeedRequest.3 \
+ Net::Google::Analytics::FeedResponse.3 \
+ Net::Google::Analytics::Metric.3 \
+ Net::Google::Analytics::XML.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-Analytics/distinfo b/net/p5-Net-Google-Analytics/distinfo
new file mode 100644
index 000000000000..0ba5b025b837
--- /dev/null
+++ b/net/p5-Net-Google-Analytics/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Google-Analytics-0.11003.tar.gz) = bb0cc63765a001fd1833671715f93c68553b47d96730bd51836bc9216df7fa81
+SIZE (Net-Google-Analytics-0.11003.tar.gz) = 17469
diff --git a/net/p5-Net-Google-Analytics/pkg-descr b/net/p5-Net-Google-Analytics/pkg-descr
new file mode 100644
index 000000000000..6619adb1e741
--- /dev/null
+++ b/net/p5-Net-Google-Analytics/pkg-descr
@@ -0,0 +1,5 @@
+This module provides a simple, straight-forward interface to the
+Google Analytics Data Export API, using LWP::UserAgent and XML::LibXML
+for the heavy lifting.
+
+WWW: http://search.cpan.org/dist/Net-Google-Analytics/
diff --git a/net/p5-Net-Google-Analytics/pkg-plist b/net/p5-Net-Google-Analytics/pkg-plist
new file mode 100644
index 000000000000..3283657991c3
--- /dev/null
+++ b/net/p5-Net-Google-Analytics/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/Analytics/.packlist
+%%SITE_PERL%%/Net/Google/Analytics.pm
+%%SITE_PERL%%/Net/Google/Analytics/AccountFeed.pm
+%%SITE_PERL%%/Net/Google/Analytics/AccountFeedEntry.pm
+%%SITE_PERL%%/Net/Google/Analytics/AccountFeedResponse.pm
+%%SITE_PERL%%/Net/Google/Analytics/DataFeed.pm
+%%SITE_PERL%%/Net/Google/Analytics/DataFeedEntry.pm
+%%SITE_PERL%%/Net/Google/Analytics/DataFeedRequest.pm
+%%SITE_PERL%%/Net/Google/Analytics/DataFeedResponse.pm
+%%SITE_PERL%%/Net/Google/Analytics/Dimension.pm
+%%SITE_PERL%%/Net/Google/Analytics/Feed.pm
+%%SITE_PERL%%/Net/Google/Analytics/FeedRequest.pm
+%%SITE_PERL%%/Net/Google/Analytics/FeedResponse.pm
+%%SITE_PERL%%/Net/Google/Analytics/Metric.pm
+%%SITE_PERL%%/Net/Google/Analytics/XML.pm
+@dirrm %%SITE_PERL%%/Net/Google/Analytics
+@dirrm %%SITE_PERL%%/Net/Google
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/Analytics
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google