aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-08-18 08:32:31 +0800
committeredwin <edwin@FreeBSD.org>2008-08-18 08:32:31 +0800
commitf77b59aff5a4df8a1200378a3be8aeefc363a300 (patch)
tree81202bb2e4c80a40d48a1f4388ed2d66c8d3bfa6 /net
parent7d11ecde380591f135396ab05be612fa07f69bcc (diff)
downloadfreebsd-ports-gnome-f77b59aff5a4df8a1200378a3be8aeefc363a300.tar.gz
freebsd-ports-gnome-f77b59aff5a4df8a1200378a3be8aeefc363a300.tar.zst
freebsd-ports-gnome-f77b59aff5a4df8a1200378a3be8aeefc363a300.zip
Port fix: net/ldapscripts - Set ICONVBIN path
This small patch sets the right path for the iconv binary used in the scripts. PR: ports/126587 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com>
Diffstat (limited to 'net')
-rw-r--r--net/ldapscripts/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/net/ldapscripts/Makefile b/net/ldapscripts/Makefile
index c96a8fb19c20..2a20c772bb27 100644
--- a/net/ldapscripts/Makefile
+++ b/net/ldapscripts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ldapscripts
PORTVERSION= 1.8.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://contribs.martymac.com/ldapscripts/
@@ -49,12 +50,15 @@ PORTDOCS= README CHANGELOG COPYING VERSION TODO
# and set paths to OpenLDAP binaries
post-patch:
${REINPLACE_CMD} "s|^all:.*|all:|g" ${WRKSRC}/Makefile
- ${REINPLACE_CMD} "s|^LDAPSEARCHBIN=.*|LDAPSEARCHBIN=\"${LOCALBASE}/bin/ldapsearch\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPADDBIN=.*|LDAPADDBIN=\"${LOCALBASE}/bin/ldapadd\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPDELETEBIN=.*|LDAPDELETEBIN=\"${LOCALBASE}/bin/ldapdelete\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPMODIFYBIN=.*|LDAPMODIFYBIN=\"${LOCALBASE}/bin/ldapmodify\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPMODRDNBIN=.*|LDAPMODRDNBIN=\"${LOCALBASE}/bin/ldapmodrdn\"|g" ${WRKSRC}/etc/ldapscripts.conf
- ${REINPLACE_CMD} "s|^LDAPPASSWDBIN=.*|LDAPPASSWDBIN=\"${LOCALBASE}/bin/ldappasswd\"|g" ${WRKSRC}/etc/ldapscripts.conf
+ ${REINPLACE_CMD} \
+ -e "s|^LDAPSEARCHBIN=.*|LDAPSEARCHBIN=\"${LOCALBASE}/bin/ldapsearch\"|g" \
+ -e "s|^LDAPADDBIN=.*|LDAPADDBIN=\"${LOCALBASE}/bin/ldapadd\"|g" \
+ -e "s|^LDAPDELETEBIN=.*|LDAPDELETEBIN=\"${LOCALBASE}/bin/ldapdelete\"|g" \
+ -e "s|^LDAPMODIFYBIN=.*|LDAPMODIFYBIN=\"${LOCALBASE}/bin/ldapmodify\"|g" \
+ -e "s|^LDAPMODRDNBIN=.*|LDAPMODRDNBIN=\"${LOCALBASE}/bin/ldapmodrdn\"|g" \
+ -e "s|^LDAPPASSWDBIN=.*|LDAPPASSWDBIN=\"${LOCALBASE}/bin/ldappasswd\"|g" \
+ -e "s|^ICONVBIN=.*|ICONVBIN=\"${LOCALBASE}/bin/iconv\"|g" \
+ ${WRKSRC}/etc/ldapscripts.conf
# Install remaining stuff
post-install: