aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-03-22 14:53:46 +0800
committerkoobs <koobs@FreeBSD.org>2014-03-22 14:53:46 +0800
commitfbcb718f5ad64eb3911c6ce034ba5d170eb73420 (patch)
tree7998c0a8bf35361fe64ade5a5517ce94ba459041 /net
parent10fbbfb4a7f42c139b6396ac098a572c921c1761 (diff)
downloadfreebsd-ports-gnome-fbcb718f5ad64eb3911c6ce034ba5d170eb73420.tar.gz
freebsd-ports-gnome-fbcb718f5ad64eb3911c6ce034ba5d170eb73420.tar.zst
freebsd-ports-gnome-fbcb718f5ad64eb3911c6ce034ba5d170eb73420.zip
devel/py-pyzmq: Move to net/ category, Update to 14.1.1
- Move from devel/ to net/ category with other ZeroMQ ports - Update to 14.1.1 - Update CATEGORIES order (put primary first) - Update MOVED, devel/Makefile and net/Makefile Approved by: maintainer (via email)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-pyzmq/Makefile31
-rw-r--r--net/py-pyzmq/distinfo2
-rw-r--r--net/py-pyzmq/pkg-descr4
4 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b74d19887830..77a09e71cc3a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -932,6 +932,7 @@
SUBDIR += py-pypcap
SUBDIR += py-pysendfile
SUBDIR += py-pysphere
+ SUBDIR += py-pyzmq
SUBDIR += py-qt4-network
SUBDIR += py-radix
SUBDIR += py-s3cmd
diff --git a/net/py-pyzmq/Makefile b/net/py-pyzmq/Makefile
new file mode 100644
index 000000000000..369fcace57ca
--- /dev/null
+++ b/net/py-pyzmq/Makefile
@@ -0,0 +1,31 @@
+# Created by: Roman Bogorodskiy <novel@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyzmq
+PORTVERSION= 14.1.1
+CATEGORIES= net devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Python bindings for ZeroMQ
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= libzmq.so:${PORTSDIR}/net/libzmq4
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ @${SED} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/setup.cfg.template > \
+ ${WRKSRC}/setup.cfg
+
+regression-test: extract
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} build_ext --inplace
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+.include <bsd.port.post.mk>
diff --git a/net/py-pyzmq/distinfo b/net/py-pyzmq/distinfo
new file mode 100644
index 000000000000..ae1a94758eff
--- /dev/null
+++ b/net/py-pyzmq/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyzmq-14.1.1.tar.gz) = 54de7564537997b9ef9375b4fc309d464f0b70865fed34063048666f2159dcdd
+SIZE (pyzmq-14.1.1.tar.gz) = 1020895
diff --git a/net/py-pyzmq/pkg-descr b/net/py-pyzmq/pkg-descr
new file mode 100644
index 000000000000..752323c4d658
--- /dev/null
+++ b/net/py-pyzmq/pkg-descr
@@ -0,0 +1,4 @@
+PyZMQ is a lightweight and super-fast messaging library built on top of
+the ZeroMQ library.
+
+WWW: https://github.com/zeromq/pyzmq