aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-31 03:56:43 +0800
committerkrion <krion@FreeBSD.org>2004-03-31 03:56:43 +0800
commit14042a07c94213103476ba10caba0e05d7386a88 (patch)
tree85ab7d332a60216705aba7ae5ea7bd5afd901b21 /net
parent17635d4d1428af00fc5c2d051fe401dc9e54a671 (diff)
downloadfreebsd-ports-gnome-14042a07c94213103476ba10caba0e05d7386a88.tar.gz
freebsd-ports-gnome-14042a07c94213103476ba10caba0e05d7386a88.tar.zst
freebsd-ports-gnome-14042a07c94213103476ba10caba0e05d7386a88.zip
- Use USE_ICONV knob
Approved by: portmgr
Diffstat (limited to 'net')
-rw-r--r--net/centericq/Makefile3
-rw-r--r--net/ickle/Makefile2
-rw-r--r--net/jabber-yahoo/Makefile2
-rw-r--r--net/jabberd/Makefile3
-rw-r--r--net/micq/Makefile2
-rw-r--r--net/nc6/Makefile3
-rw-r--r--net/netdude/Makefile4
-rw-r--r--net/ruby-net-geoip/Makefile4
-rw-r--r--net/ssltunnel-client/Makefile2
-rw-r--r--net/ulxmlrpcpp/Makefile4
-rw-r--r--net/whois/Makefile3
-rw-r--r--net/wol/Makefile3
-rw-r--r--net/yaz/Makefile4
-rw-r--r--net/ysm/Makefile3
14 files changed, 18 insertions, 24 deletions
diff --git a/net/centericq/Makefile b/net/centericq/Makefile
index fdb6aab501ce..02d908adb5fb 100644
--- a/net/centericq/Makefile
+++ b/net/centericq/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= http://centericq.de/archive/source/releases/
MAINTAINER= clsung@dragon2.net
COMMENT= A text mode menu- and window-driven IM interface
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
+USE_ICONV= yes
USE_OPENSSL= yes
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/net/ickle/Makefile b/net/ickle/Makefile
index 61c210296b6b..8f171b87113c 100644
--- a/net/ickle/Makefile
+++ b/net/ickle/Makefile
@@ -17,12 +17,12 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= ICQ2000 protocol implementation
LIB_DEPENDS= gtkmm:${PORTSDIR}/x11-toolkits/gtk-- \
- iconv.3:${PORTSDIR}/converters/libiconv \
icq2000.5:${PORTSDIR}/net/libicq2000
USE_X_PREFIX= yes
USE_GNOME= gtk12
WANT_GNOME= yes
+USE_ICONV= yes
USE_REINPLACE= yes
USE_SIZE= yes
GNU_CONFIGURE= yes
diff --git a/net/jabber-yahoo/Makefile b/net/jabber-yahoo/Makefile
index ff1c8969efb0..7a62ef69275d 100644
--- a/net/jabber-yahoo/Makefile
+++ b/net/jabber-yahoo/Makefile
@@ -17,10 +17,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Jabber Yahoo Transport module
BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net/jabber
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_GNOME= glib12
USE_GMAKE= yes
+USE_ICONV= yes
WRKSRC= ${WRKDIR}/yahoo-transport-${PORTVERSION}
diff --git a/net/jabberd/Makefile b/net/jabberd/Makefile
index e51b4ecf178e..7be6594a25f6 100644
--- a/net/jabberd/Makefile
+++ b/net/jabberd/Makefile
@@ -15,10 +15,9 @@ DIST_SUBDIR= jabber
MAINTAINER= demon@FreeBSD.org
COMMENT= Online presence and instant messaging server
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+USE_ICONV= yes
CONFIGURE_ARGS= --localstatedir=/var \
--with-libiconv-prefix=${LOCALBASE} \
--with-openssl=${OPENSSLBASE} \
diff --git a/net/micq/Makefile b/net/micq/Makefile
index 4ba3055e591b..80382c0ec62f 100644
--- a/net/micq/Makefile
+++ b/net/micq/Makefile
@@ -30,7 +30,7 @@ MAN7= micq.7
.if defined(WITHOUT_LIBICONV)
CONFIGURE_ARGS+= --disable-iconv
.else
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+USE_ICONV= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib -liconv
.endif
diff --git a/net/nc6/Makefile b/net/nc6/Makefile
index d7faf9537711..0bf1a9b2185b 100644
--- a/net/nc6/Makefile
+++ b/net/nc6/Makefile
@@ -15,10 +15,9 @@ MASTER_SITES= ftp://ftp.deepspace6.net/pub/ds6/sources/nc6/ \
MAINTAINER= filippo@widestore.net
COMMENT= Netcat clone with IPv6 support
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
MAN1= nc6.1
USE_GETTEXT= yes
+USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index 7fe1f2cc5a7e..69906ae9d0b1 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -16,10 +16,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= NETwork DUmp data Displayer and Editor for tcpdump tracefiles
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- ltdl.4:${PORTSDIR}/devel/libltdl
+LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl
USE_GETTEXT= yes
+USE_ICONV= yes
USE_REINPLACE= yes
USE_GNOME= glib12 gtk12
USE_LIBTOOL_VER=13
diff --git a/net/ruby-net-geoip/Makefile b/net/ruby-net-geoip/Makefile
index d452fa2a3af0..24017959c9af 100644
--- a/net/ruby-net-geoip/Makefile
+++ b/net/ruby-net-geoip/Makefile
@@ -16,10 +16,10 @@ DIST_SUBDIR= ruby
MAINTAINER= seanc@FreeBSD.org
COMMENT= A Ruby extension that wraps around libGeoIP
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- GeoIP.3:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= GeoIP.3:${PORTSDIR}/net/GeoIP
USE_BZIP2= yes
+USE_ICONV= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
index b14634d68dd6..e89bff45e30b 100644
--- a/net/ssltunnel-client/Makefile
+++ b/net/ssltunnel-client/Makefile
@@ -18,7 +18,7 @@ PKGNAMESUFFIX= -client
MAINTAINER= at@rominet.net
COMMENT= PPP over SSL virtual private networking (client part)
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+USE_ICONV= yes
MAN1= pppclient.1
MAN5= ssltunnelrc.5
diff --git a/net/ulxmlrpcpp/Makefile b/net/ulxmlrpcpp/Makefile
index 8c864582da7e..5f41bb6ae7e7 100644
--- a/net/ulxmlrpcpp/Makefile
+++ b/net/ulxmlrpcpp/Makefile
@@ -17,10 +17,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A ultra lightweight xml-rpc library written in C++
-LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
- iconv.3:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
USE_BZIP2= yes
+USE_ICONV= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
diff --git a/net/whois/Makefile b/net/whois/Makefile
index e773f13fec29..a468b9740493 100644
--- a/net/whois/Makefile
+++ b/net/whois/Makefile
@@ -14,11 +14,10 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= filippo@widestore.net
COMMENT= Marco d'Itri whois client
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
MAN1= whois.1
USE_GETTEXT= yes
+USE_ICONV= yes
USE_PERL5_BUILD= yes
USE_REINPLACE= yes
USE_GMAKE= yes
diff --git a/net/wol/Makefile b/net/wol/Makefile
index fe19153db497..7c30845bc4de 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -16,11 +16,10 @@ MASTER_SITE_SUBDIR= ahh
MAINTAINER= sergei@FreeBSD.org
COMMENT= Tool to wake up Wake-On-LAN compliant computers
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
GNU_CONFIGURE= yes
USE_GETOPT_LONG= yes
USE_GETTEXT= yes
+USE_ICONV= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/net/yaz/Makefile b/net/yaz/Makefile
index dc4b658fa921..8c29c773e9c2 100644
--- a/net/yaz/Makefile
+++ b/net/yaz/Makefile
@@ -10,12 +10,12 @@ PORTVERSION= 2.0.18
CATEGORIES= net
MASTER_SITES= http://ftp.indexdata.dk/pub/yaz/
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- xml2.5:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
MAINTAINER= demon@FreeBSD.org
COMMENT= Z39.50/SR client and API library
+USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-shared
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/net/ysm/Makefile b/net/ysm/Makefile
index 12af74e43e2d..fa40c8eb5096 100644
--- a/net/ysm/Makefile
+++ b/net/ysm/Makefile
@@ -16,8 +16,7 @@ DISTNAME= ${PORTNAME}v${PORTVERSION:S/./_/g}
MAINTAINER= aquatique@rusunix.org
COMMENT= Command line ICQ client with ICQ2000 and recoding support
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
+USE_ICONV= yes
USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes