aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-02-18 06:24:49 +0800
committeryuri <yuri@FreeBSD.org>2018-02-18 06:24:49 +0800
commit80239bbb21d49432ea76182b569afe68869fd6c0 (patch)
treeccee310f3be0dfc2cc1ef53c288fd49542373906 /net
parent8b161050a41302bd2db05f87c3b7785bbce8ff0f (diff)
downloadfreebsd-ports-gnome-80239bbb21d49432ea76182b569afe68869fd6c0.tar.gz
freebsd-ports-gnome-80239bbb21d49432ea76182b569afe68869fd6c0.tar.zst
freebsd-ports-gnome-80239bbb21d49432ea76182b569afe68869fd6c0.zip
New port: net/eternaltcp: Remote shell that reconnects without interrupting session
PR: 225837 Submitted by: Trevis <fbsd@silencedpoet.com> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D14414
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/eternaltcp/Makefile26
-rw-r--r--net/eternaltcp/distinfo3
-rw-r--r--net/eternaltcp/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 1da09602ae31..2f116c2803c7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -134,6 +134,7 @@
SUBDIR += enet
SUBDIR += erlang-ranch
SUBDIR += erlang-xmlrpc
+ SUBDIR += eternaltcp
SUBDIR += etrace
SUBDIR += exabgp
SUBDIR += exaddos
diff --git a/net/eternaltcp/Makefile b/net/eternaltcp/Makefile
new file mode 100644
index 000000000000..df16c9add7c0
--- /dev/null
+++ b/net/eternaltcp/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= eternaltcp
+DISTVERSIONPREFIX= et-v
+DISTVERSION= 4.2.0
+CATEGORIES= net
+
+MAINTAINER= trevis@silencedpoet.com
+COMMENT= Remote shell that reconnects without interrupting session
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgflags.so:devel/gflags \
+ libglog.so:devel/glog \
+ libprotobuf.so:devel/protobuf \
+ libsodium.so:security/libsodium
+
+USES= cmake:outsource ncurses
+USE_GITHUB= yes
+GH_ACCOUNT= MisterTea
+GH_PROJECT= EternalTCP
+
+PLIST_FILES= bin/et bin/etserver
+
+.include <bsd.port.mk>
diff --git a/net/eternaltcp/distinfo b/net/eternaltcp/distinfo
new file mode 100644
index 000000000000..91d0c8924e38
--- /dev/null
+++ b/net/eternaltcp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518904913
+SHA256 (MisterTea-EternalTCP-et-v4.2.0_GH0.tar.gz) = 42372f64bacaecffcdfe3676e631a32481043e0ff0412aaf7548bf27839b5c82
+SIZE (MisterTea-EternalTCP-et-v4.2.0_GH0.tar.gz) = 84231
diff --git a/net/eternaltcp/pkg-descr b/net/eternaltcp/pkg-descr
new file mode 100644
index 000000000000..b8a6a60c0d9f
--- /dev/null
+++ b/net/eternaltcp/pkg-descr
@@ -0,0 +1,5 @@
+Eternal Terminal is a remote shell that automatically reconnects without
+interrupting the session. Uses ssh under-the-hood for handshake and
+encryption. Connection is via TCP unlike UDP based remote shells such as mosh.
+
+WWW: https://mistertea.github.io/EternalTCP/