aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-12-27 00:53:32 +0800
committertijl <tijl@FreeBSD.org>2017-12-27 00:53:32 +0800
commit033650c9d563de91729126b24a49aef4067f23ba (patch)
tree306c449b78947496b43a51a5bad57b9daabdc359 /net
parentbd4d8eb2430019e9b8e1e8d6342cbd600247ecfa (diff)
downloadfreebsd-ports-gnome-033650c9d563de91729126b24a49aef4067f23ba.tar.gz
freebsd-ports-gnome-033650c9d563de91729126b24a49aef4067f23ba.tar.zst
freebsd-ports-gnome-033650c9d563de91729126b24a49aef4067f23ba.zip
- Remove an old patch that adds HAVE_SYS_PARAM_H to config.h.in. It's
already there in the current version of the port. - Replace a patch for configure.in with a post-patch command for configure so we can remove USE_AUTOTOOLS. - Unhide pre-install command.
Diffstat (limited to 'net')
-rw-r--r--net/proxy-suite/Makefile11
-rw-r--r--net/proxy-suite/files/patch-config.h.in12
-rw-r--r--net/proxy-suite/files/patch-configure.in11
3 files changed, 6 insertions, 28 deletions
diff --git a/net/proxy-suite/Makefile b/net/proxy-suite/Makefile
index 55d120cca1dc..aa80a1a042d0 100644
--- a/net/proxy-suite/Makefile
+++ b/net/proxy-suite/Makefile
@@ -11,14 +11,14 @@ MAINTAINER= thomas@FreeBSD.org
COMMENT= The SuSE Proxy-Suite, a set of programs to enhance firewall security
LICENSE= GPLv2
-USE_AUTOTOOLS= autoconf
+GNU_CONFIGURE= yes
USES= gmake tar:bzip2
#
# basic configure args
#
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-libwrap=/usr/lib --with-regex \
+CONFIGURE_ARGS= --with-libwrap=/usr/lib --with-regex \
--localstatedir=/var/run \
--enable-warnings --enable-so-linger \
--disable-proc-mods
@@ -53,9 +53,10 @@ MAKE_ARGS= INST_ROOT=${STAGEDIR} CONF_DST=ftp-proxy.conf.sample
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} 's,net/pfvar.h,,' ${WRKSRC}/configure
pre-install:
- @${STRIP_CMD} ${WRKSRC}/ftp-proxy/ftp-proxy
+ ${STRIP_CMD} ${WRKSRC}/ftp-proxy/ftp-proxy
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/proxy-suite/files/patch-config.h.in b/net/proxy-suite/files/patch-config.h.in
deleted file mode 100644
index 71d1ad2a7616..000000000000
--- a/net/proxy-suite/files/patch-config.h.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- config.h.in.dist Mon Dec 20 17:44:59 2004
-+++ config.h.in Mon Dec 20 17:44:36 2004
-@@ -157,6 +157,9 @@
- /* Define to 1 if you have the <syslog.h> header file. */
- #undef HAVE_SYSLOG_H
-
-+/* Define to 1 if you have the <sys/param.h> header file. */
-+#undef HAVE_SYS_PARAM_H
-+
- /* Define to 1 if you have the <sys/conf.h> header file. */
- #undef HAVE_SYS_CONF_H
-
diff --git a/net/proxy-suite/files/patch-configure.in b/net/proxy-suite/files/patch-configure.in
deleted file mode 100644
index 0d749e5680b0..000000000000
--- a/net/proxy-suite/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in Tue Mar 30 12:31:31 2004
-+++ configure.in Mon Dec 20 17:35:02 2004
-@@ -204,7 +204,7 @@
- AC_CHECK_HEADERS(sys/filio.h sys/param.h sys/conf.h paths.h stropts.h)
- AC_CHECK_HEADERS(sys/sockio.h)
-
--AC_CHECK_HEADERS(net/if.h net/pfvar.h netinet/in_systm.h)
-+AC_CHECK_HEADERS(net/if.h netinet/in_systm.h)
- AC_CHECK_HEADERS(netinet/ip.h netinet/ip_fil.h netinet/ip_nat.h)
- AC_CHECK_HEADERS(netinet/ip_compat.h netinet/ip_fil_compat.h)
-