aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-11-24 06:56:07 +0800
committerswills <swills@FreeBSD.org>2012-11-24 06:56:07 +0800
commit04c18cef869c25306136c1a10bda8e164133142a (patch)
tree06ae4459c70ed941480957173195fca9191c980e /net
parent10959ee8c961119c6047498ad2c33ab6981180e4 (diff)
downloadfreebsd-ports-gnome-04c18cef869c25306136c1a10bda8e164133142a.tar.gz
freebsd-ports-gnome-04c18cef869c25306136c1a10bda8e164133142a.tar.zst
freebsd-ports-gnome-04c18cef869c25306136c1a10bda8e164133142a.zip
A Ruby library for accessing the Amazon Web Services EC2, ELB, RDS, Cloudwatch,
and Autoscaling APIs. WWW: http://github.com/grempe/amazon-ec2 Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-amazon-ec2/Makefile19
-rw-r--r--net/rubygem-amazon-ec2/distinfo2
-rw-r--r--net/rubygem-amazon-ec2/pkg-descr4
4 files changed, 26 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 72c0d1bf2f7e..1aa10321b49e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -995,6 +995,7 @@
SUBDIR += ruby-net-geoip
SUBDIR += ruby-tcpsocketpipe
SUBDIR += ruby-tserver
+ SUBDIR += rubygem-amazon-ec2
SUBDIR += rubygem-amq-client
SUBDIR += rubygem-amq-protocol
SUBDIR += rubygem-amqp
diff --git a/net/rubygem-amazon-ec2/Makefile b/net/rubygem-amazon-ec2/Makefile
new file mode 100644
index 000000000000..8e8640561107
--- /dev/null
+++ b/net/rubygem-amazon-ec2/Makefile
@@ -0,0 +1,19 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= amazon-ec2
+PORTVERSION= 0.9.17
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Library for accessing the Amazon Web Services APIs
+
+RUN_DEPENDS= rubygem-xml-simple>=1.0.12:${PORTSDIR}/textproc/rubygem-xml-simple
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/awshell bin/ec2-gem-example.rb bin/ec2-gem-profile.rb bin/ec2sh bin/setup.rb
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-amazon-ec2/distinfo b/net/rubygem-amazon-ec2/distinfo
new file mode 100644
index 000000000000..466d5fecf700
--- /dev/null
+++ b/net/rubygem-amazon-ec2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amazon-ec2-0.9.17.gem) = 4cbbd8cada5534cc6d081281b26bbb777c53410ea571829d0b7d0826b7d1e971
+SIZE (rubygem/amazon-ec2-0.9.17.gem) = 124416
diff --git a/net/rubygem-amazon-ec2/pkg-descr b/net/rubygem-amazon-ec2/pkg-descr
new file mode 100644
index 000000000000..f1997568c42e
--- /dev/null
+++ b/net/rubygem-amazon-ec2/pkg-descr
@@ -0,0 +1,4 @@
+A Ruby library for accessing the Amazon Web Services EC2, ELB, RDS, Cloudwatch,
+and Autoscaling APIs.
+
+WWW: http://github.com/grempe/amazon-ec2