aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2017-08-18 16:05:46 +0800
committerdemon <demon@FreeBSD.org>2017-08-18 16:05:46 +0800
commit05a1f8bb78bdb43651f03251180c2f3bffd4441e (patch)
tree3272387f687c63d1112e38af1bf01191a8819241 /net
parent66e83771e4b7721ceec31e0d7a877f3b40ad54ba (diff)
downloadfreebsd-ports-gnome-05a1f8bb78bdb43651f03251180c2f3bffd4441e.tar.gz
freebsd-ports-gnome-05a1f8bb78bdb43651f03251180c2f3bffd4441e.tar.zst
freebsd-ports-gnome-05a1f8bb78bdb43651f03251180c2f3bffd4441e.zip
Update to version 1.7.9.
Diffstat (limited to 'net')
-rw-r--r--net/haproxy/Makefile3
-rw-r--r--net/haproxy/distinfo6
-rw-r--r--net/haproxy/files/patch-fix-cpuaffinity26
3 files changed, 30 insertions, 5 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 33de80ec2056..5c7c952b9fd6 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= haproxy
-PORTVERSION= 1.7.8
-PORTREVISION= 1
+PORTVERSION= 1.7.9
CATEGORIES= net www
MASTER_SITES= http://www.haproxy.org/download/1.7/src/
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
diff --git a/net/haproxy/distinfo b/net/haproxy/distinfo
index cea87b9722e0..eabdb323833e 100644
--- a/net/haproxy/distinfo
+++ b/net/haproxy/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1499429680
-SHA256 (haproxy-1.7.8.tar.gz) = ec90153ccedd20ad4015d3eaf76b502ff1f61b431d54c22b8457b5784a9ae142
-SIZE (haproxy-1.7.8.tar.gz) = 1746321
+TIMESTAMP = 1503043277
+SHA256 (haproxy-1.7.9.tar.gz) = 1072337e54fa188dc6e0cfe3ba4c2200b07082e321cbfe5a0882d85d54db068e
+SIZE (haproxy-1.7.9.tar.gz) = 1748159
SHA256 (deviceatlas-enterprise-c-2.1.2_1.tgz) = 984e1ae3147459a4ed0a8d5053d83dd05ce8c5127cd3cb055be35a74e9217372
SIZE (deviceatlas-enterprise-c-2.1.2_1.tgz) = 184432
diff --git a/net/haproxy/files/patch-fix-cpuaffinity b/net/haproxy/files/patch-fix-cpuaffinity
new file mode 100644
index 000000000000..ba992d5f9465
--- /dev/null
+++ b/net/haproxy/files/patch-fix-cpuaffinity
@@ -0,0 +1,26 @@
+X-Git-Url: http://git.haproxy.org/?p=haproxy.git;a=blobdiff_plain;f=src%2Fhaproxy.c;h=30e850c4ac4719b71adccb3b6bd41248ef5bb470;hp=7af4ab479c761a43b2fa64d2124388dbf5c21fc3;hb=97148f60b8feec39b76768d1bcfab6d755c12164;hpb=0d00593361b91017b894c4c7d5e24721a7838d6e
+
+diff --git a/src/haproxy.c b/src/haproxy.c
+index 7af4ab4..30e850c 100644
+--- src/haproxy.c
++++ src/haproxy.c
+@@ -2018,7 +2018,18 @@ int main(int argc, char **argv)
+ proc < LONGBITS && /* only the first 32/64 processes may be pinned */
+ global.cpu_map[proc]) /* only do this if the process has a CPU map */
+ #ifdef __FreeBSD__
+- cpuset_setaffinity(CPU_LEVEL_WHICH, CPU_WHICH_PID, -1, sizeof(unsigned long), (void *)&global.cpu_map[proc]);
++ {
++ cpuset_t cpuset;
++ int i;
++ unsigned long cpu_map = global.cpu_map[proc];
++
++ CPU_ZERO(&cpuset);
++ while ((i = ffsl(cpu_map)) > 0) {
++ CPU_SET(i - 1, &cpuset);
++ cpu_map &= ~(1 << (i - 1));
++ }
++ ret = cpuset_setaffinity(CPU_LEVEL_WHICH, CPU_WHICH_PID, -1, sizeof(cpuset), &cpuset);
++ }
+ #else
+ sched_setaffinity(0, sizeof(unsigned long), (void *)&global.cpu_map[proc]);
+ #endif