aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrobak <robak@FreeBSD.org>2015-06-23 00:58:05 +0800
committerrobak <robak@FreeBSD.org>2015-06-23 00:58:05 +0800
commit0c6151653653745be8b29a50b1eea2d3c4d6798b (patch)
tree0aa8165905e0056b1e85aeb0d133950eea5ccd93 /net
parentd4bf9ad6668711cb8d379a60a5e46891bf94282a (diff)
downloadfreebsd-ports-gnome-0c6151653653745be8b29a50b1eea2d3c4d6798b.tar.gz
freebsd-ports-gnome-0c6151653653745be8b29a50b1eea2d3c4d6798b.tar.zst
freebsd-ports-gnome-0c6151653653745be8b29a50b1eea2d3c4d6798b.zip
net/py-terminado: NEW PORT - Terminals served to term.js using Tornado websockets
This is a Tornado websocket backend for the term.js terminal emulator library. It evolved out of pyxterm, which was part of GraphTerm (as lineterm.py), v0.57.0 (2014-07-18), and ultimately derived from the public-domain Ajaxterm code, v0.11 (2008-11-13) (also on Github as part of QWeb). WWW: https://github.com/takluyver/terminado Submitted by: robak@FreeBSD.org
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-terminado/Makefile20
-rw-r--r--net/py-terminado/distinfo2
-rw-r--r--net/py-terminado/pkg-descr7
4 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ede96366844a..eb27ec6e9fbc 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -958,6 +958,7 @@
SUBDIR += py-soapy
SUBDIR += py-speedtest-cli
SUBDIR += py-suds
+ SUBDIR += py-terminado
SUBDIR += py-tofu
SUBDIR += py-tweepy
SUBDIR += py-twistedPair
diff --git a/net/py-terminado/Makefile b/net/py-terminado/Makefile
new file mode 100644
index 000000000000..854bef254f58
--- /dev/null
+++ b/net/py-terminado/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= terminado
+PORTVERSION= 0.5
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= robak@FreeBSD.org
+COMMENT= Terminals served to term.js using Tornado websockets
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ptyprocess>0:${PORTSDIR}/sysutils/py-ptyprocess \
+ ${PYTHON_PKGNAMEPREFIX}tornado>0:${PORTSDIR}/www/py-tornado
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/net/py-terminado/distinfo b/net/py-terminado/distinfo
new file mode 100644
index 000000000000..5b3ce7c59b1f
--- /dev/null
+++ b/net/py-terminado/distinfo
@@ -0,0 +1,2 @@
+SHA256 (terminado-0.5.tar.gz) = 63e893eff1ba84f1ee7c4bfcca7676ba1de6394538bb9aa80cbbc8866cb875b6
+SIZE (terminado-0.5.tar.gz) = 10491
diff --git a/net/py-terminado/pkg-descr b/net/py-terminado/pkg-descr
new file mode 100644
index 000000000000..4e1791a133f3
--- /dev/null
+++ b/net/py-terminado/pkg-descr
@@ -0,0 +1,7 @@
+This is a Tornado websocket backend for the term.js terminal emulator library.
+
+It evolved out of pyxterm, which was part of GraphTerm (as lineterm.py),
+v0.57.0 (2014-07-18), and ultimately derived from the public-domain Ajaxterm
+code, v0.11 (2008-11-13) (also on Github as part of QWeb).
+
+WWW: https://github.com/takluyver/terminado