aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 10:35:01 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 10:35:01 +0800
commit1b7bb332fa18b58d935d7c527a75470c92de2626 (patch)
tree2f4141a4af38a668cf36cef3a620918d857e0a08 /net
parentae62427d6d6725d1b89cb124a2b9df1780c3a6c0 (diff)
downloadfreebsd-ports-gnome-1b7bb332fa18b58d935d7c527a75470c92de2626.tar.gz
freebsd-ports-gnome-1b7bb332fa18b58d935d7c527a75470c92de2626.tar.zst
freebsd-ports-gnome-1b7bb332fa18b58d935d7c527a75470c92de2626.zip
PERL -> REINPLACE
Noticed on: bento
Diffstat (limited to 'net')
-rw-r--r--net/dnrd/Makefile3
-rw-r--r--net/easysoap/Makefile4
2 files changed, 5 insertions, 2 deletions
diff --git a/net/dnrd/Makefile b/net/dnrd/Makefile
index d607c6ab4fca..e6da2990897d 100644
--- a/net/dnrd/Makefile
+++ b/net/dnrd/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= greid@FreeBSD.org
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_GMAKE= yes
+USE_REINPLACE= yes
MAN8= dnrd.8
@@ -23,6 +24,6 @@ post-patch:
@(cd ${WRKSRC} && ${SED} -e 's,%%PREFIX%%,${PREFIX},g' $F > foo && \
${MV} foo $F)
.endfor
- ${PERL} -pi -e "s@cc@${CC}@g; s@-lc_r@${PTHREAD_LIBS}@g" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s@cc@${CC}@g; s@-lc_r@${PTHREAD_LIBS}@g" ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/net/easysoap/Makefile b/net/easysoap/Makefile
index dd5355399301..2ca1fbcd8c2e 100644
--- a/net/easysoap/Makefile
+++ b/net/easysoap/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= gabriel_ambuehl@buz.ch
LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
USE_OPENSSL= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lexpat"
@@ -30,6 +31,7 @@ BROKEN= "Does not compile on 5.0"
.endif
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/src/abyss/src/data.c
+
.include <bsd.port.post.mk>