aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2003-02-23 00:56:35 +0800
committerleeym <leeym@FreeBSD.org>2003-02-23 00:56:35 +0800
commit1c043a0448577dcd24405ffe777286bdecd8e5d5 (patch)
tree95641b4e5d3933e61c9afde976b1ab09d3321b9e /net
parent9ca9a5e2e7bae20b866f152d06cb95873d319b3d (diff)
downloadfreebsd-ports-gnome-1c043a0448577dcd24405ffe777286bdecd8e5d5.tar.gz
freebsd-ports-gnome-1c043a0448577dcd24405ffe777286bdecd8e5d5.tar.zst
freebsd-ports-gnome-1c043a0448577dcd24405ffe777286bdecd8e5d5.zip
add bmon, an interface bandwidth monitor
PR: 48553 Submitted by: Jon Nistor <nistor@snickers.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/bmon/Makefile25
-rw-r--r--net/bmon/distinfo1
-rw-r--r--net/bmon/pkg-descr8
-rw-r--r--net/bmon/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 289528273a8d..a198d7765122 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -39,6 +39,7 @@
SUBDIR += bind9-dlz
SUBDIR += bing
SUBDIR += binkd
+ SUBDIR += bmon
SUBDIR += boclient
SUBDIR += bounce
SUBDIR += bpft
diff --git a/net/bmon/Makefile b/net/bmon/Makefile
new file mode 100644
index 000000000000..35b464666f02
--- /dev/null
+++ b/net/bmon/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: bmon
+# Date created: 21 Feb 2003
+# Whom: Jon Nistor <nistor@snickers.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bmon
+PORTVERSION= 1.2.0
+CATEGORIES= net
+MASTER_SITES= http://trash.net/~reeler/bmon/files/
+
+MAINTAINER= nistor@snickers.org
+COMMENT= "BWMON - bandwidth monitor using curses lib"
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+MAN1= bmon.1
+
+do-install:
+ ${INSTALL} ${STRIP} ${COPY} ${_BINOWNGRP} -m 4755 ${WRKSRC}/bmon ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/bmon.1 ${PREFIX}/man/man1/bmon.1
+
+.include <bsd.port.mk>
diff --git a/net/bmon/distinfo b/net/bmon/distinfo
new file mode 100644
index 000000000000..7e954d2e9e33
--- /dev/null
+++ b/net/bmon/distinfo
@@ -0,0 +1 @@
+MD5 (bmon-1.2.0.tar.gz) = 7fa3e960c4d7824c1827e69a16c2832d
diff --git a/net/bmon/pkg-descr b/net/bmon/pkg-descr
new file mode 100644
index 000000000000..67b9c18e1d5c
--- /dev/null
+++ b/net/bmon/pkg-descr
@@ -0,0 +1,8 @@
+bmon is an interface bandwidth monitor using the curses library.
+It's able to compute and draw three types of diagrams (overview,
+graphical, and detailed). The overview diagram is a list of all
+interfaces including the rx/tx rates of each interface. The
+graphical diagram is a bar graph in ASCII. All diagrams are
+continously updated.
+
+WWW: http://trash.net/~reeler/bmon/
diff --git a/net/bmon/pkg-plist b/net/bmon/pkg-plist
new file mode 100644
index 000000000000..8dcbabe812e9
--- /dev/null
+++ b/net/bmon/pkg-plist
@@ -0,0 +1 @@
+sbin/bmon