aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-05-05 03:10:17 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-05-05 03:10:17 +0800
commit209cbcd76b7eb16e48e41f4e5bc76c511e7ca3c1 (patch)
tree367d58cae673ea3f89554c34b306ad4950f7982f /net
parent1892f4e2ad34bb9bf44cef1005f0fd3a42eacfc0 (diff)
downloadfreebsd-ports-gnome-209cbcd76b7eb16e48e41f4e5bc76c511e7ca3c1.tar.gz
freebsd-ports-gnome-209cbcd76b7eb16e48e41f4e5bc76c511e7ca3c1.tar.zst
freebsd-ports-gnome-209cbcd76b7eb16e48e41f4e5bc76c511e7ca3c1.zip
- Fix orphaned include/event2 dir (likely an upstream error that it is created)
- Fix shebang QA error when not using PERL_UTILS. This was broken in r374987. Error: '-w' is an invalid shebang you need USES=shebangfix for 'sbin/ntptrace' Must replace @PERL_PATH@ before install or it becomes a blank: '#! -w' Sponsored by: EMC / Isilon Storage Division
Diffstat (limited to 'net')
-rw-r--r--net/ntp-devel/Makefile8
-rw-r--r--net/ntp-devel/pkg-plist1
-rw-r--r--net/ntp/Makefile8
-rw-r--r--net/ntp/pkg-plist1
4 files changed, 12 insertions, 6 deletions
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index 46ad730b3552..5942c0419889 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.3.20
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-dev/ \
http://archive.ntp.org/ntp4/ntp-dev/
@@ -19,7 +20,10 @@ OPTIONS_SUB= yes
USES= cpe pathfix shebangfix libtool
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
-NTP_SHEBANG_FILES= sbin/ntp-wait sbin/ntptrace sbin/update-leap
+SHEBANG_FILES= ${WRKSRC}/scripts/ntptrace/ntptrace.in \
+ ${WRKSRC}/scripts/ntp-wait/ntp-wait.in \
+ ${WRKSRC}/scripts/update-leap/update-leap
+perl_OLD_CMD= @PATH_PERL@
.include "Makefile.inc"
@@ -60,7 +64,5 @@ post-install:
@${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
@cd ${WRKSRC}/html && ${FIND} . -print | \
${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${STAGEDIR}${DOCSDIR}
- @cd ${STAGEDIR}${PREFIX}; \
- ${ECHO_CMD} ${NTP_SHEBANG_FILES} | ${XARGS} ${SED} -i '' ${_SHEBANG_REINPLACE_ARGS}
.include <bsd.port.post.mk>
diff --git a/net/ntp-devel/pkg-plist b/net/ntp-devel/pkg-plist
index a2d9109de8b7..7d1a7c0de7ac 100644
--- a/net/ntp-devel/pkg-plist
+++ b/net/ntp-devel/pkg-plist
@@ -497,3 +497,4 @@ sbin/update-leap
%%EXAMPLESDIR%%/malarky.conf
%%EXAMPLESDIR%%/pogo.conf
%%EXAMPLESDIR%%/rackety.conf
+@dir include/event2
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 931e567b84c5..f5fee542449b 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8p2
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
@@ -19,7 +20,10 @@ OPTIONS_SUB= yes
USES= cpe pathfix shebangfix libtool
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
-NTP_SHEBANG_FILES= sbin/ntp-wait sbin/ntptrace sbin/update-leap
+SHEBANG_FILES= ${WRKSRC}/scripts/ntptrace/ntptrace.in \
+ ${WRKSRC}/scripts/ntp-wait/ntp-wait.in \
+ ${WRKSRC}/scripts/update-leap/update-leap
+perl_OLD_CMD= @PATH_PERL@
.include "Makefile.inc"
@@ -60,7 +64,5 @@ post-install:
@${FIND} ${WRKSRC}/html -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
@cd ${WRKSRC}/html && ${FIND} . -print | \
${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${STAGEDIR}${DOCSDIR}
- @cd ${STAGEDIR}${PREFIX}; \
- ${ECHO_CMD} ${NTP_SHEBANG_FILES} | ${XARGS} ${SED} -i '' ${_SHEBANG_REINPLACE_ARGS}
.include <bsd.port.post.mk>
diff --git a/net/ntp/pkg-plist b/net/ntp/pkg-plist
index a2d9109de8b7..7d1a7c0de7ac 100644
--- a/net/ntp/pkg-plist
+++ b/net/ntp/pkg-plist
@@ -497,3 +497,4 @@ sbin/update-leap
%%EXAMPLESDIR%%/malarky.conf
%%EXAMPLESDIR%%/pogo.conf
%%EXAMPLESDIR%%/rackety.conf
+@dir include/event2