aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-06-13 21:51:28 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-06-13 21:51:28 +0800
commit2464b202e6020faca2994a49fcacba7bcf7a012a (patch)
tree072f381a0d42f6afa1e0b5e535d01edd0ce1f494 /net
parent95a5b158572c08f6a2fb8cdcf646fc9116ae8e29 (diff)
downloadfreebsd-ports-gnome-2464b202e6020faca2994a49fcacba7bcf7a012a.tar.gz
freebsd-ports-gnome-2464b202e6020faca2994a49fcacba7bcf7a012a.tar.zst
freebsd-ports-gnome-2464b202e6020faca2994a49fcacba7bcf7a012a.zip
- Add LICENSE
- Strip shared library - Regenerate patch files with makepatch: - Reformat pkg-descr - Bump PORTREVISION for package change - Take maintainership
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-ARP/Makefile11
-rw-r--r--net/p5-Net-ARP/files/patch-ARP.xs6
-rw-r--r--net/p5-Net-ARP/files/patch-arp.h9
-rw-r--r--net/p5-Net-ARP/files/patch-arp_lookup_bsd.c6
-rw-r--r--net/p5-Net-ARP/files/patch-ppport.h6
-rw-r--r--net/p5-Net-ARP/files/patch-send_packet_bsd.c6
-rw-r--r--net/p5-Net-ARP/pkg-descr4
7 files changed, 29 insertions, 19 deletions
diff --git a/net/p5-Net-ARP/Makefile b/net/p5-Net-ARP/Makefile
index 54598e6c2ee9..05e72eebffc0 100644
--- a/net/p5-Net-ARP/Makefile
+++ b/net/p5-Net-ARP/Makefile
@@ -3,17 +3,24 @@
PORTNAME= Net-ARP
PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl extension for creating ARP packets
+LICENSE= GPLv2
+
BUILD_DEPENDS= p5-Net-Pcap>=0:${PORTSDIR}/net/p5-Net-Pcap
USES= perl5 tar:tgz
USE_PERL5= configure
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/ARP/ARP.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/ARP/ARP.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Net/ARP/ARP.so
+
.include <bsd.port.mk>
diff --git a/net/p5-Net-ARP/files/patch-ARP.xs b/net/p5-Net-ARP/files/patch-ARP.xs
index 38100d6a5c9d..adb788a1234a 100644
--- a/net/p5-Net-ARP/files/patch-ARP.xs
+++ b/net/p5-Net-ARP/files/patch-ARP.xs
@@ -1,6 +1,6 @@
---- ARP.xs.orig 2009-05-04 16:08:52.000000000 -0700
-+++ ARP.xs 2009-05-04 16:08:58.000000000 -0700
-@@ -27,7 +27,6 @@
+--- ARP.xs.orig 2013-06-24 05:15:16 UTC
++++ ARP.xs
+@@ -27,7 +27,6 @@ See the GNU General Public License for m
#include <string.h>
#include <errno.h>
#include <net/ethernet.h>
diff --git a/net/p5-Net-ARP/files/patch-arp.h b/net/p5-Net-ARP/files/patch-arp.h
index 312215782d18..817b9f83d960 100644
--- a/net/p5-Net-ARP/files/patch-arp.h
+++ b/net/p5-Net-ARP/files/patch-arp.h
@@ -1,8 +1,11 @@
---- arp.h.orig 2007-08-16 09:38:44.000000000 +0200
-+++ arp.h 2008-06-24 14:47:24.000000000 +0200
-@@ -54,5 +54,3 @@
+--- arp.h.orig 2013-06-24 05:14:10 UTC
++++ arp.h
+@@ -58,8 +58,6 @@ struct my_arphdr {
u_char dest_add[ETH_ALEN]; // dest mac
u_char dest_ip[IP_ALEN]; // dest ip
};
-
-extern struct ether_addr *ether_aton (__const char *__asc) __THROW;
+ extern int get_mac_linux(const char *dev, char *mac);
+ extern int get_mac_bsd(const char *dev, char *mac);
+ extern int arp_lookup_linux(const char *dev, const char *ip, char *mac);
diff --git a/net/p5-Net-ARP/files/patch-arp_lookup_bsd.c b/net/p5-Net-ARP/files/patch-arp_lookup_bsd.c
index 3e905ecb3281..5d34e77a9d1b 100644
--- a/net/p5-Net-ARP/files/patch-arp_lookup_bsd.c
+++ b/net/p5-Net-ARP/files/patch-arp_lookup_bsd.c
@@ -1,6 +1,6 @@
---- arp_lookup_bsd.c.orig 2006-09-20 11:19:00.000000000 +0200
-+++ arp_lookup_bsd.c 2008-06-24 14:57:10.000000000 +0200
-@@ -18,6 +18,8 @@
+--- arp_lookup_bsd.c.orig 2009-05-23 11:11:58 UTC
++++ arp_lookup_bsd.c
+@@ -18,6 +18,8 @@ FOR A PARTICULAR PURPOSE.
See the GNU General Public License for more details.
*/
diff --git a/net/p5-Net-ARP/files/patch-ppport.h b/net/p5-Net-ARP/files/patch-ppport.h
index b4e12507d8e8..f9ed1ed6981f 100644
--- a/net/p5-Net-ARP/files/patch-ppport.h
+++ b/net/p5-Net-ARP/files/patch-ppport.h
@@ -1,6 +1,6 @@
---- ppport.h.orig 2008-06-24 12:35:16.000000000 +0000
-+++ ppport.h 2008-06-24 12:35:40.000000000 +0000
-@@ -220,6 +220,7 @@
+--- ppport.h.orig 2009-06-20 19:10:51 UTC
++++ ppport.h
+@@ -211,6 +211,7 @@ __DATA__
/* Replace: 0 */
#endif
diff --git a/net/p5-Net-ARP/files/patch-send_packet_bsd.c b/net/p5-Net-ARP/files/patch-send_packet_bsd.c
index 88313c1a1624..f724e1f37041 100644
--- a/net/p5-Net-ARP/files/patch-send_packet_bsd.c
+++ b/net/p5-Net-ARP/files/patch-send_packet_bsd.c
@@ -1,6 +1,6 @@
---- send_packet_bsd.c.orig 2009-05-04 16:27:55.000000000 -0700
-+++ send_packet_bsd.c 2009-05-04 16:28:43.000000000 -0700
-@@ -56,7 +56,13 @@
+--- send_packet_bsd.c.orig 2009-05-23 11:11:58 UTC
++++ send_packet_bsd.c
+@@ -56,7 +56,13 @@ int send_packet_bsd(const char *dev, u_c
flock(bpffd,LOCK_EX);
// Bind it to a device
diff --git a/net/p5-Net-ARP/pkg-descr b/net/p5-Net-ARP/pkg-descr
index 8ea7150fd5ea..a4af72a48184 100644
--- a/net/p5-Net-ARP/pkg-descr
+++ b/net/p5-Net-ARP/pkg-descr
@@ -1,4 +1,4 @@
-This module can be used to create and send ARP packets and to get
-the mac address of an ethernet interface or ip address.
+Net::ARP can be used to create and send ARP packets and to get the mac address
+of an ethernet interface or IP address.
WWW: http://search.cpan.org/dist/Net-ARP/