aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2005-10-21 20:39:59 +0800
committersem <sem@FreeBSD.org>2005-10-21 20:39:59 +0800
commit3444db83482436472604d7b127254915049ff0d9 (patch)
tree180e4409ad212053723597dc31312d8c3c1bbfe2 /net
parent6823ea2aeb92e8e32561166e22a053f5252e6b3d (diff)
downloadfreebsd-ports-gnome-3444db83482436472604d7b127254915049ff0d9.tar.gz
freebsd-ports-gnome-3444db83482436472604d7b127254915049ff0d9.tar.zst
freebsd-ports-gnome-3444db83482436472604d7b127254915049ff0d9.zip
This module provides methods for implementing a DHCP client. It allows
perl scripts to interacts with DHCP servers. It's good for DHCP servers testing.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-DHCPClient/Makefile25
-rw-r--r--net/p5-Net-DHCPClient/distinfo2
-rw-r--r--net/p5-Net-DHCPClient/pkg-descr6
-rw-r--r--net/p5-Net-DHCPClient/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 338d0901a6bd..c3b5bd02c904 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -512,6 +512,7 @@
SUBDIR += p5-Net-BGP
SUBDIR += p5-Net-Blogger
SUBDIR += p5-Net-CIDR-Lite
+ SUBDIR += p5-Net-DHCPClient
SUBDIR += p5-Net-DLookup
SUBDIR += p5-Net-Daemon
SUBDIR += p5-Net-Delicious
diff --git a/net/p5-Net-DHCPClient/Makefile b/net/p5-Net-DHCPClient/Makefile
new file mode 100644
index 000000000000..55f7bfb98a0f
--- /dev/null
+++ b/net/p5-Net-DHCPClient/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-DHCPClient
+# Date created: 21 October 2005
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-DHCPClient
+PORTVERSION= 1.0
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= A Perl implementation of a DHCP client API
+
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP
+PERL_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN3= Net::DHCPClient.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-DHCPClient/distinfo b/net/p5-Net-DHCPClient/distinfo
new file mode 100644
index 000000000000..21d0f218bc0f
--- /dev/null
+++ b/net/p5-Net-DHCPClient/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-DHCPClient-1.0.tar.gz) = f78194112f070961d311d43e743b9b9f
+SIZE (Net-DHCPClient-1.0.tar.gz) = 5428
diff --git a/net/p5-Net-DHCPClient/pkg-descr b/net/p5-Net-DHCPClient/pkg-descr
new file mode 100644
index 000000000000..27a39608c0c6
--- /dev/null
+++ b/net/p5-Net-DHCPClient/pkg-descr
@@ -0,0 +1,6 @@
+This module provides methods for implementing a DHCP client. It allows
+perl scripts to interacts with DHCP servers.
+
+It's good for DHCP servers testing.
+
+WWW: http://search.cpan.org/dist/Net-DHCPClient/
diff --git a/net/p5-Net-DHCPClient/pkg-plist b/net/p5-Net-DHCPClient/pkg-plist
new file mode 100644
index 000000000000..54239328cedd
--- /dev/null
+++ b/net/p5-Net-DHCPClient/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Net/DHCPClient.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DHCPClient/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DHCPClient
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true