aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2018-05-24 16:43:36 +0800
committerdecke <decke@FreeBSD.org>2018-05-24 16:43:36 +0800
commit3be195cba36faf0610fcfebfccf61e9d0c64ef25 (patch)
tree692aa458db836da58329a7620c2e6fe130116338 /net
parent33a3fa2fe5dbbdd963d356cf4c420c8797fa2593 (diff)
downloadfreebsd-ports-gnome-3be195cba36faf0610fcfebfccf61e9d0c64ef25.tar.gz
freebsd-ports-gnome-3be195cba36faf0610fcfebfccf61e9d0c64ef25.tar.zst
freebsd-ports-gnome-3be195cba36faf0610fcfebfccf61e9d0c64ef25.zip
This is an implementation of Wireguard in Go.
WireGuard is an extremely simple yet fast and modern VPN that utilizes state-of-the-art cryptography. It aims to be faster, simpler, leaner, and more useful than IPSec, while avoiding the massive headache. It intends to be considerably more performant than OpenVPN. WireGuard is designed as a general purpose VPN for running on embedded interfaces and super computers alike, fit for many different circumstances. WWW: https://www.wireguard.com
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/wireguard-go/Makefile28
-rw-r--r--net/wireguard-go/distinfo5
-rw-r--r--net/wireguard-go/pkg-descr10
4 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f37b82d7ce91..047fc06002e3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1520,6 +1520,7 @@
SUBDIR += wakeonlan
SUBDIR += whois
SUBDIR += widentd
+ SUBDIR += wireguard-go
SUBDIR += wireshark
SUBDIR += wireshark-lite
SUBDIR += wireshark-qt5
diff --git a/net/wireguard-go/Makefile b/net/wireguard-go/Makefile
new file mode 100644
index 000000000000..7754bc57a798
--- /dev/null
+++ b/net/wireguard-go/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= wireguard-go
+PORTVERSION= 0.0.20180524
+CATEGORIES= net
+MASTER_SITES= https://git.zx2c4.com/wireguard-go/snapshot/ \
+ LOCAL/decke
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-${PORTVERSION}-vendor${EXTRACT_SUFX}
+
+MAINTAINER= decke@FreeBSD.org
+COMMENT= WireGuard implementation in Go
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= go:lang/go \
+ dep:devel/dep
+
+USES= gmake tar:xz
+
+PLIST_FILES= bin/${PORTNAME}
+
+# To generate the vendor source tarball with all dependencies
+genvendor:
+ (cd ${WRKDIR} ; ${TAR} cvfJ ${PORTNAME}-${PORTVERSION}-vendor.tar.xz ${PORTNAME}-${PORTVERSION}/vendor)
+
+.include <bsd.port.mk>
diff --git a/net/wireguard-go/distinfo b/net/wireguard-go/distinfo
new file mode 100644
index 000000000000..cbe8a2d65282
--- /dev/null
+++ b/net/wireguard-go/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1527146018
+SHA256 (wireguard-go-0.0.20180524.tar.xz) = 1d539f6c51dd33098a536af0285ef03c561db0ff343f23a75405207fcf48ec3e
+SIZE (wireguard-go-0.0.20180524.tar.xz) = 53432
+SHA256 (wireguard-go-0.0.20180524-vendor.tar.xz) = 582e2add0ea66c04015aa90700cef549028f2572c4b8234b39ece5be6d7e56ad
+SIZE (wireguard-go-0.0.20180524-vendor.tar.xz) = 253864
diff --git a/net/wireguard-go/pkg-descr b/net/wireguard-go/pkg-descr
new file mode 100644
index 000000000000..bac1b3db112f
--- /dev/null
+++ b/net/wireguard-go/pkg-descr
@@ -0,0 +1,10 @@
+This is an implementation of Wireguard in Go.
+
+WireGuard is an extremely simple yet fast and modern VPN that utilizes
+state-of-the-art cryptography. It aims to be faster, simpler, leaner,
+and more useful than IPSec, while avoiding the massive headache. It
+intends to be considerably more performant than OpenVPN. WireGuard is
+designed as a general purpose VPN for running on embedded interfaces and
+super computers alike, fit for many different circumstances.
+
+WWW: https://www.wireguard.com