aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /net
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork4/Makefile6
-rw-r--r--net/kdenetwork4/distinfo4
-rw-r--r--net/krdc/Makefile2
-rw-r--r--net/krfb/Makefile5
4 files changed, 9 insertions, 8 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 3b27f0965c2d..47cadbbca6de 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -3,11 +3,10 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= net kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Network applications
@@ -25,7 +24,8 @@ USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs workspace \
automoc4 ontologies strigi
USES= cmake:outsource
USE_OPENSSL= yes
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT4= corelib gui sql \
+ moc_build qmake_build rcc_build uic_build
USE_SQLITE= yes
USE_XORG= x11 xdamage xext xscrnsaver xtst
USE_XZ= yes
diff --git a/net/kdenetwork4/distinfo b/net/kdenetwork4/distinfo
index 3aa3d9020234..7ec28d3e4a85 100644
--- a/net/kdenetwork4/distinfo
+++ b/net/kdenetwork4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdenetwork-4.9.5.tar.xz) = a33b00d33335786b08a76d3f837cc59c63c570ed466ae42c1516009d18ae6f70
-SIZE (KDE/kdenetwork-4.9.5.tar.xz) = 9027808
+SHA256 (KDE/4.10.1/kdenetwork-4.10.1.tar.xz) = d8e1566f444387f9bbc2a02aa75cea280ce6ae7703bac1c5f6b0d1c66c2c931a
+SIZE (KDE/4.10.1/kdenetwork-4.10.1.tar.xz) = 9051764
diff --git a/net/krdc/Makefile b/net/krdc/Makefile
index 8e45d93f4823..008365b45232 100644
--- a/net/krdc/Makefile
+++ b/net/krdc/Makefile
@@ -6,7 +6,7 @@ CATEGORIES= net kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
DISTNAME= kdenetwork-${PORTVERSION}
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= RDP and VNC client for KDE
diff --git a/net/krfb/Makefile b/net/krfb/Makefile
index b26bdecaf3f8..0c63a77cc576 100644
--- a/net/krfb/Makefile
+++ b/net/krfb/Makefile
@@ -6,7 +6,7 @@ CATEGORIES= net kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
DISTNAME= kdenetwork-${PORTVERSION}
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= VNC server for KDE
@@ -20,7 +20,8 @@ CONFLICTS_INSTALL= kdenetwork-4.[1-8].*
USES= cmake:outsource
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT4= corelib gui network \
+ moc_build qmake_build rcc_build uic_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes