aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-08-20 00:15:17 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-08-20 00:15:17 +0800
commit4094d0750e0e73d400143d8dd256600d9ea85821 (patch)
treecb43a62168c4c3318be5abf15366462ee3023cdd /net
parent288ee8d6d7869680725dbac49cfd3449a123978b (diff)
downloadfreebsd-ports-gnome-4094d0750e0e73d400143d8dd256600d9ea85821.tar.gz
freebsd-ports-gnome-4094d0750e0e73d400143d8dd256600d9ea85821.tar.zst
freebsd-ports-gnome-4094d0750e0e73d400143d8dd256600d9ea85821.zip
- Install inspectsocks and validateconf which are mentioned in the manpage
- Add license - Use SUB_FILES for pkg-message - Use DISTVERSION instead of PORTVERSION - Recreate patch files to satisfy portlint - Reformat pkg-message to what the PHB (section 8.5) defines as a good format - Bump PORTREVISION - Take maintainership
Diffstat (limited to 'net')
-rw-r--r--net/tsocks/Makefile19
-rw-r--r--net/tsocks/files/patch-INSTALL (renamed from net/tsocks/files/patch-readme)18
-rw-r--r--net/tsocks/files/patch-Makefile.in6
-rw-r--r--net/tsocks/files/patch-configure12
-rw-r--r--net/tsocks/files/patch-parser.c4
-rw-r--r--net/tsocks/files/patch-tsocks.16
-rw-r--r--net/tsocks/files/patch-tsocks.816
-rw-r--r--net/tsocks/files/patch-tsocks.c2
-rw-r--r--net/tsocks/files/pkg-message.in4
-rw-r--r--net/tsocks/pkg-message9
-rw-r--r--net/tsocks/pkg-plist6
11 files changed, 53 insertions, 49 deletions
diff --git a/net/tsocks/Makefile b/net/tsocks/Makefile
index 6ddc46554b93..137dd3b2b81a 100644
--- a/net/tsocks/Makefile
+++ b/net/tsocks/Makefile
@@ -2,28 +2,30 @@
# $FreeBSD$
PORTNAME= tsocks
-PORTVERSION= 1.8.b5
-PORTREVISION= 6
+DISTVERSION= 1.8.b5
+PORTREVISION= 7
CATEGORIES= net security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.8%20beta%205 \
http://ftp1.sourceforge.net/tsocks/ \
http://www.yazzy.org/ports/tsocks/
DISTNAME= ${PORTNAME}-${PORTVERSION:C/.b/beta/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Allow non SOCKS aware applications to use SOCKS without modification
+LICENSE= GPLv2
+
GNU_CONFIGURE= yes
USES= gmake
USE_LDCONFIG= yes
-WRKSRC=${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b.*//}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.b.*//}
CONFIGURE_ARGS= --with-conf=${PREFIX}/etc/tsocks.conf \
--libdir=${PREFIX}/lib
OPTIONS_DEFINE= DOCS EXAMPLES HOSTNAMES MUTE OLDMETHOD SOCKSDNS
-OPTIONS_DEFAULT= HOSTNAMES
+OPTIONS_DEFAULT=HOSTNAMES
HOSTNAMES_DESC= Enable DNS lookups
OLDMETHOD_DESC= Do not use RTLD_NEXT parameter to dlsym
@@ -35,12 +37,17 @@ MUTE_CONFIGURE_ON= --disable-debug
OLDMETHOD_CONFIGURE_ON= --enable-oldmethod
SOCKSDNS_CONFIGURE_ON= --enable-socksdns
+SUB_FILES= pkg-message
+
post-patch:
@${REINPLACE_CMD} -e 's|ufds|fds|g' ${WRKSRC}/tsocks.c
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' ${WRKSRC}/tsocks
post-install:
- ${INSTALL_DATA} ${WRKSRC}/tsocks.conf.simple.example ${STAGEDIR}${PREFIX}/etc/tsocks.conf.sample
+ ${INSTALL_PROGRAM} ${WRKSRC}/inspectsocks ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/validateconf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/tsocks.conf.simple.example \
+ ${STAGEDIR}${PREFIX}/etc/tsocks.conf.sample
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/*.example ${STAGEDIR}${EXAMPLESDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/net/tsocks/files/patch-readme b/net/tsocks/files/patch-INSTALL
index 2fdc1fdac737..65c3898cb7a8 100644
--- a/net/tsocks/files/patch-readme
+++ b/net/tsocks/files/patch-INSTALL
@@ -1,5 +1,5 @@
---- INSTALL Sat May 18 04:12:30 2002
-+++ README Sat Sep 6 18:36:27 2003
+--- INSTALL.orig 2002-05-18 02:12:30 UTC
++++ INSTALL
@@ -1,12 +1,7 @@
-Quick Installation Instructions
+Quick Instructions
@@ -15,7 +15,7 @@
specific to tsocks include):
--enable-socksdns This option causes tsocks to intercept
DNS lookups and attempt to force them
-@@ -39,55 +34,31 @@
+@@ -39,55 +34,31 @@ achieved that)
Other standard autoconf options are provided by typing './configure
--help'
@@ -28,10 +28,10 @@
-you really wish to install the library into some other path use --libdir.
-
-3. Compile the code by typing:
+-
+- make
+2. Created files:
-- make
--
-This should result in the creation of the following:
- libtsocks.so - the libtsocks library
- validateconf - a utility to verify the tsocks configuration file
@@ -49,15 +49,15 @@
-to be able to use it however, su to root then type
-
- make install
-+3. Configuration
-
+-
-This will install the library, the tsocks script and its man pages
-(tsocks(8), tsocks(1) and tsocks.conf(5)) to the paths specified to
-configure.
-
-Note that by default the library is installed to /lib and that the
-configure --prefix is IGNORED. See above for more detail.
--
++3. Configuration
+
-6. At this point you'll need to create the tsocks configuration file.
-There are two samples provided in the build directory called
+You'll need to create the tsocks configuration file.
@@ -79,7 +79,7 @@
who choose to use it. If you want users to use it themselves, they can
simply use the tsocks(1) shell script to run programs (see 'man tsocks')
or do the following in their shell before running applications that need
-@@ -97,25 +68,15 @@
+@@ -97,25 +68,15 @@ to be transparently proxied:
(in CSH) setenv LD_PRELOAD <path to library>
diff --git a/net/tsocks/files/patch-Makefile.in b/net/tsocks/files/patch-Makefile.in
index d36d3299368d..9e9563eed00e 100644
--- a/net/tsocks/files/patch-Makefile.in
+++ b/net/tsocks/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Tue Oct 7 18:13:47 2003
-+++ Makefile.in Tue Oct 7 18:14:24 2003
-@@ -67,8 +67,7 @@
+--- Makefile.in.orig 2002-03-16 10:12:40 UTC
++++ Makefile.in
+@@ -67,8 +67,7 @@ installscript:
installlib:
${MKINSTALLDIRS} "${DESTDIR}${libdir}"
diff --git a/net/tsocks/files/patch-configure b/net/tsocks/files/patch-configure
index 275f2c312df2..68a2c7c97dcd 100644
--- a/net/tsocks/files/patch-configure
+++ b/net/tsocks/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Jul 15 15:51:08 2002
-+++ configure Wed Oct 8 01:42:17 2003
-@@ -1836,14 +1836,14 @@
+--- configure.orig 2002-07-15 22:51:08 UTC
++++ configure
+@@ -1836,14 +1836,14 @@ fi
SIMPLELIBS=${LIBS}
LIBS=
@@ -18,7 +18,7 @@
cat > conftest.$ac_ext <<EOF
#line 1849 "configure"
#include "confdefs.h"
-@@ -1877,7 +1877,7 @@
+@@ -1877,7 +1877,7 @@ if eval "test \"`echo '$ac_cv_lib_'$ac_l
#define $ac_tr_lib 1
EOF
@@ -27,7 +27,7 @@
else
echo "$ac_t""no" 1>&6
-@@ -2151,6 +2151,7 @@
+@@ -2151,6 +2151,7 @@ do
#line 2152 "configure"
#include "confdefs.h"
@@ -35,7 +35,7 @@
#include <sys/socket.h>
int connect($testproto);
-@@ -2227,14 +2228,16 @@
+@@ -2227,14 +2228,16 @@ EOF
echo $ac_n "checking for correct poll prototype""... $ac_c" 1>&6
echo "configure:2230: checking for correct poll prototype" >&5
diff --git a/net/tsocks/files/patch-parser.c b/net/tsocks/files/patch-parser.c
index 080776142a2f..1c98675cb706 100644
--- a/net/tsocks/files/patch-parser.c
+++ b/net/tsocks/files/patch-parser.c
@@ -1,5 +1,5 @@
---- parser.c.orig Wed Oct 8 01:43:48 2003
-+++ parser.c Wed Oct 8 01:43:58 2003
+--- parser.c.orig 2002-03-13 12:34:22 UTC
++++ parser.c
@@ -4,6 +4,7 @@
*/
diff --git a/net/tsocks/files/patch-tsocks.1 b/net/tsocks/files/patch-tsocks.1
index 44a0e7eb601e..a592243c7671 100644
--- a/net/tsocks/files/patch-tsocks.1
+++ b/net/tsocks/files/patch-tsocks.1
@@ -1,5 +1,5 @@
---- tsocks.1.orig Sat Mar 16 11:34:44 2002
-+++ tsocks.1 Sat Sep 6 17:54:49 2003
+--- tsocks.1.orig 2002-03-16 10:34:44 UTC
++++ tsocks.1
@@ -1,24 +1,24 @@
-.TH TSOCKS 1 "" "TSOCKS"
-
@@ -33,7 +33,7 @@
.IP \fB[application\ \fB[application's\ arguments]]
run the application as specified with the environment (LD_PRELOAD) set
such that tsocks(8) will transparently proxy SOCKS connections in
-@@ -28,19 +28,19 @@
+@@ -28,19 +28,19 @@ this option adds or removes tsocks(8) fr
variable. When tsocks(8) is in this variable all executed
applications are automatically socksified. If you want to
use this function, you HAVE to source the shell script from yours,
diff --git a/net/tsocks/files/patch-tsocks.8 b/net/tsocks/files/patch-tsocks.8
index e2023046e1fe..2cdedb0c75d0 100644
--- a/net/tsocks/files/patch-tsocks.8
+++ b/net/tsocks/files/patch-tsocks.8
@@ -1,5 +1,5 @@
---- tsocks.8.orig Sat Mar 16 11:20:51 2002
-+++ tsocks.8 Sat Sep 6 18:15:08 2003
+--- tsocks.8.orig 2002-03-16 10:20:51 UTC
++++ tsocks.8
@@ -1,25 +1,24 @@
-.TH TSOCKS 8 "" "Shaun Clowes" \" -*-
- \" nroff -*
@@ -35,7 +35,7 @@
This process can be automated (for Bash, Bourne and Korn shell
users) for a single command or for all commands in a shell session
-@@ -30,13 +29,12 @@
+@@ -30,13 +29,12 @@ automatically use it, a very useful conf
information on this configuration see the CAVEATS section of this
manual page.
@@ -51,7 +51,7 @@
it is not, the library redirects the connection to a SOCKS server
specified in the configuration file. It then negotiates that connection
with the SOCKS server and passes the connection back to the calling
-@@ -52,42 +50,42 @@
+@@ -52,42 +50,42 @@ the SOCKSified TCP/IP stacks seen on oth
Most arguments to
.BR tsocks
are provided in the configuration file (the location of which is defined
@@ -104,7 +104,7 @@
.I TSOCKS_USERNAME
This environment variable can be used to specify the username to be used when
version 5 SOCKS servers request username/password authentication. This
-@@ -95,7 +93,7 @@
+@@ -95,7 +93,7 @@ overrides the default username that can
file using 'default_user', see tsocks.conf(8) for more information. This
variable is ignored for version 4 SOCKS servers.
@@ -113,7 +113,7 @@
.I TSOCKS_PASSWORD
This environment variable can be used to specify the password to be used when
version 5 SOCKS servers request username/password authentication. This
-@@ -115,11 +113,12 @@
+@@ -115,11 +113,12 @@ consult the INSTALL file for more inform
.BR tsocks
will generate error messages and print them to stderr when there are
problems with the configuration file or the SOCKS negotiation with the
@@ -128,7 +128,7 @@
.BR tsocks
will not in the above configuration be able to provide SOCKS proxying to
setuid applications or applications that are not run from a shell. You can
-@@ -132,8 +131,7 @@
+@@ -132,8 +131,7 @@ the INSTALL file for more info). THIS I
careful. Also be sure the library is in the root filesystem as all hell
will break loose if the directory it is in is not available at boot time.
@@ -138,7 +138,7 @@
.BR tsocks
can only proxy outgoing TCP connections
-@@ -157,21 +155,21 @@
+@@ -157,21 +155,21 @@ not. This introduces overhead and should
.BR tsocks
uses ELF dynamic loader features to intercept dynamic function calls from
programs in which it is embedded. As a result, it cannot trace the
diff --git a/net/tsocks/files/patch-tsocks.c b/net/tsocks/files/patch-tsocks.c
index 7d5b4984dbdd..eed81cc56f58 100644
--- a/net/tsocks/files/patch-tsocks.c
+++ b/net/tsocks/files/patch-tsocks.c
@@ -1,4 +1,4 @@
---- tsocks.c.orig 2014-12-19 02:01:24 UTC
+--- tsocks.c.orig 2002-07-15 22:50:52 UTC
+++ tsocks.c
@@ -852,7 +852,7 @@ static int connect_server(struct connreq
sizeof(conn->serveraddr));
diff --git a/net/tsocks/files/pkg-message.in b/net/tsocks/files/pkg-message.in
new file mode 100644
index 000000000000..81badd2fbac7
--- /dev/null
+++ b/net/tsocks/files/pkg-message.in
@@ -0,0 +1,4 @@
+Simple setup file was copied to %%PREFIX%%/etc/tsocks.conf.sample
+An example of a more complex setup file can be found in
+%%PREFIX%%/share/examples/tsocks/
+Some more details avaliable in %%PREFIX%%/share/examples/tsocks/README
diff --git a/net/tsocks/pkg-message b/net/tsocks/pkg-message
deleted file mode 100644
index 985d693814c6..000000000000
--- a/net/tsocks/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
-
-###
-
-Simple setup file was copied to ${PREFIX}/etc/tsocks.conf.sample
-An example of a more complex setup file can be found in
-${PREFIX}/share/examples/tsocks/
-Some more details avaliable in ${PREFIX}/share/examples/tsocks/README
-
-###
diff --git a/net/tsocks/pkg-plist b/net/tsocks/pkg-plist
index db617b2ffcc2..1589e0fc5248 100644
--- a/net/tsocks/pkg-plist
+++ b/net/tsocks/pkg-plist
@@ -1,10 +1,12 @@
+bin/inspectsocks
bin/tsocks
+bin/validateconf
etc/tsocks.conf.sample
-lib/libtsocks.so.1
lib/libtsocks.so
+lib/libtsocks.so.1
man/man1/tsocks.1.gz
man/man5/tsocks.conf.5.gz
man/man8/tsocks.8.gz
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tsocks.conf.complex.example
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tsocks.conf.simple.example
-%%PORTDOCS%%%%DOCSDIR%%/README