aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-05-19 23:56:44 +0800
committertcberner <tcberner@FreeBSD.org>2017-05-19 23:56:44 +0800
commit43fbc3fa67628a06039ccbee7d205da7849b9d5f (patch)
tree997384218b5c9e1c26381e1c7c2e07a7fb7d0a39 /net
parentb26372ef4119c7145e88112448aef8db2dca4a47 (diff)
downloadfreebsd-ports-gnome-43fbc3fa67628a06039ccbee7d205da7849b9d5f.tar.gz
freebsd-ports-gnome-43fbc3fa67628a06039ccbee7d205da7849b9d5f.tar.zst
freebsd-ports-gnome-43fbc3fa67628a06039ccbee7d205da7849b9d5f.zip
New port: net/py-cloudflare-scrape
A simple Python module to bypass Cloudflare's anti-bot page (also known as "I'm Under Attack Mode", or IUAM), implemented with Requests. https://github.com/Anorov/cloudflare-scrape Approved by: rakuco (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D10813
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-cloudflare-scrape/Makefile22
-rw-r--r--net/py-cloudflare-scrape/distinfo3
-rw-r--r--net/py-cloudflare-scrape/pkg-descr9
4 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 828bcc7c4832..03021983860f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -969,6 +969,7 @@
SUBDIR += py-beanstalkc
SUBDIR += py-cjdns
SUBDIR += py-cloudfiles
+ SUBDIR += py-cloudflare-scrape
SUBDIR += py-coherence
SUBDIR += py-cymruwhois
SUBDIR += py-dpkt
diff --git a/net/py-cloudflare-scrape/Makefile b/net/py-cloudflare-scrape/Makefile
new file mode 100644
index 000000000000..ef22a43446ae
--- /dev/null
+++ b/net/py-cloudflare-scrape/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= cloudflare-scrape
+PORTVERSION= 1.8.0
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tcberner@FreeBSD.org
+COMMENT= Python module to bypass Cloudflare's anti-bot page
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyExecJS>=0:devel/py-PyExecJS
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= Anorov
+
+.include <bsd.port.mk>
diff --git a/net/py-cloudflare-scrape/distinfo b/net/py-cloudflare-scrape/distinfo
new file mode 100644
index 000000000000..e4b31cb257c3
--- /dev/null
+++ b/net/py-cloudflare-scrape/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1495173015
+SHA256 (Anorov-cloudflare-scrape-1.8.0_GH0.tar.gz) = 59cc3b1a39a5965cf989bd459769c6ff76418cc133c32320bfd0880857d3e8d7
+SIZE (Anorov-cloudflare-scrape-1.8.0_GH0.tar.gz) = 7703
diff --git a/net/py-cloudflare-scrape/pkg-descr b/net/py-cloudflare-scrape/pkg-descr
new file mode 100644
index 000000000000..7b4b89740800
--- /dev/null
+++ b/net/py-cloudflare-scrape/pkg-descr
@@ -0,0 +1,9 @@
+A simple Python module to bypass Cloudflare's anti-bot page (also known as "I'm
+Under Attack Mode", or IUAM), implemented with Requests. Cloudflare changes
+their techniques periodically, so I will update this repo frequently.
+
+This can be useful if you wish to scrape or crawl a website protected with
+Cloudflare. Cloudflare's anti-bot page currently just checks if the client
+supports Javascript, though they may add additional techniques in the future.
+
+WWW: https://github.com/Anorov/cloudflare-scrape