aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoreik <eik@FreeBSD.org>2004-03-25 22:28:17 +0800
committereik <eik@FreeBSD.org>2004-03-25 22:28:17 +0800
commit45cf9d206ffd693ca7076885959a0863f6757a70 (patch)
tree1caba68580d8a6160e3f6627de7ccfa7f3df576b /net
parente64e7f2d90604018c2fe9f150791544f5ef7a9a6 (diff)
downloadfreebsd-ports-gnome-45cf9d206ffd693ca7076885959a0863f6757a70.tar.gz
freebsd-ports-gnome-45cf9d206ffd693ca7076885959a0863f6757a70.tar.zst
freebsd-ports-gnome-45cf9d206ffd693ca7076885959a0863f6757a70.zip
Try to fix the lingering thread problem on -CURRENT, for the better or
the worse, GNATS will tell. Linking all components with PTHREAD_LIBS may not be the most elegant solution. Bump PORTREVISION on all components, which may be unnecessary, but safe.
Diffstat (limited to 'net')
-rw-r--r--net/openldap21-server/Makefile10
-rw-r--r--net/openldap22-server/Makefile10
-rw-r--r--net/openldap23-server/Makefile10
-rw-r--r--net/openldap24-server/Makefile10
4 files changed, 24 insertions, 16 deletions
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index 44981acd628d..cc11a5d39707 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openldap
PORTVERSION= 2.1.28
-PORTREVISION= ${OPENLDAP_PORTVERSION}
+PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
http://public.planetmirror.com/pub/openldap/%SUBDIR%/ \
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.matrix.com.br/pub/openldap/%SUBDIR%/ \
ftp://ftp.ucr.ac.cr/pub/Unix/openldap/%SUBDIR%/ \
ftp://ftp.ntua.gr/mirror/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.shellhung.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/%SUBDIR%/ \
ftp://ftp.u-aizu.ac.jp/pub/net/openldap/%SUBDIR%/ \
ftp://ftp.holywar.net/pub/OpenLDAP/%SUBDIR%/ \
@@ -40,7 +41,7 @@ BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
.if defined(CLIENT_ONLY)
-OPENLDAP_PORTVERSION= 0
+OPENLDAP_PORTREVISION= 1
OPENLDAP_PKGNAMESUFFIX?=-client
OPENLDAP_PKGFILESUFX?= .client
@@ -52,7 +53,7 @@ PORTDOCS= drafts rfc
.error You have `USE_OPENLDAP' defined either in your environment or in make(1) arguments.
.endif
.else
-OPENLDAP_PORTVERSION= 0
+OPENLDAP_PORTREVISION= 1
OPENLDAP_PKGNAMESUFFIX?=-server
OPENLDAP_PKGFILESUFX?=
@@ -88,7 +89,7 @@ SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%DATABASEDIR%%,${DATABASEDIR},g' \
-e 's,%%SLURPDIR%%,${SLURPDIR},g'
-CONFIGURE_ARGS= --with-threads \
+CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
--enable-dynamic
@@ -191,6 +192,7 @@ CONFIGURE_ARGS+= --enable-wrappers
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= ${PTHREAD_LIBS}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 3739c5834177..4b49a43df1de 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openldap
PORTVERSION= 2.2.7
-PORTREVISION= ${OPENLDAP_PORTVERSION}
+PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
http://public.planetmirror.com/pub/openldap/%SUBDIR%/ \
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.matrix.com.br/pub/openldap/%SUBDIR%/ \
ftp://ftp.ucr.ac.cr/pub/Unix/openldap/%SUBDIR%/ \
ftp://ftp.ntua.gr/mirror/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.shellhung.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/%SUBDIR%/ \
ftp://ftp.u-aizu.ac.jp/pub/net/openldap/%SUBDIR%/ \
ftp://ftp.holywar.net/pub/OpenLDAP/%SUBDIR%/ \
@@ -40,7 +41,7 @@ BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
.if defined(CLIENT_ONLY)
-OPENLDAP_PORTVERSION= 2
+OPENLDAP_PORTREVISION= 3
OPENLDAP_PKGNAMESUFFIX?=-client
OPENLDAP_PKGFILESUFX?= .client
@@ -52,7 +53,7 @@ PORTDOCS= drafts rfc
.error You have `USE_OPENLDAP' defined either in your environment or in make(1) arguments.
.endif
.else
-OPENLDAP_PORTVERSION= 1
+OPENLDAP_PORTREVISION= 2
OPENLDAP_PKGNAMESUFFIX?=-server
OPENLDAP_PKGFILESUFX?=
@@ -88,7 +89,7 @@ SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%DATABASEDIR%%,${DATABASEDIR},g' \
-e 's,%%SLURPDIR%%,${SLURPDIR},g'
-CONFIGURE_ARGS= --with-threads \
+CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
--enable-dynamic
@@ -201,6 +202,7 @@ CONFIGURE_ARGS+= --enable-wrappers
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= ${PTHREAD_LIBS}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 3739c5834177..4b49a43df1de 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openldap
PORTVERSION= 2.2.7
-PORTREVISION= ${OPENLDAP_PORTVERSION}
+PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
http://public.planetmirror.com/pub/openldap/%SUBDIR%/ \
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.matrix.com.br/pub/openldap/%SUBDIR%/ \
ftp://ftp.ucr.ac.cr/pub/Unix/openldap/%SUBDIR%/ \
ftp://ftp.ntua.gr/mirror/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.shellhung.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/%SUBDIR%/ \
ftp://ftp.u-aizu.ac.jp/pub/net/openldap/%SUBDIR%/ \
ftp://ftp.holywar.net/pub/OpenLDAP/%SUBDIR%/ \
@@ -40,7 +41,7 @@ BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
.if defined(CLIENT_ONLY)
-OPENLDAP_PORTVERSION= 2
+OPENLDAP_PORTREVISION= 3
OPENLDAP_PKGNAMESUFFIX?=-client
OPENLDAP_PKGFILESUFX?= .client
@@ -52,7 +53,7 @@ PORTDOCS= drafts rfc
.error You have `USE_OPENLDAP' defined either in your environment or in make(1) arguments.
.endif
.else
-OPENLDAP_PORTVERSION= 1
+OPENLDAP_PORTREVISION= 2
OPENLDAP_PKGNAMESUFFIX?=-server
OPENLDAP_PKGFILESUFX?=
@@ -88,7 +89,7 @@ SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%DATABASEDIR%%,${DATABASEDIR},g' \
-e 's,%%SLURPDIR%%,${SLURPDIR},g'
-CONFIGURE_ARGS= --with-threads \
+CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
--enable-dynamic
@@ -201,6 +202,7 @@ CONFIGURE_ARGS+= --enable-wrappers
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= ${PTHREAD_LIBS}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 3739c5834177..4b49a43df1de 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openldap
PORTVERSION= 2.2.7
-PORTREVISION= ${OPENLDAP_PORTVERSION}
+PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
http://public.planetmirror.com/pub/openldap/%SUBDIR%/ \
@@ -15,6 +15,7 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.matrix.com.br/pub/openldap/%SUBDIR%/ \
ftp://ftp.ucr.ac.cr/pub/Unix/openldap/%SUBDIR%/ \
ftp://ftp.ntua.gr/mirror/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.shellhung.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/%SUBDIR%/ \
ftp://ftp.u-aizu.ac.jp/pub/net/openldap/%SUBDIR%/ \
ftp://ftp.holywar.net/pub/OpenLDAP/%SUBDIR%/ \
@@ -40,7 +41,7 @@ BROKEN= "incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}"
.endif
.if defined(CLIENT_ONLY)
-OPENLDAP_PORTVERSION= 2
+OPENLDAP_PORTREVISION= 3
OPENLDAP_PKGNAMESUFFIX?=-client
OPENLDAP_PKGFILESUFX?= .client
@@ -52,7 +53,7 @@ PORTDOCS= drafts rfc
.error You have `USE_OPENLDAP' defined either in your environment or in make(1) arguments.
.endif
.else
-OPENLDAP_PORTVERSION= 1
+OPENLDAP_PORTREVISION= 2
OPENLDAP_PKGNAMESUFFIX?=-server
OPENLDAP_PKGFILESUFX?=
@@ -88,7 +89,7 @@ SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%DATABASEDIR%%,${DATABASEDIR},g' \
-e 's,%%SLURPDIR%%,${SLURPDIR},g'
-CONFIGURE_ARGS= --with-threads \
+CONFIGURE_ARGS= --with-threads=posix \
--with-tls=openssl \
--enable-dynamic
@@ -201,6 +202,7 @@ CONFIGURE_ARGS+= --enable-wrappers
CPPFLAGS+= ${PTHREAD_CFLAGS} \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= ${PTHREAD_LIBS}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \