aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2018-07-24 16:44:32 +0800
committertz <tz@FreeBSD.org>2018-07-24 16:44:32 +0800
commit4827d6341c8195df448c86d232c0a643ba3aceaa (patch)
tree751612430d8a08dd5989d9992db1e4cabdd5ea9c /net
parent4494d7dc520498523a4d72377b421a7319f42162 (diff)
downloadfreebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.tar.gz
freebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.tar.zst
freebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.zip
PHP 7.1 and PHP 7.2: add TEST_TARGET to all extensions
This enables "make test" in every extension and eases the test of changes to PHP. I did ignore PHP 7.0 intentionally since it only receives security updates and will EOL at the end of the year. Therefore no great amount of work is expected for 7.0.
Diffstat (limited to 'net')
-rw-r--r--net/php71-ldap/Makefile2
-rw-r--r--net/php71-soap/Makefile2
-rw-r--r--net/php71-sockets/Makefile2
-rw-r--r--net/php71-xmlrpc/Makefile2
-rw-r--r--net/php72-ldap/Makefile2
-rw-r--r--net/php72-soap/Makefile2
-rw-r--r--net/php72-sockets/Makefile2
-rw-r--r--net/php72-xmlrpc/Makefile2
8 files changed, 16 insertions, 0 deletions
diff --git a/net/php71-ldap/Makefile b/net/php71-ldap/Makefile
index 1edcb04d0de5..4f318bb213ab 100644
--- a/net/php71-ldap/Makefile
+++ b/net/php71-ldap/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -ldap
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/php71-soap/Makefile b/net/php71-soap/Makefile
index 8f0142f7d728..55c2013f0164 100644
--- a/net/php71-soap/Makefile
+++ b/net/php71-soap/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -soap
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/php71-sockets/Makefile b/net/php71-sockets/Makefile
index 9284f2d9c7ae..1a26abfa436b 100644
--- a/net/php71-sockets/Makefile
+++ b/net/php71-sockets/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -sockets
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/php71-xmlrpc/Makefile b/net/php71-xmlrpc/Makefile
index 961bb83a703c..f1c28d03e6c0 100644
--- a/net/php71-xmlrpc/Makefile
+++ b/net/php71-xmlrpc/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -xmlrpc
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-ldap/Makefile b/net/php72-ldap/Makefile
index 930af552e593..756ea8eaf8b4 100644
--- a/net/php72-ldap/Makefile
+++ b/net/php72-ldap/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -ldap
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-soap/Makefile b/net/php72-soap/Makefile
index 2fb49fe37328..36fd246a11c9 100644
--- a/net/php72-soap/Makefile
+++ b/net/php72-soap/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -soap
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-sockets/Makefile b/net/php72-sockets/Makefile
index 7ae4fafe9e71..80afc8848316 100644
--- a/net/php72-sockets/Makefile
+++ b/net/php72-sockets/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -sockets
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/php72-xmlrpc/Makefile b/net/php72-xmlrpc/Makefile
index 21440fea888b..6fbfcbe9e4b1 100644
--- a/net/php72-xmlrpc/Makefile
+++ b/net/php72-xmlrpc/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -xmlrpc
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"