aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-07-16 08:42:04 +0800
committerlioux <lioux@FreeBSD.org>2002-07-16 08:42:04 +0800
commit584db33f436522827873b48fb0b631a55a982316 (patch)
tree1f93919acc03f9acb2b6bf177af2370b524ff6d3 /net
parentd803f6c0f16c4af67db7634bda6bdd42ca7980de (diff)
downloadfreebsd-ports-gnome-584db33f436522827873b48fb0b631a55a982316.tar.gz
freebsd-ports-gnome-584db33f436522827873b48fb0b631a55a982316.tar.zst
freebsd-ports-gnome-584db33f436522827873b48fb0b631a55a982316.zip
o New port dcgui version 0.1 beta 9: A Direct Connect client QT GUI
o Assign maintainership to 1st submitter: Sverrir Valgeirsson <e96sv@yahoo.se> PR: 40425, 40585 Submitted by: Amar Takhar <verm@drunkmonk.net>, Sverrir Valgeirsson <e96sv@yahoo.se>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/dcgui/Makefile38
-rw-r--r--net/dcgui/distinfo1
-rw-r--r--net/dcgui/pkg-comment1
-rw-r--r--net/dcgui/pkg-descr7
-rw-r--r--net/dcgui/pkg-plist1
-rw-r--r--net/valknut/Makefile38
-rw-r--r--net/valknut/distinfo1
-rw-r--r--net/valknut/pkg-comment1
-rw-r--r--net/valknut/pkg-descr7
-rw-r--r--net/valknut/pkg-plist1
11 files changed, 97 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 04836ee14d19..90d72ca554e2 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -73,6 +73,7 @@
SUBDIR += dante
SUBDIR += darkstat
SUBDIR += datapipe
+ SUBDIR += dcgui
SUBDIR += dclib
SUBDIR += dctc
SUBDIR += dctc-gui
diff --git a/net/dcgui/Makefile b/net/dcgui/Makefile
new file mode 100644
index 000000000000..51c649efc11f
--- /dev/null
+++ b/net/dcgui/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: dclib
+# Date created: Wed 10 Jul 2002
+# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
+# Amar Takhar <verm@drunkmonk.net> et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= dcgui
+PORTVERSION= 0.1.9
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
+ http://download.berlios.de/dcgui/ \
+ ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
+ http://dc.ketelhot.de/files/dcgui/unstable/source/
+MASTER_SITE_SUBDIR= dc-gui
+DISTNAME= dcgui-0.1beta9
+
+MAINTAINER= e96sv@yahoo.se
+
+LIB_DEPENDS= dc.0:${PORTSDIR}/devel/dclib \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_X_PREFIX= yes
+USE_QT_VER=3
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libdc=${LOCALBASE} \
+ --with-xml-prefix=${LOCALBASE}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/net/dcgui/distinfo b/net/dcgui/distinfo
new file mode 100644
index 000000000000..cc800aa0ad97
--- /dev/null
+++ b/net/dcgui/distinfo
@@ -0,0 +1 @@
+MD5 (dcgui-0.1beta9.tar.bz2) = 33277a01afbe38d8824042c7c8c357cd
diff --git a/net/dcgui/pkg-comment b/net/dcgui/pkg-comment
new file mode 100644
index 000000000000..368928dbc71e
--- /dev/null
+++ b/net/dcgui/pkg-comment
@@ -0,0 +1 @@
+A Direct Connect client QT GUI
diff --git a/net/dcgui/pkg-descr b/net/dcgui/pkg-descr
new file mode 100644
index 000000000000..bc60949e63a7
--- /dev/null
+++ b/net/dcgui/pkg-descr
@@ -0,0 +1,7 @@
+This is a QT frontend to the Direct Connect system. It supports
+most if not all of the DC features.
+
+WWW: http://dc.ketelhot.de/
+
+- sverrir
+e96sv@yahoo.se
diff --git a/net/dcgui/pkg-plist b/net/dcgui/pkg-plist
new file mode 100644
index 000000000000..76407897fa28
--- /dev/null
+++ b/net/dcgui/pkg-plist
@@ -0,0 +1 @@
+bin/dcgui
diff --git a/net/valknut/Makefile b/net/valknut/Makefile
new file mode 100644
index 000000000000..51c649efc11f
--- /dev/null
+++ b/net/valknut/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: dclib
+# Date created: Wed 10 Jul 2002
+# Whom: Sverrir Valgeirsson <e96sv@yahoo.se> and
+# Amar Takhar <verm@drunkmonk.net> et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= dcgui
+PORTVERSION= 0.1.9
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
+ http://download.berlios.de/dcgui/ \
+ ftp://ftp.kde.com/Networking_Internet/File_Sharing/Direct_Connect_4_Linux/ \
+ http://dc.ketelhot.de/files/dcgui/unstable/source/
+MASTER_SITE_SUBDIR= dc-gui
+DISTNAME= dcgui-0.1beta9
+
+MAINTAINER= e96sv@yahoo.se
+
+LIB_DEPENDS= dc.0:${PORTSDIR}/devel/dclib \
+ xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_X_PREFIX= yes
+USE_QT_VER=3
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libdc=${LOCALBASE} \
+ --with-xml-prefix=${LOCALBASE}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's@xmlversion.h@libxml/xmlversion.h@' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/net/valknut/distinfo b/net/valknut/distinfo
new file mode 100644
index 000000000000..cc800aa0ad97
--- /dev/null
+++ b/net/valknut/distinfo
@@ -0,0 +1 @@
+MD5 (dcgui-0.1beta9.tar.bz2) = 33277a01afbe38d8824042c7c8c357cd
diff --git a/net/valknut/pkg-comment b/net/valknut/pkg-comment
new file mode 100644
index 000000000000..368928dbc71e
--- /dev/null
+++ b/net/valknut/pkg-comment
@@ -0,0 +1 @@
+A Direct Connect client QT GUI
diff --git a/net/valknut/pkg-descr b/net/valknut/pkg-descr
new file mode 100644
index 000000000000..bc60949e63a7
--- /dev/null
+++ b/net/valknut/pkg-descr
@@ -0,0 +1,7 @@
+This is a QT frontend to the Direct Connect system. It supports
+most if not all of the DC features.
+
+WWW: http://dc.ketelhot.de/
+
+- sverrir
+e96sv@yahoo.se
diff --git a/net/valknut/pkg-plist b/net/valknut/pkg-plist
new file mode 100644
index 000000000000..76407897fa28
--- /dev/null
+++ b/net/valknut/pkg-plist
@@ -0,0 +1 @@
+bin/dcgui