aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-07-02 12:00:29 +0800
committerlinimon <linimon@FreeBSD.org>2018-07-02 12:00:29 +0800
commit5b460a6e6dcba3bf614469ba987dfba042c883e4 (patch)
tree1132ef2f7655593f25dfefe7bd682bbbb7a0d555 /net
parenta3584ef01f826922b53df0d4006400529d28375f (diff)
downloadfreebsd-ports-gnome-5b460a6e6dcba3bf614469ba987dfba042c883e4.tar.gz
freebsd-ports-gnome-5b460a6e6dcba3bf614469ba987dfba042c883e4.tar.zst
freebsd-ports-gnome-5b460a6e6dcba3bf614469ba987dfba042c883e4.zip
Mark ports broken on mips64 that are already broken on powerpc64. In
most cases, the failure mode is the same. Also, mark them broken on mips when necessary. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net')
-rw-r--r--net/delegate/Makefile2
-rw-r--r--net/freeradius3/Makefile2
-rw-r--r--net/ndproxy/Makefile2
-rw-r--r--net/openvswitch/Makefile1
4 files changed, 7 insertions, 0 deletions
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 8b0126c27d6d..d4b9e3e6f696 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -10,6 +10,8 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= danilo@FreeBSD.org
COMMENT= General purpose TCP/IP proxy system
+BROKEN_mips= fails to build: gmake[1]: *** [Makefile:116: mkmake.exe] Error 1
+BROKEN_mips64= fails to build: gmake[1]: *** [Makefile:116: mkmake.exe] Error 1
BROKEN_powerpc64= fails to build: gmake[1]: *** [Makefile:116: mkmake.exe] Error 1
USES= gmake
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 2728062298ad..26de0d847500 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -17,6 +17,8 @@ COMMENT= Free RADIUS server implementation
LICENSE= GPLv2
+BROKEN_mips= fails to compile: unrecognized command line option "-Wno-date-time"
+BROKEN_mips64= fails to compile: unrecognized command line option "-Wno-date-time"
BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-date-time"
LIB_DEPENDS= libgdbm.so:databases/gdbm \
diff --git a/net/ndproxy/Makefile b/net/ndproxy/Makefile
index 36258931b4e4..e7e3d2902188 100644
--- a/net/ndproxy/Makefile
+++ b/net/ndproxy/Makefile
@@ -11,6 +11,8 @@ COMMENT= Implementation of IPv6 Neighbor Discovery proxy
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_mips= fails to build: ndproxy.c:51: function declaration isn't a prototype
+BROKEN_mips64= fails to build: ndproxy.c:51: function declaration isn't a prototype
BROKEN_powerpc64= fails to build: ndproxy.c:51: function declaration isn't a prototype
SUB_FILES= pkg-message
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 4649638c00c3..e12e7640b3bc 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -11,6 +11,7 @@ COMMENT= Production quality, multilayer virtual switch
LICENSE= APACHE20
+BROKEN_mips64= fails to compile: ofp-actions.h:486: flexible array member in otherwise empty struct
BROKEN_powerpc64= fails to compile: bfd.c: internal compiler error: in extract_insn, at recog.c
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}