aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2018-10-20 23:26:26 +0800
committerzi <zi@FreeBSD.org>2018-10-20 23:26:26 +0800
commit5b7b4ba4948f1881db40b8fd0900368b7f431530 (patch)
tree7f3fc3360e2e5d5d93cfa59c528d1518d9d4f277 /net
parent5ee6fdc514309db5e3654593979cb3cdfd97bd3b (diff)
downloadfreebsd-ports-gnome-5b7b4ba4948f1881db40b8fd0900368b7f431530.tar.gz
freebsd-ports-gnome-5b7b4ba4948f1881db40b8fd0900368b7f431530.tar.zst
freebsd-ports-gnome-5b7b4ba4948f1881db40b8fd0900368b7f431530.zip
New port: devel/p5-Twitter-API:
Twitter::API provides an interface to the Twitter REST API for perl. Features: * full support for all Twitter REST API endpoints * not dependent on a new distribution for new endpoint support * optionally specify access tokens per API call * error handling via an exception object that captures the full request/response context * full support for OAuth handshake and Xauth authentication Additional features are available via optional traits: * convenient methods for API endpoints with simplified argument handling via ApiMethods * normalized booleans (Twitter likes 'true' and 'false', except when it doesn't) via NormalizeBooleans * automatic decoding of HTML entities via DecodeHtmlEntities * automatic retry on transient errors via RetryOnError * "the whole enchilada" combines all the above traits via Enchilada * app-only (OAuth2) support via AppAuth * automatic rate limiting via RateLimiting WWW: https://metacpan.org/release/Twitter-API
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Twitter-API/Makefile40
-rw-r--r--net/p5-Twitter-API/distinfo3
-rw-r--r--net/p5-Twitter-API/pkg-descr22
-rw-r--r--net/p5-Twitter-API/pkg-plist26
5 files changed, 92 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4aaf5ddb45f2..0b2210ab6590 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -880,6 +880,7 @@
SUBDIR += p5-Sort-Key-IPv4
SUBDIR += p5-TFTP
SUBDIR += p5-Test-URI
+ SUBDIR += p5-Twitter-API
SUBDIR += p5-URI
SUBDIR += p5-URI-FromHash
SUBDIR += p5-URI-Match
diff --git a/net/p5-Twitter-API/Makefile b/net/p5-Twitter-API/Makefile
new file mode 100644
index 000000000000..683a460ddadb
--- /dev/null
+++ b/net/p5-Twitter-API/Makefile
@@ -0,0 +1,40 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Twitter-API
+PORTVERSION= 1.0005
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A Twitter REST API library for Perl
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-Twitter>0:net/p5-Net-Twitter \
+ p5-Devel-StackTrace>=1.21:devel/p5-Devel-StackTrace \
+ p5-Digest-HMAC>0:security/p5-Digest-HMAC \
+ p5-IO-Socket-SSL>0:security/p5-IO-Socket-SSL \
+ p5-JSON-MaybeXS>0:converters/p5-JSON-MaybeXS \
+ p5-Moo>0:devel/p5-Moo \
+ p5-MooX-Aliases>0:devel/p5-MooX-Aliases \
+ p5-MooX-Traits>0:devel/p5-MooX-Traits \
+ p5-Net-OAuth>0:net/p5-Net-OAuth \
+ p5-Ref-Util>0:devel/p5-Ref-Util \
+ p5-Throwable>0:devel/p5-Throwable \
+ p5-Try-Tiny>0.03:lang/p5-Try-Tiny \
+ p5-URI>=1.40:net/p5-URI \
+ p5-URL-Encode>0:www/p5-URL-Encode \
+ p5-WWW-OAuth>0:www/p5-WWW-OAuth \
+ p5-libwww>=2.032:www/p5-libwww \
+ p5-namespace-clean>0:devel/p5-namespace-clean
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= modbuildtiny
+
+.include <bsd.port.mk>
diff --git a/net/p5-Twitter-API/distinfo b/net/p5-Twitter-API/distinfo
new file mode 100644
index 000000000000..1d0f4d5ab1c2
--- /dev/null
+++ b/net/p5-Twitter-API/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1540034621
+SHA256 (Twitter-API-1.0005.tar.gz) = e65242efcbbfec7ffac9f62fa6778fbbbd3dea539ebb537c187e274737079e2d
+SIZE (Twitter-API-1.0005.tar.gz) = 56000
diff --git a/net/p5-Twitter-API/pkg-descr b/net/p5-Twitter-API/pkg-descr
new file mode 100644
index 000000000000..84932bfeddfb
--- /dev/null
+++ b/net/p5-Twitter-API/pkg-descr
@@ -0,0 +1,22 @@
+Twitter::API provides an interface to the Twitter REST API for perl.
+
+Features:
+ * full support for all Twitter REST API endpoints
+ * not dependent on a new distribution for new endpoint support
+ * optionally specify access tokens per API call
+ * error handling via an exception object that captures the full
+ request/response context
+ * full support for OAuth handshake and Xauth authentication
+
+Additional features are available via optional traits:
+ * convenient methods for API endpoints with simplified argument
+ handling via ApiMethods
+ * normalized booleans (Twitter likes 'true' and 'false', except
+ when it doesn't) via NormalizeBooleans
+ * automatic decoding of HTML entities via DecodeHtmlEntities
+ * automatic retry on transient errors via RetryOnError
+ * "the whole enchilada" combines all the above traits via Enchilada
+ * app-only (OAuth2) support via AppAuth
+ * automatic rate limiting via RateLimiting
+
+WWW: https://metacpan.org/release/Twitter-API
diff --git a/net/p5-Twitter-API/pkg-plist b/net/p5-Twitter-API/pkg-plist
new file mode 100644
index 000000000000..abf8cdccf30b
--- /dev/null
+++ b/net/p5-Twitter-API/pkg-plist
@@ -0,0 +1,26 @@
+%%SITE_PERL%%/Twitter/API.pm
+%%SITE_PERL%%/Twitter/API/Context.pm
+%%SITE_PERL%%/Twitter/API/Error.pm
+%%SITE_PERL%%/Twitter/API/Role/RequestArgs.pm
+%%SITE_PERL%%/Twitter/API/Trait/ApiMethods.pm
+%%SITE_PERL%%/Twitter/API/Trait/AppAuth.pm
+%%SITE_PERL%%/Twitter/API/Trait/DecodeHtmlEntities.pm
+%%SITE_PERL%%/Twitter/API/Trait/Enchilada.pm
+%%SITE_PERL%%/Twitter/API/Trait/Migration.pm
+%%SITE_PERL%%/Twitter/API/Trait/NormalizeBooleans.pm
+%%SITE_PERL%%/Twitter/API/Trait/RateLimiting.pm
+%%SITE_PERL%%/Twitter/API/Trait/RetryOnError.pm
+%%SITE_PERL%%/Twitter/API/Util.pm
+%%PERL5_MAN3%%/Twitter::API.3.gz
+%%PERL5_MAN3%%/Twitter::API::Context.3.gz
+%%PERL5_MAN3%%/Twitter::API::Error.3.gz
+%%PERL5_MAN3%%/Twitter::API::Role::RequestArgs.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::ApiMethods.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::AppAuth.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::DecodeHtmlEntities.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::Enchilada.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::Migration.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::NormalizeBooleans.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::RateLimiting.3.gz
+%%PERL5_MAN3%%/Twitter::API::Trait::RetryOnError.3.gz
+%%PERL5_MAN3%%/Twitter::API::Util.3.gz