aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-01-23 21:09:55 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-01-23 21:09:55 +0800
commit682f31469c964ded36240904f1d32884c0ab9cc4 (patch)
tree15a883d0547d9f8df2442abccfcd3b61cd7b9a50 /net
parenta5a47efba1c063c396bd1977019cd0947995310c (diff)
downloadfreebsd-ports-gnome-682f31469c964ded36240904f1d32884c0ab9cc4.tar.gz
freebsd-ports-gnome-682f31469c964ded36240904f1d32884c0ab9cc4.tar.zst
freebsd-ports-gnome-682f31469c964ded36240904f1d32884c0ab9cc4.zip
Use $SUB_FILES to dynamically update pkg-message
PR: 143109 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk>
Diffstat (limited to 'net')
-rw-r--r--net/micro_proxy/Makefile3
-rw-r--r--net/micro_proxy/files/pkg-message.in (renamed from net/micro_proxy/pkg-message)0
2 files changed, 2 insertions, 1 deletions
diff --git a/net/micro_proxy/Makefile b/net/micro_proxy/Makefile
index b26ae8573044..0f12ebfdcb2e 100644
--- a/net/micro_proxy/Makefile
+++ b/net/micro_proxy/Makefile
@@ -20,6 +20,7 @@ MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= libexec/micro_proxy
MAN8= micro_proxy.8
+SUB_FILES= pkg-message
do-build:
${CC} ${CFLAGS} -c ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}.o
@@ -30,6 +31,6 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${MANPREFIX}/man/man8
post-install:
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/micro_proxy/pkg-message b/net/micro_proxy/files/pkg-message.in
index 83738e8a1d19..83738e8a1d19 100644
--- a/net/micro_proxy/pkg-message
+++ b/net/micro_proxy/files/pkg-message.in