aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorroger <roger@FreeBSD.org>2000-11-23 01:51:42 +0800
committerroger <roger@FreeBSD.org>2000-11-23 01:51:42 +0800
commit6bc713c65986e624ab49fb06234e20a3a165102f (patch)
treeffaf48c557bd2e31c031194de06fcedfd5c62c31 /net
parent970ac33e696ed816d5b1badd7527a5cff0096ba8 (diff)
downloadfreebsd-ports-gnome-6bc713c65986e624ab49fb06234e20a3a165102f.tar.gz
freebsd-ports-gnome-6bc713c65986e624ab49fb06234e20a3a165102f.tar.zst
freebsd-ports-gnome-6bc713c65986e624ab49fb06234e20a3a165102f.zip
Add OpenH323 Proxy. This is based on OpenGatekeeper and adds H323
Proxy functions. This means you can use H323 clients (like OhPhone and NetMeeting) through FireWalls and with NAT.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/openh323proxy/Makefile34
-rw-r--r--net/openh323proxy/distinfo1
-rw-r--r--net/openh323proxy/files/patch-aa19
-rw-r--r--net/openh323proxy/files/patch-ab38
-rw-r--r--net/openh323proxy/files/patch-ac30
-rw-r--r--net/openh323proxy/pkg-comment1
-rw-r--r--net/openh323proxy/pkg-descr15
-rw-r--r--net/openh323proxy/pkg-plist1
9 files changed, 140 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 465657cc45e1..f7a3ac32dfb9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -173,6 +173,7 @@
SUBDIR += openam
SUBDIR += opengatekeeper
SUBDIR += openh323
+ SUBDIR += openh323proxy
SUBDIR += openldap
SUBDIR += openldap2
SUBDIR += openmcu
diff --git a/net/openh323proxy/Makefile b/net/openh323proxy/Makefile
new file mode 100644
index 000000000000..3f7551a9c80a
--- /dev/null
+++ b/net/openh323proxy/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: openh323proxy
+# Date created: Tue Nov 21 12:59:00 GMT 2000
+# Whom: Roger Hardiman <roger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openh323proxy
+PORTVERSION= 0.9a3.m08
+CATEGORIES= net
+MASTER_SITES= http://download.sourceforge.net/openh323proxy/
+DISTNAME= ${PORTNAME}_0.9a3_m08
+
+MAINTAINER= roger@FreeBSD.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/net/openh323:build
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NOCLEANDEPENDS= yes
+
+USE_NEWGCC= yes
+USE_BISON= yes
+USE_GMAKE= yes
+ALL_TARGET= opt
+MAKE_ENV= PWLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/pwlib \
+ OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323
+THE_MACHTYPE= ${ARCH:S/i386/x86/}
+MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/obj_${OPSYS}_${THE_MACHTYPE}_r/opengate_proxy ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/openh323proxy/distinfo b/net/openh323proxy/distinfo
new file mode 100644
index 000000000000..caa0206c7602
--- /dev/null
+++ b/net/openh323proxy/distinfo
@@ -0,0 +1 @@
+MD5 (openh323proxy_0.9a3_m08.tar.gz) = 6a94049a8cf965e41e15a382cf1b93a2
diff --git a/net/openh323proxy/files/patch-aa b/net/openh323proxy/files/patch-aa
new file mode 100644
index 000000000000..755a523ccc86
--- /dev/null
+++ b/net/openh323proxy/files/patch-aa
@@ -0,0 +1,19 @@
+*** Makefile.orig Wed Nov 22 14:00:59 2000
+--- Makefile Wed Nov 22 14:00:02 2000
+***************
+*** 70,76 ****
+ #
+
+
+! PROG = opengate
+ SOURCES = opengate.cxx EndpointTabl.cxx RasThread.cxx RasServer.cxx MulticastThread.cxx \
+ AddrUtils.cxx Log.cxx CallTabl.cxx CallThread.cxx Environ.cxx DNSUtils.cxx \
+ Proxy.cxx ProxyTabl.cxx ProxyThread.cxx ProxyCriteria.cxx
+--- 70,76 ----
+ #
+
+
+! PROG = opengate_proxy
+ SOURCES = opengate.cxx EndpointTabl.cxx RasThread.cxx RasServer.cxx MulticastThread.cxx \
+ AddrUtils.cxx Log.cxx CallTabl.cxx CallThread.cxx Environ.cxx DNSUtils.cxx \
+ Proxy.cxx ProxyTabl.cxx ProxyThread.cxx ProxyCriteria.cxx
diff --git a/net/openh323proxy/files/patch-ab b/net/openh323proxy/files/patch-ab
new file mode 100644
index 000000000000..55376d2e5ae7
--- /dev/null
+++ b/net/openh323proxy/files/patch-ab
@@ -0,0 +1,38 @@
+*** opengate.cxx.orig Thu Oct 26 13:05:21 2000
+--- opengate.cxx Wed Nov 22 13:59:34 2000
+*************** static PSemaphore TerminatedSema(0,1);
+*** 101,107 ****
+ PCREATE_PROCESS(opengate)
+
+ opengate::opengate()
+! : PServiceProcess("Egoboo", "opengate",
+ GKVER_MAJOR, GKVER_MINOR, GKVER_STATUS, GKVER_BUILD
+ )
+ {
+--- 101,107 ----
+ PCREATE_PROCESS(opengate)
+
+ opengate::opengate()
+! : PServiceProcess("Marco Polci and Egoboo", "openh323proxy",
+ GKVER_MAJOR, GKVER_MINOR, GKVER_STATUS, GKVER_BUILD
+ )
+ {
+*************** void opengate::Main()
+*** 165,172 ****
+ PString AkaLocalAddr = Cfg.GetString( "Local Address", "*" );
+ MyEnviron.LocalAddr = AkaLocalAddr;
+
+! // Set the gatekeeper id, the default is "Opengate: " + hostname
+! PString AkaMyId = Cfg.GetString( "Gatekeeper Id", (PString) "Opengate: " + PIPSocket::GetHostName() );
+ MyEnviron.MyId = AkaMyId;
+ // if ( MyEnviron.LocalAddr == INADDR_ANY )
+ // PIPSocket::GetHostAddress( MyEnviron.LocalAddr );
+--- 165,172 ----
+ PString AkaLocalAddr = Cfg.GetString( "Local Address", "*" );
+ MyEnviron.LocalAddr = AkaLocalAddr;
+
+! // Set the gatekeeper id, the default is "OpengateProxy: " + hostname
+! PString AkaMyId = Cfg.GetString( "Gatekeeper Id", (PString) "OpengateProxy: " + PIPSocket::GetHostName() );
+ MyEnviron.MyId = AkaMyId;
+ // if ( MyEnviron.LocalAddr == INADDR_ANY )
+ // PIPSocket::GetHostAddress( MyEnviron.LocalAddr );
diff --git a/net/openh323proxy/files/patch-ac b/net/openh323proxy/files/patch-ac
new file mode 100644
index 000000000000..4c29fe697628
--- /dev/null
+++ b/net/openh323proxy/files/patch-ac
@@ -0,0 +1,30 @@
+*** Log.cxx.orig Mon Oct 16 14:39:43 2000
+--- Log.cxx Wed Nov 22 13:59:51 2000
+*************** OpengateLog::OpengateLog() : Cfg("Log")
+*** 66,72 ****
+ PTime now;
+ PString DateStamp = now.AsString("hh:mm:ss dd/MM/yyyy");
+ PString StartupMsg = "Starting logging: ";
+! LogFilename = Cfg.GetString("File", "OpengateLog.txt");
+
+ // Check to see if logging has been requested
+ // If none then do not open log file
+--- 66,72 ----
+ PTime now;
+ PString DateStamp = now.AsString("hh:mm:ss dd/MM/yyyy");
+ PString StartupMsg = "Starting logging: ";
+! LogFilename = Cfg.GetString("File", "opengate_proxy.log");
+
+ // Check to see if logging has been requested
+ // If none then do not open log file
+*************** void OpengateLog::LogH245Msg(const H245_
+*** 268,271 ****
+ }
+ WriteTrailer();
+ }
+! }
+--- 268,271 ----
+ }
+ WriteTrailer();
+ }
+! }
diff --git a/net/openh323proxy/pkg-comment b/net/openh323proxy/pkg-comment
new file mode 100644
index 000000000000..af5d9f1b2cf3
--- /dev/null
+++ b/net/openh323proxy/pkg-comment
@@ -0,0 +1 @@
+Proxy for Videoconferencing and VoIP using H323 (eg OhPhone and NetMeeting)
diff --git a/net/openh323proxy/pkg-descr b/net/openh323proxy/pkg-descr
new file mode 100644
index 000000000000..65b379bdfd54
--- /dev/null
+++ b/net/openh323proxy/pkg-descr
@@ -0,0 +1,15 @@
+OpenH323Proxy is a Gatekeeper and Proxy for Video Conferencing and
+Internet Phone (VoIP) applications using the H323 protocol.
+
+The H323 protocol is used by OpenH323, OhPhone and Microsoft's NetMeeting
+plus many other applications.
+
+It makes use of PWLib and the OpenH323 stack from Equivalence Ltd Pty
+and as it is based on OpenGatekeeper from Egoboo, it is a
+gatekeeper as well as a proxy.
+
+WWW: http://openh323proxy.sourceforge.net/
+
+and
+
+WWW: http://www.openh323.org/
diff --git a/net/openh323proxy/pkg-plist b/net/openh323proxy/pkg-plist
new file mode 100644
index 000000000000..078b9b6b1222
--- /dev/null
+++ b/net/openh323proxy/pkg-plist
@@ -0,0 +1 @@
+bin/opengate_proxy