aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwoodsb02 <woodsb02@FreeBSD.org>2017-06-07 22:47:29 +0800
committerwoodsb02 <woodsb02@FreeBSD.org>2017-06-07 22:47:29 +0800
commit70a395788b09295ffdb31e1f8b65f2284527bddb (patch)
tree01d42570e83f690b6923705654d52a4a183be8b7 /net
parentb05018fa20c1918aa4538aeb8d140b220fee87f4 (diff)
downloadfreebsd-ports-gnome-70a395788b09295ffdb31e1f8b65f2284527bddb.tar.gz
freebsd-ports-gnome-70a395788b09295ffdb31e1f8b65f2284527bddb.tar.zst
freebsd-ports-gnome-70a395788b09295ffdb31e1f8b65f2284527bddb.zip
[NEW] net/py3-urllib3: Create Python 3.x version of port
The latest www/py-requests update [1] unbundled its dependencies, now requiring chardet, idna, urllib3 and certifi from ports. www/py3-requests port was not tested during QA, which would have highlighted the need for many new py3-* ports (and their dependencies). This change creates one of those ports. [1] https://svnweb.freebsd.org/changeset/ports/442565 PR: 219833
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-urllib3/Makefile4
-rw-r--r--net/py3-urllib3/Makefile14
3 files changed, 17 insertions, 2 deletions
diff --git a/net/Makefile b/net/Makefile
index b229433f513e..e92f79efaad5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1078,6 +1078,7 @@
SUBDIR += py-zsi
SUBDIR += py3-netifaces
SUBDIR += py3-pysocks
+ SUBDIR += py3-urllib3
SUBDIR += pygopherd
SUBDIR += pynids
SUBDIR += pyrad
diff --git a/net/py-urllib3/Makefile b/net/py-urllib3/Makefile
index 508b675b39f3..1d06e32c2900 100644
--- a/net/py-urllib3/Makefile
+++ b/net/py-urllib3/Makefile
@@ -13,12 +13,12 @@ COMMENT= HTTP library with thread-safe connection pooling, file post, and more
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography \
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py-idna \
${PYTHON_PKGNAMEPREFIX}openssl>=16.0:security/py-openssl \
${PYTHON_PKGNAMEPREFIX}pysocks>=1.5.7:net/py-pysocks
-USES= python
+USES?= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
SUB_FILES= pkg-message
diff --git a/net/py3-urllib3/Makefile b/net/py3-urllib3/Makefile
new file mode 100644
index 000000000000..3d6fd3a406ad
--- /dev/null
+++ b/net/py3-urllib3/Makefile
@@ -0,0 +1,14 @@
+# Created by: Ben Woods <woodsb02@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-urllib3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py3-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py3-idna \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=16.0:security/py3-openssl \
+ ${PYTHON_PKGNAMEPREFIX}pysocks>=1.5.7:net/py3-pysocks
+
+USES= python:3.3+
+
+.include "${MASTERDIR}/Makefile"
+