aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-04 18:01:09 +0800
committermat <mat@FreeBSD.org>2016-07-04 18:01:09 +0800
commit772686f6f0d213c88ef6053b31df55fefcde45d6 (patch)
tree78417e9166c5257afcc507a7fb6f1fcc85a5991d /net
parentd86001faa8e6e543a77573b339e895636a2ede9d (diff)
downloadfreebsd-ports-gnome-772686f6f0d213c88ef6053b31df55fefcde45d6.tar.gz
freebsd-ports-gnome-772686f6f0d213c88ef6053b31df55fefcde45d6.tar.zst
freebsd-ports-gnome-772686f6f0d213c88ef6053b31df55fefcde45d6.zip
Fix ports depending on security/(open|libre)ssl directly.
Sponsored by: Absolight
Diffstat (limited to 'net')
-rw-r--r--net/openntpd/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index f606b5b73f6d..3a5c55c97e1f 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -28,7 +28,6 @@ OPTIONS_DEFAULT= RESSL
# Requires libtls from LibreSSL
RESSL_USE= openssl=yes
RESSL_VARS= with_openssl_port=yes \
- openssl_port=security/libressl
RESSL_CONFIGURE_WITH= cacert=${LOCALBASE}/etc/ssl/cert.pem
RESSL_CPPFLAGS= -I${LOCALBASE}/include
RESSL_LDFLAGS= -L${LOCALBASE}/lib
@@ -41,4 +40,10 @@ pre-build:
post-install:
cd ${STAGEDIR}${PREFIX}/etc && ${MV} ntpd.conf ntpd.conf.sample
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MRESSL} && empty(SSL_DEFAULT:Mlibressl*)
+IGNORE= Requires LibreSSL from ports, define DEFAULT_VERSIONS+=ssl=libressl in your make.conf and rebuild everything.
+.endif
+
+.include <bsd.port.post.mk>