aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-06-20 07:50:31 +0800
committerjgh <jgh@FreeBSD.org>2012-06-20 07:50:31 +0800
commit7a241ecc5e36d6aab8f7cc47301efb8fb07272d9 (patch)
treecbcc337e0179b568a9ddee7aaddcc971eff0d1cb /net
parente5963eade2cfcb6bea07f05a3455c853cc4679ee (diff)
downloadfreebsd-ports-gnome-7a241ecc5e36d6aab8f7cc47301efb8fb07272d9.tar.gz
freebsd-ports-gnome-7a241ecc5e36d6aab8f7cc47301efb8fb07272d9.tar.zst
freebsd-ports-gnome-7a241ecc5e36d6aab8f7cc47301efb8fb07272d9.zip
- adopt optionsNG
- while here shift license section (portlint), and use stardard licenses PR: ports/169244 Submitted by: maintainer, rabbitmq@geoffgarside.co.uk
Diffstat (limited to 'net')
-rw-r--r--net/rabbitmq-c/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/net/rabbitmq-c/Makefile b/net/rabbitmq-c/Makefile
index 7e0acaf77627..d9c6b9ed1c8e 100644
--- a/net/rabbitmq-c/Makefile
+++ b/net/rabbitmq-c/Makefile
@@ -19,6 +19,9 @@ DIST_SUBDIR= rabbitmq
MAINTAINER= rabbitmq@geoffgarside.co.uk
COMMENT= RabbitMQ C AMQP client library
+LICENSE= GPLv2 MPL
+LICENSE_COMB= dual
+
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0:${PORTSDIR}/devel/py-simplejson
CONFLICTS= rabbitmq-c-devel-[0-9]*
@@ -32,23 +35,19 @@ USE_AUTOTOOLS= aclocal autoconf automake autoheader libtool
AUTOMAKE_ARGS= -i --add-missing
ACLOCAL_ARGS= -I . -I ${LOCALBASE}/share/aclocal
-LICENSE= GPLv2 MPL
-LICENSE_COMB= dual
-LICENSE_FILE_MPL= ${WRKSRC}/LICENSE-GPL-2.0
-LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSE-MPL-RabbitMQ
-
-OPTIONS= 64BIT "Produce 64-bit library" Off \
- POPT "Popt support in tools" Off
+OPTIONS_DEFINE= 64BIT POPT
+64BIT_DESC= Produce 64-bit library
+POPT_DESC= Popt support in tools
.include <bsd.port.options.mk>
-.if defined(WITH_64BIT)
+.if ${PORT_OPTIONS:M64BIT}
ONLY_FOR_ARCHS= amd64 sparc64 powerpc
-ONLY_FOR_ARCHS_REASON= WITH_64BIT is set
+ONLY_FOR_ARCHS_REASON= 64BIT option is set
CONFIGURE_ARGS+= --enable-64-bit
.endif
-.if defined(WITH_POPT)
+.if ${PORT_OPTIONS:MPOPT}
LIB_DEPENDS+= popt.0:${PORTSDIR}/devel/popt
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib