aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-02 12:31:39 +0800
committeryuri <yuri@FreeBSD.org>2018-07-02 12:31:39 +0800
commit807b9a8bfbef8c45c191d2ed66057505eeae643b (patch)
treeade1b5a2b4307c1fea5b0145c97ae3661cc68505 /net
parent5b460a6e6dcba3bf614469ba987dfba042c883e4 (diff)
downloadfreebsd-ports-gnome-807b9a8bfbef8c45c191d2ed66057505eeae643b.tar.gz
freebsd-ports-gnome-807b9a8bfbef8c45c191d2ed66057505eeae643b.tar.zst
freebsd-ports-gnome-807b9a8bfbef8c45c191d2ed66057505eeae643b.zip
net/mpich2: Unbreak build by setting BASH_SHELL environment variable
Without it it was failing for me with wrong bash interpreter path in all executables (ex. mpicxx). Not sure why central builds weren't failing, but configrure expects BASH_SHELL to be set. Also order USExx section. Approved by: portmgr
Diffstat (limited to 'net')
-rw-r--r--net/mpich2/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index c6dd3afc28ab..e22a83c61f0a 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -20,9 +20,9 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= bash:shells/bash
RUN_DEPENDS= bash:shells/bash
-GNU_CONFIGURE= yes
USES= libtool:keepla localbase fortran perl5 \
pkgconfig python:2.7
+GNU_CONFIGURE= yes
USE_GCC= yes
USE_LDCONFIG= yes
USE_PERL5= build
@@ -44,7 +44,8 @@ CONFIGURE_ARGS= --enable-romio --enable-shared \
CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
MPI_CFLAGS="-I${LOCALBASE}/include" \
PACKAGE="${PORTNAME}" \
- PTHREAD_LIBS="-lpthread"
+ PTHREAD_LIBS="-lpthread" \
+ BASH_SHELL="${LOCALBASE}/bin/bash"
.if ${FFLAGS} == "-O"
FFLAGS= -O2