aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-01-08 03:26:43 +0800
committerpav <pav@FreeBSD.org>2004-01-08 03:26:43 +0800
commit8acb2306ca9689a8d852c08a4e05464a04e1b673 (patch)
treeedb08b2624435574245aea686f0f0189229d8109 /net
parenta2f338a61dafcf2da545af9b6b86ce1f7485faa7 (diff)
downloadfreebsd-ports-gnome-8acb2306ca9689a8d852c08a4e05464a04e1b673.tar.gz
freebsd-ports-gnome-8acb2306ca9689a8d852c08a4e05464a04e1b673.tar.zst
freebsd-ports-gnome-8acb2306ca9689a8d852c08a4e05464a04e1b673.zip
- Fix build with ocaml-3.07_1
PR: ports/61012 Submitted by: Holger Lamm <holger@e-gitt.net> (maintainer)
Diffstat (limited to 'net')
-rw-r--r--net/mldonkey-devel/Makefile2
-rw-r--r--net/mldonkey-devel/files/patch-configure11
-rw-r--r--net/mldonkey/Makefile2
-rw-r--r--net/mldonkey/files/patch-configure11
4 files changed, 24 insertions, 2 deletions
diff --git a/net/mldonkey-devel/Makefile b/net/mldonkey-devel/Makefile
index f0323743d647..8032c0a7a769 100644
--- a/net/mldonkey-devel/Makefile
+++ b/net/mldonkey-devel/Makefile
@@ -18,7 +18,7 @@ COMMENT?= A OCAML client for multiple peer-to-peer networks
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-pthread
+CONFIGURE_ARGS= --enable-pthread --enable-ocamlver=3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.(.)$/-\1/}
USE_GMAKE= yes
ALL_TARGET= depend opt
diff --git a/net/mldonkey-devel/files/patch-configure b/net/mldonkey-devel/files/patch-configure
new file mode 100644
index 000000000000..f0efc85a7e90
--- /dev/null
+++ b/net/mldonkey-devel/files/patch-configure
@@ -0,0 +1,11 @@
+--- config/configure.orig Sun Oct 12 20:41:28 2003
++++ config/configure Wed Jan 7 13:24:29 2004
+@@ -3651,7 +3651,7 @@
+
+ case "$OCAMLVERSION" in
+ 3.06) TYPE_FORMAT="";;
+- 3.07) TYPE_FORMAT="";;
++ 3.07*) TYPE_FORMAT="";;
+ *) TYPE_FORMAT="type ('a,'b,'c) ml_format = ('a,'b, 'c,'c) format type ('a,'b,'c) format = ('a,'b, 'c) ml_format";;
+ esac
+
diff --git a/net/mldonkey/Makefile b/net/mldonkey/Makefile
index f0323743d647..8032c0a7a769 100644
--- a/net/mldonkey/Makefile
+++ b/net/mldonkey/Makefile
@@ -18,7 +18,7 @@ COMMENT?= A OCAML client for multiple peer-to-peer networks
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-pthread
+CONFIGURE_ARGS= --enable-pthread --enable-ocamlver=3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.(.)$/-\1/}
USE_GMAKE= yes
ALL_TARGET= depend opt
diff --git a/net/mldonkey/files/patch-configure b/net/mldonkey/files/patch-configure
new file mode 100644
index 000000000000..f0efc85a7e90
--- /dev/null
+++ b/net/mldonkey/files/patch-configure
@@ -0,0 +1,11 @@
+--- config/configure.orig Sun Oct 12 20:41:28 2003
++++ config/configure Wed Jan 7 13:24:29 2004
+@@ -3651,7 +3651,7 @@
+
+ case "$OCAMLVERSION" in
+ 3.06) TYPE_FORMAT="";;
+- 3.07) TYPE_FORMAT="";;
++ 3.07*) TYPE_FORMAT="";;
+ *) TYPE_FORMAT="type ('a,'b,'c) ml_format = ('a,'b, 'c,'c) format type ('a,'b,'c) format = ('a,'b, 'c) ml_format";;
+ esac
+