aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-09 20:35:47 +0800
committeredwin <edwin@FreeBSD.org>2003-09-09 20:35:47 +0800
commit9628afde92aab8514e07d6d34d7f5e6380dec649 (patch)
tree9976023f6bfca69c294b8debe6d063a277752b13 /net
parent0b3e1300efbb468986db7a366e32959da5dc5368 (diff)
downloadfreebsd-ports-gnome-9628afde92aab8514e07d6d34d7f5e6380dec649.tar.gz
freebsd-ports-gnome-9628afde92aab8514e07d6d34d7f5e6380dec649.tar.zst
freebsd-ports-gnome-9628afde92aab8514e07d6d34d7f5e6380dec649.zip
New ports: coda6_server and coda6_client
I've just added the kernel support for Coda 6.x. It would be great to have the server and client in the ports collection to make it easier for people to experiment with. PR: ports/56623 Submitted by: Tim Robbins <tim@robbins.dropbear.id.au>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/coda6_client/Makefile19
-rw-r--r--net/coda6_client/pkg-descr11
-rw-r--r--net/coda6_client/pkg-plist30
4 files changed, 61 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 83ba2738a8f3..ade58d943ba9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -67,6 +67,7 @@
SUBDIR += coda5_client
SUBDIR += coda5_doc
SUBDIR += coda5_server
+ SUBDIR += coda6_client
SUBDIR += coda6_server
SUBDIR += coda_doc
SUBDIR += coda_intro
diff --git a/net/coda6_client/Makefile b/net/coda6_client/Makefile
new file mode 100644
index 000000000000..e7302bf593d9
--- /dev/null
+++ b/net/coda6_client/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: coda6_client
+# Date created: 9 September 2003
+# Whom: Tim Robbins <tim@robbins.dropbear.id.au>
+#
+# $FreeBSD$
+
+PORTNAME= coda
+PORTVERSION= ${CODA_VERSION}
+
+COMMENT= Client programs for a replicated high-performance network file system
+
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
+
+MASTERDIR= ${.CURDIR}/../coda6_server
+PKGDIR= ${.CURDIR}
+
+CODA_SUITE= client
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/coda6_client/pkg-descr b/net/coda6_client/pkg-descr
new file mode 100644
index 000000000000..43eb0a4bc1d4
--- /dev/null
+++ b/net/coda6_client/pkg-descr
@@ -0,0 +1,11 @@
+Coda is a distributed file system. Among its features are disconnected
+operation, good security model, server replication and persistent
+client side caching.
+
+This package builds the entire source tree but only installs(/packages)
+the client side programs.
+
+For more info, contact information available below.
+
+EMAIL: coda@cs.cmu.edu
+WWW: http://www.coda.cs.cmu.edu/
diff --git a/net/coda6_client/pkg-plist b/net/coda6_client/pkg-plist
new file mode 100644
index 000000000000..f174294a477d
--- /dev/null
+++ b/net/coda6_client/pkg-plist
@@ -0,0 +1,30 @@
+bin/cfs
+bin/clog
+bin/cmon
+bin/codacon
+bin/cpasswd
+bin/ctokens
+bin/cunlog
+bin/filerepair
+bin/hoard
+bin/mklka
+bin/parser
+bin/removeinc
+bin/repair
+bin/coda_replay
+bin/spy
+bin/xaskuser
+bin/xfrepair
+etc/coda/realms
+etc/coda/sidekick.intr.ex
+etc/coda/venus.conf.ex
+sbin/au
+sbin/coda-client-logrotate
+sbin/coda-setup-ports
+sbin/codaconfedit
+sbin/sidekick
+sbin/venus
+sbin/venus-setup
+sbin/volmunge
+sbin/vutil
+@dirrm etc/coda