aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-07-02 16:31:21 +0800
committerwill <will@FreeBSD.org>2000-07-02 16:31:21 +0800
commita38b1e089200ba0ca8316600208c87d39b6ea07c (patch)
tree79cb7e1fe57516d96269af4a96cdda21fa41807f /net
parent2a3b6b8ae6c81e7b10af62ad0f7182bcaeb58c2f (diff)
downloadfreebsd-ports-gnome-a38b1e089200ba0ca8316600208c87d39b6ea07c.tar.gz
freebsd-ports-gnome-a38b1e089200ba0ca8316600208c87d39b6ea07c.tar.zst
freebsd-ports-gnome-a38b1e089200ba0ca8316600208c87d39b6ea07c.zip
Add vtun, which is "the easiest way to create Virtual Tunnels over TCP/IP
networks with traffic shaping, compression and encryption." PR: 16629 Submitted by: kevlo
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/vtun/Makefile32
-rw-r--r--net/vtun/distinfo1
-rw-r--r--net/vtun/pkg-comment1
-rw-r--r--net/vtun/pkg-descr10
-rw-r--r--net/vtun/pkg-plist4
6 files changed, 49 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fbefb3ccb1f8..23c0b6999df4 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -231,6 +231,7 @@
SUBDIR += tund
SUBDIR += ucd-snmp
SUBDIR += vnc
+ SUBDIR += vtun
SUBDIR += wais
SUBDIR += wide-dhcp
SUBDIR += wmnet
diff --git a/net/vtun/Makefile b/net/vtun/Makefile
new file mode 100644
index 000000000000..305cafab061d
--- /dev/null
+++ b/net/vtun/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: vtun
+# Date created: 05 Feb 2000
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vtun
+PORTVERSION= 2.3
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= vtun
+
+MAINTAINER= kevlo@FreeBSD.org
+
+LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
+
+MAN5= vtund.conf.5
+MAN8= vtund.8
+MANCOMPRESSED= no
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--localstatedir=/var \
+ --with-crypto-headers=${LOCALBASE}/include/openssl \
+ --with-crypto-lib=${LOCALBASE}/lib \
+ --with-lzo-headers=${LOCALBASE}/include \
+ --with-lzo-lib=${LOCALBASE}/lib
+
+ALL_TARGET= vtund
+
+.include <bsd.port.mk>
diff --git a/net/vtun/distinfo b/net/vtun/distinfo
new file mode 100644
index 000000000000..c199b63e2fe9
--- /dev/null
+++ b/net/vtun/distinfo
@@ -0,0 +1 @@
+MD5 (vtun-2.3.tar.gz) = e0bc652994fc77e4d1d8fc998787e3cd
diff --git a/net/vtun/pkg-comment b/net/vtun/pkg-comment
new file mode 100644
index 000000000000..1d262e240076
--- /dev/null
+++ b/net/vtun/pkg-comment
@@ -0,0 +1 @@
+Virtual Tunnels over TCP/IP networks with traffic shaping
diff --git a/net/vtun/pkg-descr b/net/vtun/pkg-descr
new file mode 100644
index 000000000000..1f58fa351b14
--- /dev/null
+++ b/net/vtun/pkg-descr
@@ -0,0 +1,10 @@
+VTun provides the method for creating Virtual Tunnels over TCP/IP
+networks and allows to shape, compress, encrypt traffic in that
+tunnels.
+
+Supported type of tunnels are: PPP, IP, Ethernet and most of other
+serial protocols and programs. VTun is easily and highly configurable,
+it can be used for various network task like VPN, Mobile IP, Shaped
+Internet access, IP address saving, etc. It is completely user
+space implementation and does not require modification to any kernel
+parts.
diff --git a/net/vtun/pkg-plist b/net/vtun/pkg-plist
new file mode 100644
index 000000000000..08eac39fcdb6
--- /dev/null
+++ b/net/vtun/pkg-plist
@@ -0,0 +1,4 @@
+etc/vtund.conf
+man/man8/vtun.8
+sbin/vtund
+@exec rm -rf /var/log/vtund