aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-19 16:35:09 +0800
committerkwm <kwm@FreeBSD.org>2013-03-19 16:35:09 +0800
commita85aecebdd8c44211e1e75ba57188650ca9e1d59 (patch)
tree49db5857ca1cb9b5538032033848b9c4c5ba0515 /net
parent87a4d499316f4ad8a7a076cbc40832eef269b6ef (diff)
downloadfreebsd-ports-gnome-a85aecebdd8c44211e1e75ba57188650ca9e1d59.tar.gz
freebsd-ports-gnome-a85aecebdd8c44211e1e75ba57188650ca9e1d59.tar.zst
freebsd-ports-gnome-a85aecebdd8c44211e1e75ba57188650ca9e1d59.zip
Covert to OptionsNG, remove obsolete OSVERSION check and add USE_GCC=any for
now to fix the build on CURRENT.
Diffstat (limited to 'net')
-rw-r--r--net/ekiga3/Makefile73
1 files changed, 28 insertions, 45 deletions
diff --git a/net/ekiga3/Makefile b/net/ekiga3/Makefile
index 9b5ab50ecc22..b9eb55c4e492 100644
--- a/net/ekiga3/Makefile
+++ b/net/ekiga3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ekiga3
-# Date created: 2009-09-27
-# Whom: Charlie & <root@ws.ipfw.ru>
-#
+# Created by: Charlie & <root@ws.ipfw.ru>
# $FreeBSD$
-#
PORTNAME= ekiga3
PORTVERSION= 3.2.6
@@ -23,6 +19,7 @@ BUILD_DEPENDS= intltoolize:${PORTSDIR}/textproc/intltool \
CONFLICTS= ekiga-2.*
+USE_GCC= any
USE_PERL5= yes
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
@@ -37,44 +34,34 @@ MAKE_JOBS_SAFE= yes
MAN1= ekiga.1
-OPTIONS= LDAP "Enable LDAP support" off \
- KDE4 "Enable KDE4 support (experimental)" off \
- H323 "Enable H.323 protocol support" off \
- VIDEO "Enable video support" on \
- NOTIFY "Enable libnotify support" on \
- EVOLUTION "Enable evolution data server support" off \
- GCONF "Enable GCONF usage" on \
- DBUS "Enable DBUS usage" off \
- AVAHI "Enable avahi mDNS" on \
- GNOMEHELP "Build Ekiga help files" off \
- GCONFEDITOR "Install gconf-editor" off
+OPTIONS_DEFINE= LDAP KDE4 H323 VIDEO NOTIFY EVOLUTION GCONF DBUS AVAHI \
+ GNOMEHELP GCONFEDITOR
+OPTIONS_DEFAULT=VIDEO NOTIFY GCONF AVAHI
+KDE4_DESC= KDE4 support (experimental)
+EVOLUTION_DESC= Evolution data server support
+GNOMEHELP_DESC= Build Ekiga help files
+GCONFEDITOR_DESC=Depend on gconf-editor
.include <bsd.port.options.mk>
-.if defined(WITH_KDE4)
-. if !defined(WITH_DBUS)
-BROKEN= Please set WITH_DBUS or remove WITH_KDE4!
-. endif
+.if ${PORT_OPTIONS:MKDE4}
+. if !${PORT_OPTIONS:MDBUS}
+BROKEN= Please set DBUS option or remove the KDE4 option!
+. endif
USE_KDE4= kdehier kdelibs
USE_QT4= # empty
CONFIGURE_ARGS+= --enable-kde
+CONFIGURE_ENV+= KDE_CFLAGS="-I${KDE4_PREFIX}/include -I${QT_INCDIR} \
+ -I${LOCALBASE}/include" KDE_LIBS="-L${KDE4_PREFIX}/lib"
.else
CONFIGURE_ARGS+= --disable-kde
.endif
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_KDE4)
-CONFIGURE_ENV+= KDE_CFLAGS="-I${KDE4_PREFIX}/include -I${QT_INCDIR} -I${LOCALBASE}/include" \
- KDE_LIBS="-L${KDE4_PREFIX}/lib"
-K4_INC= ${KDE4_PREFIX:C/\//\\\//g}
-.endif
-
-.if defined(WITH_VIDEO)
+.if ${PORT_OPTIONS:MVIDEO}
BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
LIB_DEPENDS+= sasl2:${PORTSDIR}/security/cyrus-sasl2
CONFIGURE_ARGS+= --enable-ldap --with-ldap-dir="${LOCALBASE}" --with-libsasl2-dir="${LOCALBASE}"
@@ -82,21 +69,21 @@ CONFIGURE_ARGS+= --enable-ldap --with-ldap-dir="${LOCALBASE}" --with-libsasl2-di
CONFIGURE_ARGS+= --disable-ldap
.endif
-.if defined(WITH_H323)
+.if ${PORT_OPTIONS:MH323}
CONFIGURE_ARGS+= --enable-h323
.else
CONFIGURE_ARGS+= --disable-h323
.endif
-.if defined(WITH_NOTIFY)
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
+.if ${PORT_OPTIONS:MNOTIFY}
+LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+= --enable-notify
.else
CONFIGURE_ARGS+= --disable-notify
.endif
-.if defined(WITH_DBUS)
-LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+.if ${PORT_OPTIONS:MDBUS}
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+= --enable-dbus --enable-dbus-service
PLIST_SUB+= DBUS=""
.else
@@ -104,7 +91,7 @@ CONFIGURE_ARGS+= --disable-dbus --disable-dbus-service
PLIST_SUB+= DBUS="@comment "
.endif
-.if defined(WITH_GCONF)
+.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= gconf2
CONFIGURE_ARGS+= --enable-gconf
GCONF_SCHEMAS= ekiga.schemas
@@ -114,25 +101,25 @@ CONFIGURE_ARGS+= --disable-gconf
PLIST_SUB+= NO_GCONF=""
.endif
-.if defined(WITH_EVOLUTION)
+.if ${PORT_OPTIONS:MEVOLUTION}
USE_GNOME+= evolutiondataserver
CONFIGURE_ARGS+= --enable-eds
.else
CONFIGURE_ARGS+= --disable-eds
.endif
-.if defined(WITH_AVAHI)
+.if ${PORT_OPTIONS:MAVAHI}
CONFIGURE_ARGS+= --enable-avahi
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-client.pc:${PORTSDIR}/net/avahi-app
.else
CONFIGURE_ARGS+= --disable-avahi
.endif
-.if defined(WITH_GCONFEDITOR)
+.if ${PORT_OPTIONS:MGCONFEDITOR}
RUN_DEPENDS+= ${LOCALBASE}/bin/gconf-editor:${PORTSDIR}/sysutils/gconf-editor
.endif
-.if defined(WITH_GNOMEHELP)
+.if ${PORT_OPTIONS:MGNOMEHELP}
PLIST_SUB+= GNOMEHELP=""
USE_GNOME+= gnomedocutils
.else
@@ -140,10 +127,6 @@ CONFIGURE_ARGS+= --disable-gdu
PLIST_SUB+= GNOMEHELP="@comment "
.endif
-.if ${OSVERSION} < 700042
-BROKEN= does not build on 6.x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's/V4L="enabled"/V4L="disabled"/' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's?^\(KDE_CFLAGS.*\)$$?\1 -I'"${KDE4_PREFIX}/include?" ${WRKSRC}/lib/engine/components/kde/Makefile.in
@@ -151,4 +134,4 @@ post-patch:
post-configure:
@${REINPLACE_CMD} -e 's?^\(CPPFLAGS\) =\(.*\)$$?\1 = '"-I${LOCALBASE}/include"' \2?' ${WRKSRC}/lib/engine/addressbook/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>