aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-27 04:42:20 +0800
committerantoine <antoine@FreeBSD.org>2014-09-27 04:42:20 +0800
commita9f8cf9388da4e8779b10a35f596c98677cce73b (patch)
tree180456f9149a72bf971579def7f804c26c1fde4c /net
parent96ee895213076944656013cdb7856322a6e74ac8 (diff)
downloadfreebsd-ports-gnome-a9f8cf9388da4e8779b10a35f596c98677cce73b.tar.gz
freebsd-ports-gnome-a9f8cf9388da4e8779b10a35f596c98677cce73b.tar.zst
freebsd-ports-gnome-a9f8cf9388da4e8779b10a35f596c98677cce73b.zip
- Allow staging as a regular user
- Remove references to stagedir - Bump portversion as files were not packaged with intended group and refered to stagedir
Diffstat (limited to 'net')
-rw-r--r--net/xisp/Makefile2
-rw-r--r--net/xisp/files/patch-Makefile81
-rw-r--r--net/xisp/pkg-plist4
3 files changed, 75 insertions, 12 deletions
diff --git a/net/xisp/Makefile b/net/xisp/Makefile
index 2bd78b5da3fb..f41cde5a0e0b 100644
--- a/net/xisp/Makefile
+++ b/net/xisp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xisp
PORTVERSION= 2.7p4
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net
MASTER_SITES= http://xisp.hellug.gr/release/
diff --git a/net/xisp/files/patch-Makefile b/net/xisp/files/patch-Makefile
index 66e8289ded6e..885e7a0114d3 100644
--- a/net/xisp/files/patch-Makefile
+++ b/net/xisp/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sun Nov 6 22:38:22 2005
-+++ Makefile Mon Feb 27 08:22:22 2006
+--- Makefile.orig 2005-11-07 00:38:22 UTC
++++ Makefile
@@ -12,12 +12,12 @@
# Compilation/installation vars (global for all following sections) |
#=====================================================================
@@ -115,46 +115,109 @@
#
#=====================================================================
# Program configuration options |
-@@ -399,30 +399,39 @@
+@@ -352,32 +352,32 @@
+ $(CC) $(CCOPTS) -o xispid xispid.c
+
+ xisp.1: xisp.man
+- sed -e s,@ETCPPP@,$(DESTDIR)$(ETCPPP),g \
+- -e s,@USRLIBPPP@,$(DESTDIR)$(USRLIBPPP),g \
+- -e s,@USRLOCAL@,$(DESTDIR)$(USRLOCAL),g < xisp.man > xisp.1
++ sed -e s,@ETCPPP@,$(ETCPPP),g \
++ -e s,@USRLIBPPP@,$(USRLIBPPP),g \
++ -e s,@USRLOCAL@,$(USRLOCAL),g < xisp.man > xisp.1
+
+ install: xisp xispdial xisprccv xispterm xispid xisp.1
+ if [ ! -d $(DESTDIR)$(BINX11) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(BINX11); fi
+- $(INSTALL) -g $(GROUP) -m 750 -o $(XISPUSER) -s \
++ $(INSTALL) -m 750 -s \
+ xisp $(DESTDIR)$(BINX11)/xisp
+ if [ $(XISPUSER) != root ]; then \
+ chmod 4750 $(DESTDIR)$(BINX11)/xisp; fi
+ if [ ! -d $(DESTDIR)$(USRLIBPPP) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(USRLIBPPP); fi
+- $(INSTALL) -g $(GROUP) -m 750 -o $(XISPUSER) -s \
++ $(INSTALL) -m 750 -s \
+ xispdial $(DESTDIR)$(USRLIBPPP)/xispdial
+ if [ $(XISPUSER) != root ]; then \
+ chmod 4750 $(DESTDIR)$(USRLIBPPP)/xispdial; fi
+- $(INSTALL) -g $(GROUP) -m 750 -o root -s \
++ $(INSTALL) -m 750 -s \
+ xispterm $(DESTDIR)$(USRLIBPPP)/xispterm
+ if [ ! -d $(DESTDIR)$(USRLOCAL) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(USRLOCAL); fi
+- $(INSTALL) -g $(GROUP) -m 750 -o $(XISPUSER) -s \
++ $(INSTALL) -m 750 -s \
+ xisprccv $(DESTDIR)$(USRLOCAL)/xisprccv
+ if [ $(XISPUSER) != root ]; then \
+ chmod 4750 $(DESTDIR)$(USRLOCAL)/xisprccv; fi
+- $(INSTALL) -g $(GROUP) -m 750 -o root -s \
++ $(INSTALL) -m 750 -s \
+ xispid $(DESTDIR)$(USRLOCAL)/xispid
+ # if [ ! -d $(DESTDIR)$(OPTSDIR) ]; then \
+ # $(INSTALL) -d $(DESTDIR)$(OPTSDIR); fi
+@@ -385,44 +385,53 @@
+ # options.xisp $(DESTDIR)$(OPTSDIR)/options.xisp
+ if [ ! -d $(DESTDIR)$(MANDIR) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(MANDIR); fi
+- $(INSTALL) -g $(GROUP) -m 644 -o root \
++ $(INSTALL) -m 644 \
+ xisp.1 $(DESTDIR)$(MANDIR)/xisp.1
+ sed -e s/__XISPGROUP/$(GROUP)/ \
+- -e sM__XISPIDM/$(DESTDIR)$(USRLOCAL)/xispidM \
++ -e sM__XISPIDM$(USRLOCAL)/xispidM \
+ < ip-up.xisp > ip-up.install
+ sed -e s/__XISPGROUP/$(GROUP)/ \
+- -e sM__XISPIDM/$(DESTDIR)$(USRLOCAL)/xispidM \
++ -e sM__XISPIDM$(USRLOCAL)/xispidM \
+ < ip-down.xisp > ip-down.install
+ if [ ! -d $(DESTDIR)$(INSTPPPDIR) ]; then \
+ $(INSTALL) -d $(DESTDIR)$(INSTPPPDIR); fi
+ if [ -f $(DESTDIR)$(INSTPPPDIR)/ip-up ]; then \
mv -f $(DESTDIR)$(INSTPPPDIR)/ip-up \
$(DESTDIR)$(INSTPPPDIR)/ip-up.bak; fi
- $(INSTALL) -g $(GROUP) -m 750 -o root \
+- $(INSTALL) -g $(GROUP) -m 750 -o root \
- ip-up.install $(DESTDIR)$(INSTPPPDIR)/ip-up
++ $(INSTALL) -m 750 \
+ ip-up.install $(DESTDIR)$(INSTPPPDIR)/ip-up.xisp
if [ -f $(DESTDIR)$(INSTPPPDIR)/ip-down ]; then \
mv -f $(DESTDIR)$(INSTPPPDIR)/ip-down \
$(DESTDIR)$(INSTPPPDIR)/ip-down.bak; fi
- $(INSTALL) -g $(GROUP) -m 750 -o root \
+- $(INSTALL) -g $(GROUP) -m 750 -o root \
- ip-down.install $(DESTDIR)$(INSTPPPDIR)/ip-down
++ $(INSTALL) -m 750 \
+ ip-down.install $(DESTDIR)$(INSTPPPDIR)/ip-down.xisp
rm -f ip-up.install ip-down.install
- sed -e sM__DEVICEM$(MODEM_PATH)M \
- < xisp.peers.device > xisp_$(MODEM_DEV)
+- sed -e sM__DIALER_PATHM$(DESTDIR)$(USRLIBPPP)M \
+ for i in $(MODEM_DEVS); do \
+ sed -e sM__DEVICEM/dev/$${i}M \
+ < xisp.peers.device > xisp_$${i}; \
+ done
- sed -e sM__DIALER_PATHM$(DESTDIR)$(USRLIBPPP)M \
++ sed -e sM__DIALER_PATHM$(USRLIBPPP)M \
< xisp.peers.dialer > xisp_dialer
if [ ! -d $(DESTDIR)$(INSTPPPDIR)/peers ]; then \
$(INSTALL) -d $(DESTDIR)$(INSTPPPDIR)/peers; fi
- if [ -f $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$(MODEM_DEV) ]; then \
- mv -f $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$(MODEM_DEV) \
- $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$(MODEM_DEV).bak; fi
+- $(INSTALL) -g $(GROUP) -m 640 -o root \
+- xisp_$(MODEM_DEV) $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$(MODEM_DEV)
+ for i in $(MODEM_DEVS); do \
+ if [ -f $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$${i} ]; then \
+ mv -f $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$${i} \
+ $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$${i}.bak; fi; \
+ done
+ for i in $(MODEM_DEVS); do \
- $(INSTALL) -g $(GROUP) -m 640 -o root \
-- xisp_$(MODEM_DEV) $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$(MODEM_DEV)
++ $(INSTALL) -m 640 \
+ xisp_$$i $(DESTDIR)$(INSTPPPDIR)/peers/xisp_$${i}; \
+ done
if [ -f $(DESTDIR)$(INSTPPPDIR)/peers/xisp_dialer ]; then \
mv -f $(DESTDIR)$(INSTPPPDIR)/peers/xisp_dialer \
$(DESTDIR)$(INSTPPPDIR)/peers/xisp_dialer.bak; fi
- $(INSTALL) -g $(GROUP) -m 640 -o root \
+- $(INSTALL) -g $(GROUP) -m 640 -o root \
++ $(INSTALL) -m 640 \
xisp_dialer $(DESTDIR)$(INSTPPPDIR)/peers/xisp_dialer
- rm -f xisp_$(MODEM_DEV) xisp_dialer
+ for i in $(MODEM_DEVS); do \
diff --git a/net/xisp/pkg-plist b/net/xisp/pkg-plist
index 9d7b7323724c..a8b0ebe82d87 100644
--- a/net/xisp/pkg-plist
+++ b/net/xisp/pkg-plist
@@ -1,3 +1,4 @@
+@group dialer
bin/xisp
bin/xispid
bin/xisprccv
@@ -11,6 +12,5 @@ etc/ppp/peers/xisp_dialer
etc/ppp/peers/xisp_umodem
libexec/xispdial
libexec/xispterm
+@group
man/man1/xisp.1.gz
-@dirrm etc/ppp/peers
-@dirrmtry etc/ppp