aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-12-13 11:23:46 +0800
committerijliao <ijliao@FreeBSD.org>2001-12-13 11:23:46 +0800
commitab88878294e1c422905dbdc00adb7ddccc72d0b0 (patch)
tree0abf24b8d2456db8702f0c0fe8dd18f3c75e8100 /net
parent14860e6954e406bc76fc3cacb8215f3f99a2ffb6 (diff)
downloadfreebsd-ports-gnome-ab88878294e1c422905dbdc00adb7ddccc72d0b0.tar.gz
freebsd-ports-gnome-ab88878294e1c422905dbdc00adb7ddccc72d0b0.tar.zst
freebsd-ports-gnome-ab88878294e1c422905dbdc00adb7ddccc72d0b0.zip
add p5-SNMP-MIB-Compiler
A Perl MIB compiler supporting both SMIv1 and SMIv2 PR: 32763 Submitted by: Joe Marcus Clarke <marcus@marcuscom.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-SNMP-MIB-Compiler/Makefile25
-rw-r--r--net/p5-SNMP-MIB-Compiler/distinfo1
-rw-r--r--net/p5-SNMP-MIB-Compiler/pkg-comment1
-rw-r--r--net/p5-SNMP-MIB-Compiler/pkg-descr6
-rw-r--r--net/p5-SNMP-MIB-Compiler/pkg-plist13
6 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 236b343ad9b1..b3a8aa3f900a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -310,6 +310,7 @@
SUBDIR += p5-PlRPC
SUBDIR += p5-RPC-XML
SUBDIR += p5-SNMP
+ SUBDIR += p5-SNMP-MIB-Compiler
SUBDIR += p5-SNMP-Util
SUBDIR += p5-SNMP_Session
SUBDIR += p5-SOAP
diff --git a/net/p5-SNMP-MIB-Compiler/Makefile b/net/p5-SNMP-MIB-Compiler/Makefile
new file mode 100644
index 000000000000..aa6084655c3c
--- /dev/null
+++ b/net/p5-SNMP-MIB-Compiler/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-SNMP-MIB-Compiler
+# Date created: December 12, 2001
+# Whom: Joe Clarke <marcus@marcuscom.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= SNMP-MIB-Compiler
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SNMP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= marcus@marcuscom.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Data/Compare.pm:${PORTSDIR}/devel/p5-Data-Compare
+
+PERL_CONFIGURE= yes
+
+MAN3= SNMP::MIB::Compiler.3 \
+ Bundle::SNMP::MIB::Compiler.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-SNMP-MIB-Compiler/distinfo b/net/p5-SNMP-MIB-Compiler/distinfo
new file mode 100644
index 000000000000..d65b1acb19a7
--- /dev/null
+++ b/net/p5-SNMP-MIB-Compiler/distinfo
@@ -0,0 +1 @@
+MD5 (SNMP-MIB-Compiler-0.06.tar.gz) = 1bc0a54ac5e5e4210503cdc4ee48c9c1
diff --git a/net/p5-SNMP-MIB-Compiler/pkg-comment b/net/p5-SNMP-MIB-Compiler/pkg-comment
new file mode 100644
index 000000000000..d8c7a5aeed15
--- /dev/null
+++ b/net/p5-SNMP-MIB-Compiler/pkg-comment
@@ -0,0 +1 @@
+A Perl MIB compiler supporting both SMIv1 and SMIv2
diff --git a/net/p5-SNMP-MIB-Compiler/pkg-descr b/net/p5-SNMP-MIB-Compiler/pkg-descr
new file mode 100644
index 000000000000..946bd81d3ee3
--- /dev/null
+++ b/net/p5-SNMP-MIB-Compiler/pkg-descr
@@ -0,0 +1,6 @@
+SNMP::MIB::Compiler is a MIB compiler that fully supports
+both SMI(v1) and SMIv2. This module can be use to compile
+MIBs (recursively or not) or load already compiled MIBs for
+later use.
+
+More information about this module is included in this package.
diff --git a/net/p5-SNMP-MIB-Compiler/pkg-plist b/net/p5-SNMP-MIB-Compiler/pkg-plist
new file mode 100644
index 000000000000..1dc69ce8baba
--- /dev/null
+++ b/net/p5-SNMP-MIB-Compiler/pkg-plist
@@ -0,0 +1,13 @@
+bin/mibbrowser
+bin/mibcompiler
+lib/perl5/site_perl/%%PERL_VER%%/SNMP/MIB/Compiler.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bundle/SNMP/MIB/Compiler.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SNMP/MIB/Compiler/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SNMP/MIB/Compiler
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SNMP/MIB
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SNMP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SNMP/MIB
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SNMP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bundle/SNMP/MIB
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bundle/SNMP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bundle 2>/dev/null || true