aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-12 04:16:18 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-12 04:16:18 +0800
commitbfa333a5e2fb224bb56a49cc492478d6c8261558 (patch)
tree849dedc44996f2957c9b1e4380bbbdbffded6e01 /net
parent61d7faa2341e952b1af2866fbbecc06f6be75dd9 (diff)
downloadfreebsd-ports-gnome-bfa333a5e2fb224bb56a49cc492478d6c8261558.tar.gz
freebsd-ports-gnome-bfa333a5e2fb224bb56a49cc492478d6c8261558.tar.zst
freebsd-ports-gnome-bfa333a5e2fb224bb56a49cc492478d6c8261558.zip
net/nepenthes: unbreak with gcc6 or later
In file included from SMBDialogue.cpp:34:0: asn1-shellcodes.h:25:1: error: narrowing conversion of '133' from 'int' to 'char' inside { } [-Wnarrowing] }; ^ asn1-shellcodes.h:25:1: error: narrowing conversion of '255' from 'int' to 'char' inside { } [-Wnarrowing] asn1-shellcodes.h:25:1: error: narrowing conversion of '200' from 'int' to 'char' inside { } [-Wnarrowing] asn1-shellcodes.h:300:1: error: narrowing conversion of '191' from 'int' to 'char' inside { } [-Wnarrowing] }; ^ [...]
Diffstat (limited to 'net')
-rw-r--r--net/nepenthes/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index f2dc77db63e4..ff4b0b93b690 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
USES= dos2unix libtool perl5
DOS2UNIX_FILE= modules/shellcode-generic/sch_generic_connect_trans.cpp
+USE_CXXSTD= gnu++98
USE_GCC= any
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var