aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
committertijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
commitc06f97c7c46a03f3f6bb887aee3534bece5267a1 (patch)
tree320f49e86d38a480aace5bd0e27c34d6c8f75c2c /net
parent682bd0d0ee3984087ff6a9f3bf4b0552db04d013 (diff)
downloadfreebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.gz
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.zst
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.zip
Replace USE_AUTOTOOLS=libltdl with an ordinary LIB_DEPENDS in all ports.
There are only 60 such ports so there doesn't need to be a separate keyword or USES for this. Approved by: portmgr (bapt)
Diffstat (limited to 'net')
-rw-r--r--net/asterisk/Makefile4
-rw-r--r--net/asterisk11/Makefile4
-rw-r--r--net/freeradius2/Makefile5
-rw-r--r--net/gnu-dico/Makefile3
-rw-r--r--net/gnu-radius/Makefile3
-rw-r--r--net/libnetdude/Makefile4
-rw-r--r--net/netdude/Makefile4
-rw-r--r--net/openldap24-server/Makefile2
8 files changed, 16 insertions, 13 deletions
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index d66119e53e23..bacb5ac573d8 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -77,8 +77,8 @@ DAHDI_LIB_DEPENDS= libpri.so:${PORTSDIR}/misc/libpri \
libopenr2.so:${PORTSDIR}/misc/openr2
ODBC_CONFIGURE_WITH= unixodbc
ODBC_CONFIGURE_ON= --with-ltdl
-ODBC_USE= AUTOTOOLS=libltdl
-ODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
+ODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC \
+ libltdl.so:${PORTSDIR}/devel/libltdl
FREETDS_CONFIGURE_ON= --with-tds=${LOCALBASE}
FREETDS_CONFIGURE_OFF= --without-tds
FREETDS_LIB_DEPENDS= libtds.so:${PORTSDIR}/databases/freetds
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 866087452965..e018b26dfc47 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -73,8 +73,8 @@ DAHDI_LIB_DEPENDS= libpri.so:${PORTSDIR}/misc/libpri \
libopenr2.so:${PORTSDIR}/misc/openr2
ODBC_CONFIGURE_WITH= unixodbc
ODBC_CONFIGURE_ON= --with-ltdl
-ODBC_USE= AUTOTOOLS=libltdl
-ODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
+ODBC_LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC \
+ libltdl.so:${PORTSDIR}/devel/libltdl
FREETDS_CONFIGURE_ON= --with-tds=${LOCALBASE}
FREETDS_CONFIGURE_OFF= --without-tds
FREETDS_LIB_DEPENDS= libtds.so:${PORTSDIR}/databases/freetds
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index 5698f4156417..1e5ef3d518fc 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -17,7 +17,8 @@ COMMENT= Free RADIUS server implementation
LICENSE= GPLv2
-LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm \
+ libltdl.so:${PORTSDIR}/devel/libltdl
LOGDIR?= /var/log
KRB5_CONFIG?= /usr/bin/krb5-config --libs
@@ -29,7 +30,7 @@ USE_RC_SUBR= radiusd
USES= gmake libtool shebangfix tar:bzip2
SHEBANG_FILES= scripts/radsqlrelay src/modules/rlm_counter/rad_counter
-USE_AUTOTOOLS= libltdl libtoolize aclocal autoconf autoheader
+USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader
USE_OPENSSL= yes
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= ${CPPFLAGS}
diff --git a/net/gnu-dico/Makefile b/net/gnu-dico/Makefile
index 37274c02f62c..6ce6f34d2de1 100644
--- a/net/gnu-dico/Makefile
+++ b/net/gnu-dico/Makefile
@@ -12,9 +12,10 @@ PKGNAMEPREFIX= gnu-
MAINTAINER= goran.tal@gmail.com
COMMENT= Flexible modular implementation of DICT server
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USE_LDCONFIG= yes
USES= tar:xz gmake libtool
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CFLAGS+= -Wno-error=return-type
diff --git a/net/gnu-radius/Makefile b/net/gnu-radius/Makefile
index 96c626212fa5..6080525b1f46 100644
--- a/net/gnu-radius/Makefile
+++ b/net/gnu-radius/Makefile
@@ -12,13 +12,14 @@ DISTNAME= radius-${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= GNU RADIUS server
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
CONFLICTS= freeradius-0.* openradius-0.* radiusd-cistron-1.*
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= gmake libtool
USE_RC_SUBR= radiusd
USE_SUBMAKE= yes
-USE_AUTOTOOLS= libltdl
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/net/libnetdude/Makefile b/net/libnetdude/Makefile
index 48aa15542406..81e47f686afa 100644
--- a/net/libnetdude/Makefile
+++ b/net/libnetdude/Makefile
@@ -10,14 +10,14 @@ MASTER_SITES= SF/netdude/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for manipulating libpcap/tcpdump trace files
-LIB_DEPENDS= libpcapnav.so:${PORTSDIR}/net/libpcapnav
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libpcapnav.so:${PORTSDIR}/net/libpcapnav
USES= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc --disable-static --with-html-dir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-USE_AUTOTOOLS= libltdl
USE_GNOME= glib12
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index b33f5e12ff0b..22448bc6c774 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= NETwork DUmp data Displayer and Editor for tcpdump tracefiles
-LIB_DEPENDS= libnetdude.so:${PORTSDIR}/net/libnetdude
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libnetdude.so:${PORTSDIR}/net/libnetdude
USES= gettext iconv libtool gmake
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${DOCSDIR}
LIBS+= -L${LOCALBASE}/lib -lltdl
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 171abca08cca..4bd756a5dacb 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -220,7 +220,7 @@ USE_RC_SUBR= slapd
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-Makefile.in
.if ${PORT_OPTIONS:MMODULES} || ${PORT_OPTIONS:MDYNAMIC_BACKENDS} || ${PORT_OPTIONS:MSLAPI}
-USE_AUTOTOOLS+= libltdl
+LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl
CONFIGURE_ARGS+= --enable-modules
PLIST_SUB+= MODULES=""
.else