aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-11 03:12:33 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-11 03:12:33 +0800
commitc1197be34870b13fe82981493b58905c901de3c1 (patch)
tree0b2ccfe25fc36aba7188c607c85b18725841612f /net
parent554dcf70a5110ea553dd349671f05d9400c82db8 (diff)
downloadfreebsd-ports-gnome-c1197be34870b13fe82981493b58905c901de3c1.tar.gz
freebsd-ports-gnome-c1197be34870b13fe82981493b58905c901de3c1.tar.zst
freebsd-ports-gnome-c1197be34870b13fe82981493b58905c901de3c1.zip
- Convert to new LIB_DEPENDS format
- Convert to new options helper - Remove deprecated PTHREAD_* - Simplify Makefile
Diffstat (limited to 'net')
-rw-r--r--net/tintin++/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/net/tintin++/Makefile b/net/tintin++/Makefile
index 08ddd70d3591..48b6665fef09 100644
--- a/net/tintin++/Makefile
+++ b/net/tintin++/Makefile
@@ -12,7 +12,7 @@ COMMENT= Client program to help playing MUDs
LICENSE= GPLv2
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
OPTIONS_DEFINE= BIG5 DOCS
BIG5_DESC= Big5 support
@@ -33,20 +33,14 @@ PORTDOCS= ${DOCS:T}
SLAVEDIRS= chinese/tintin++
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MBIG5}
-CONFIGURE_ARGS+=--enable-big5
-.endif
+BIG5_CONFIGURE_ARGS= --enable-big5
post-configure:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|-lpthread|-pthread|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tt++ ${STAGEDIR}${PREFIX}/bin/
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/../ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
-.endif
.include <bsd.port.mk>