aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2011-02-06 00:19:32 +0800
committerfluffy <fluffy@FreeBSD.org>2011-02-06 00:19:32 +0800
commitc1779aa3a4a54a427d277613e338c179ed3875e1 (patch)
tree880df72ae1d001238643210e4f49fe57aa37b5fa /net
parent2ab6f0f5368af84c12029c1805b7c73eb657339d (diff)
downloadfreebsd-ports-gnome-c1779aa3a4a54a427d277613e338c179ed3875e1.tar.gz
freebsd-ports-gnome-c1779aa3a4a54a427d277613e338c179ed3875e1.tar.zst
freebsd-ports-gnome-c1779aa3a4a54a427d277613e338c179ed3875e1.zip
- Add kio-upnp-ms, KIO slave to access UPnP MediaServers
Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/kio-upnp-ms/Makefile28
-rw-r--r--net/kio-upnp-ms/distinfo2
-rw-r--r--net/kio-upnp-ms/pkg-descr10
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index d5151bd32198..6fb0025e98c3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -290,6 +290,7 @@
SUBDIR += kdenetwork4
SUBDIR += keepalived
SUBDIR += kiax
+ SUBDIR += kio-upnp-ms
SUBDIR += kissd
SUBDIR += kmuddy
SUBDIR += knemo
diff --git a/net/kio-upnp-ms/Makefile b/net/kio-upnp-ms/Makefile
new file mode 100644
index 000000000000..0ffe5c254fcc
--- /dev/null
+++ b/net/kio-upnp-ms/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: kio-upnp-ms
+# Date created: 2010-12-29
+# Whom: Dima Panov <fluffy@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= kio-upnp-ms
+PORTVERSION= 0.8.0
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTNAME}/${PORTVERSION}/src
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KIO slave to access UPnP MediaServers
+
+LIB_DEPENDS= HUpnp.1:${PORTSDIR}/net/hupnp
+
+USE_CMAKE= yes
+USE_KDE4= automoc4 kdehier kdelibs
+USE_QT_VER= 4
+QT_COMPONENTS= corelib network xml dbus gui \
+ qmake_build moc_build rcc_build uic_build
+
+PLIST_FILES= include/kio/upnptypes.h \
+ lib/kde4/kio_upnp_ms.so \
+ share/kde4/services/kio_upnp_ms.protocol
+
+.include <bsd.port.mk>
diff --git a/net/kio-upnp-ms/distinfo b/net/kio-upnp-ms/distinfo
new file mode 100644
index 000000000000..3446f15ae27c
--- /dev/null
+++ b/net/kio-upnp-ms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kio-upnp-ms-0.8.0.tar.gz) = 6fba4246ea83aec2a78b33d154ffce9be4055a76b93f10bb1b53d38a2c5e2d9c
+SIZE (kio-upnp-ms-0.8.0.tar.gz) = 31461
diff --git a/net/kio-upnp-ms/pkg-descr b/net/kio-upnp-ms/pkg-descr
new file mode 100644
index 000000000000..f6a38d85a878
--- /dev/null
+++ b/net/kio-upnp-ms/pkg-descr
@@ -0,0 +1,10 @@
+]This KIO slave enables KDE applications to access
+files over the UPnP MediaServer protocol. It currently
+supports both Browse and Search operations depending on
+what the server supports.
+
+The protocol is "upnp-ms://<uuid>"
+
+where UUID is the UUID of the MediaServer device without the "uuid:" prefix.
+
+WWW: https://projects.kde.org/projects/playground/base/kio-upnp-ms