aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2001-07-10 09:23:26 +0800
committerdwcjr <dwcjr@FreeBSD.org>2001-07-10 09:23:26 +0800
commitc661f40cd2c9393134cdcd9c52db64060b5976ef (patch)
treeb380031420d202b9c5c8ef176ad4d61a3f5161d5 /net
parent61fbc32ac409073d3e234bff5a1466244852fa9d (diff)
downloadfreebsd-ports-gnome-c661f40cd2c9393134cdcd9c52db64060b5976ef.tar.gz
freebsd-ports-gnome-c661f40cd2c9393134cdcd9c52db64060b5976ef.tar.zst
freebsd-ports-gnome-c661f40cd2c9393134cdcd9c52db64060b5976ef.zip
Take out GNU_CONFIGURE
PORTDOC police w/ DOCSDIR PR: 28854 Submitted by: Patrick Li <pat@databits.net>
Diffstat (limited to 'net')
-rw-r--r--net/samba/Makefile23
-rw-r--r--net/samba/pkg-plist408
2 files changed, 214 insertions, 217 deletions
diff --git a/net/samba/Makefile b/net/samba/Makefile
index 8bbb6a9c292a..f7280562a39f 100644
--- a/net/samba/Makefile
+++ b/net/samba/Makefile
@@ -14,12 +14,10 @@ MASTER_SITES= ftp://ftp.samba.org/pub/samba/%SUBDIR%/ \
ftp://de.samba.org/pub/mirror/samba/%SUBDIR%/ \
ftp://se.samba.org/pub/samba/%SUBDIR%/ \
ftp://ftp.sunet.se/pub/unix/utilities/samba/%SUBDIR%/
-MASTER_SITE_SUBDIR= . old-versions old
+MASTER_SITE_SUBDIR= . old-versions old
MAINTAINER= dwcjr@FreeBSD.org
-USE_AUTOCONF= yes
-
.if defined(WITH_CUPS)
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups
.endif
@@ -34,19 +32,19 @@ SAMBA_CONFDIR= ${PREFIX}/etc
STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/samba.sh.sample
SAMPLE_CONFIG= ${SAMBA_CONFDIR}/smb.conf.default
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
+USE_AUTOCONF= yes
+CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
--localstatedir=${VARDIR} --with-swatdir=${PREFIX}/share/swat \
--with-sambabook=${PREFIX}/share/swat/using_samba \
--with-lockdir=${VARDIR}/spool/lock \
--with-privatedir=${SAMBA_PRIVATE}
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
-CONFIGURE_ARGS+=--with-krb5=${KRB5_HOME}
+CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
.endif
.if defined(WITH_CUPS)
-CONFIGURE_ARGS+=--with-cups=${LOCALBASE}
+CONFIGURE_ARGS+= --with-cups=${LOCALBASE}
.endif
WRKSRC= ${WRKDIR}/${DISTNAME}/source
@@ -96,7 +94,7 @@ post-install:
.endif
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/samba
+ ${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${PREFIX}/share/doc/samba
for i in ${WRKDIR}/${DISTNAME}/README \
${WRKDIR}/${DISTNAME}/COPYING \
@@ -108,18 +106,17 @@ post-install:
${WRKDIR}/${DISTNAME}/docs/THANKS \
${WRKDIR}/${DISTNAME}/docs/announce \
${WRKDIR}/${DISTNAME}/docs/history ; do \
- ${INSTALL_DATA} $$i ${PREFIX}/share/doc/samba ; \
+ ${INSTALL_DATA} $$i ${DOCSDIR} ; \
done
for i in faq htmldocs textdocs yodldocs ; do \
- ${MKDIR} ${PREFIX}/share/doc/samba/$$i ; \
+ ${MKDIR} ${DOCSDIR}/$$i ; \
for j in ${WRKDIR}/${DISTNAME}/docs/$$i/* ; do \
if [ $$j != ${WRKDIR}/${DISTNAME}/docs/htmldocs/using_samba ] ; then \
- ${INSTALL_DATA} $$j ${PREFIX}/share/doc/samba/$$i ;\
+ ${INSTALL_DATA} $$j ${DOCSDIR}/$$i ;\
fi; \
done \
done
- ${MKDIR} ${PREFIX}/share/doc/samba
- ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/swat/README ${PREFIX}/share/doc/samba/README.swat
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/swat/README ${DOCSDIR}/README.swat
.endif
.include <bsd.port.mk>
diff --git a/net/samba/pkg-plist b/net/samba/pkg-plist
index 30696e5e6baf..e7e906363b1a 100644
--- a/net/samba/pkg-plist
+++ b/net/samba/pkg-plist
@@ -1,23 +1,187 @@
-bin/smbclient
-bin/smbstatus
-bin/smbpasswd
-bin/nmblookup
-bin/smbtar
bin/addtosmbpass
bin/convert_smbpasswd
-bin/testparm
-bin/testprns
-bin/make_smbpasswd
+bin/make_printerdef
bin/make_smbcodepage
+bin/make_smbpasswd
bin/make_unicodemap
-bin/make_printerdef
+bin/nmblookup
bin/rpcclient
+bin/smbclient
+bin/smbpasswd
bin/smbspool
-sbin/smbd
+bin/smbstatus
+bin/smbtar
+bin/testparm
+bin/testprns
+etc/codepages/codepage.1251
+etc/codepages/codepage.437
+etc/codepages/codepage.737
+etc/codepages/codepage.775
+etc/codepages/codepage.850
+etc/codepages/codepage.852
+etc/codepages/codepage.861
+etc/codepages/codepage.866
+etc/codepages/codepage.932
+etc/codepages/codepage.936
+etc/codepages/codepage.949
+etc/codepages/codepage.950
+etc/codepages/unicode_map.437
+etc/codepages/unicode_map.737
+etc/codepages/unicode_map.850
+etc/codepages/unicode_map.852
+etc/codepages/unicode_map.861
+etc/codepages/unicode_map.866
+etc/codepages/unicode_map.932
+etc/codepages/unicode_map.936
+etc/codepages/unicode_map.949
+etc/codepages/unicode_map.950
+etc/codepages/unicode_map.ISO8859-1
+etc/codepages/unicode_map.ISO8859-2
+etc/codepages/unicode_map.ISO8859-5
+etc/codepages/unicode_map.ISO8859-7
+etc/codepages/unicode_map.KOI8-R
+etc/rc.d/samba.sh.sample
+etc/smb.conf.default
sbin/nmbd
+sbin/smbd
sbin/swat
+%%PORTDOCS%%share/doc/samba/COPYING
+%%PORTDOCS%%share/doc/samba/Manifest
+%%PORTDOCS%%share/doc/samba/NT4-Locking.reg
+%%PORTDOCS%%share/doc/samba/NT4_PlainPassword.reg
+%%PORTDOCS%%share/doc/samba/README
+%%PORTDOCS%%share/doc/samba/README.FreeBSD
+%%PORTDOCS%%share/doc/samba/README.swat
+%%PORTDOCS%%share/doc/samba/Read-Manifest-Now
+%%PORTDOCS%%share/doc/samba/Roadmap
+%%PORTDOCS%%share/doc/samba/THANKS
+%%PORTDOCS%%share/doc/samba/WHATSNEW.txt
+%%PORTDOCS%%share/doc/samba/Win2000_PlainPassword.reg
+%%PORTDOCS%%share/doc/samba/Win95_PlainPassword.reg
+%%PORTDOCS%%share/doc/samba/Win98_PlainPassword.reg
+%%PORTDOCS%%share/doc/samba/Win9X-CacheHandling.reg
+%%PORTDOCS%%share/doc/samba/WindowsTerminalServer.reg
+%%PORTDOCS%%share/doc/samba/announce
+%%PORTDOCS%%share/doc/samba/faq/Samba-Server-FAQ-1.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-Server-FAQ-2.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-Server-FAQ.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-Server-FAQ.sgml
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ-1.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ-2.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ-3.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ-4.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ-5.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ-6.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ.html
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ.sgml
+%%PORTDOCS%%share/doc/samba/faq/Samba-meta-FAQ.txt
+%%PORTDOCS%%share/doc/samba/faq/sambafaq-1.html
+%%PORTDOCS%%share/doc/samba/faq/sambafaq-2.html
+%%PORTDOCS%%share/doc/samba/faq/sambafaq-3.html
+%%PORTDOCS%%share/doc/samba/faq/sambafaq-4.html
+%%PORTDOCS%%share/doc/samba/faq/sambafaq-5.html
+%%PORTDOCS%%share/doc/samba/faq/sambafaq.html
+%%PORTDOCS%%share/doc/samba/faq/sambafaq.sgml
+%%PORTDOCS%%share/doc/samba/faq/sambafaq.txt
+%%PORTDOCS%%share/doc/samba/history
+%%PORTDOCS%%share/doc/samba/htmldocs/DOMAIN_MEMBER.html
+%%PORTDOCS%%share/doc/samba/htmldocs/NT_Security.html
+%%PORTDOCS%%share/doc/samba/htmldocs/lmhosts.5.html
+%%PORTDOCS%%share/doc/samba/htmldocs/make_smbcodepage.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/make_unicodemap.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/nmbd.8.html
+%%PORTDOCS%%share/doc/samba/htmldocs/nmblookup.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/samba.7.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smb.conf.5.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbclient.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbd.8.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbmnt.8.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbmount.8.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbpasswd.5.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbpasswd.8.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbrun.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbsh.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbspool.8.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbstatus.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/smbtar.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/swat.8.html
+%%PORTDOCS%%share/doc/samba/htmldocs/testparm.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/testprns.1.html
+%%PORTDOCS%%share/doc/samba/htmldocs/wfw_slip.htm
+%%PORTDOCS%%share/doc/samba/textdocs/Application_Serving.txt
+%%PORTDOCS%%share/doc/samba/textdocs/BROWSING-Config.txt
+%%PORTDOCS%%share/doc/samba/textdocs/BROWSING.txt
+%%PORTDOCS%%share/doc/samba/textdocs/BUGS.txt
+%%PORTDOCS%%share/doc/samba/textdocs/CRLF-LF-Conversions.txt
+%%PORTDOCS%%share/doc/samba/textdocs/CVS_ACCESS.txt
+%%PORTDOCS%%share/doc/samba/textdocs/DHCP-Server-Configuration.txt
+%%PORTDOCS%%share/doc/samba/textdocs/DIAGNOSIS.txt
+%%PORTDOCS%%share/doc/samba/textdocs/DNIX.txt
+%%PORTDOCS%%share/doc/samba/textdocs/DOMAIN.txt
+%%PORTDOCS%%share/doc/samba/textdocs/DOMAIN_CONTROL.txt
+%%PORTDOCS%%share/doc/samba/textdocs/DOMAIN_MEMBER.txt
+%%PORTDOCS%%share/doc/samba/textdocs/ENCRYPTION.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Faxing.txt
+%%PORTDOCS%%share/doc/samba/textdocs/File-Cacheing.txt
+%%PORTDOCS%%share/doc/samba/textdocs/GOTCHAS.txt
+%%PORTDOCS%%share/doc/samba/textdocs/HINTS.txt
+%%PORTDOCS%%share/doc/samba/textdocs/INSTALL.sambatar
+%%PORTDOCS%%share/doc/samba/textdocs/MIRRORS.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Macintosh_Clients.txt
+%%PORTDOCS%%share/doc/samba/textdocs/NT-Guest-Access.txt
+%%PORTDOCS%%share/doc/samba/textdocs/NTDOMAIN.txt
+%%PORTDOCS%%share/doc/samba/textdocs/NT_Security.txt
+%%PORTDOCS%%share/doc/samba/textdocs/NetBIOS.txt
+%%PORTDOCS%%share/doc/samba/textdocs/OS2-Client-HOWTO.txt
+%%PORTDOCS%%share/doc/samba/textdocs/PRINTER_DRIVER.txt
+%%PORTDOCS%%share/doc/samba/textdocs/PROFILES.txt
+%%PORTDOCS%%share/doc/samba/textdocs/PROJECTS
+%%PORTDOCS%%share/doc/samba/textdocs/Passwords.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Printing.txt
+%%PORTDOCS%%share/doc/samba/textdocs/README.DCEDFS
+%%PORTDOCS%%share/doc/samba/textdocs/README.jis
+%%PORTDOCS%%share/doc/samba/textdocs/README.sambatar
+%%PORTDOCS%%share/doc/samba/textdocs/Recent-FAQs.txt
+%%PORTDOCS%%share/doc/samba/textdocs/RoutedNetworks.txt
+%%PORTDOCS%%share/doc/samba/textdocs/SCO.txt
+%%PORTDOCS%%share/doc/samba/textdocs/SMBTAR.notes
+%%PORTDOCS%%share/doc/samba/textdocs/SSLeay.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Speed.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Speed2.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Support.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Tracing.txt
+%%PORTDOCS%%share/doc/samba/textdocs/UNIX-SMB.txt
+%%PORTDOCS%%share/doc/samba/textdocs/UNIX_INSTALL.txt
+%%PORTDOCS%%share/doc/samba/textdocs/UNIX_SECURITY.txt
+%%PORTDOCS%%share/doc/samba/textdocs/Win95.txt
+%%PORTDOCS%%share/doc/samba/textdocs/WinNT.txt
+%%PORTDOCS%%share/doc/samba/textdocs/cifsntdomain.txt
+%%PORTDOCS%%share/doc/samba/textdocs/security_level.txt
+%%PORTDOCS%%share/doc/samba/textdocs/smbmount.txt
+%%PORTDOCS%%share/doc/samba/yodldocs/DOMAIN_MEMBER.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/NT_Security.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/lmhosts.5.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/make_smbcodepage.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/make_unicodemap.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/nmbd.8.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/nmblookup.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/samba.7.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smb.conf.5.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbclient.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbd.8.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbmnt.8.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbmount.8.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbpasswd.5.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbpasswd.8.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbrun.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbsh.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbspool.8.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbstatus.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/smbtar.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/swat.8.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/testparm.1.yo
+%%PORTDOCS%%share/doc/samba/yodldocs/testprns.1.yo
share/examples/samba/README
-share/examples/samba/smb.conf.default
share/examples/samba/autofs/README
share/examples/samba/autofs/auto.a
share/examples/samba/dce-dfs/README
@@ -34,6 +198,7 @@ share/examples/samba/printing/smbprint
share/examples/samba/printing/smbprint.sysv
share/examples/samba/simple/README
share/examples/samba/simple/smb.conf
+share/examples/samba/smb.conf.default
share/examples/samba/svr4-startup/README
share/examples/samba/svr4-startup/samba.server
share/examples/samba/thoralf/smb.conf
@@ -50,190 +215,6 @@ share/examples/samba/validchars/validchr.c
share/examples/samba/validchars/validchr.com
share/examples/samba/wins_hook/README
share/examples/samba/wins_hook/dns_update
-@dirrm share/examples/samba/autofs
-@dirrm share/examples/samba/dce-dfs
-@dirrm share/examples/samba/misc
-@dirrm share/examples/samba/printing
-@dirrm share/examples/samba/printer-accounting
-@dirrm share/examples/samba/simple
-@dirrm share/examples/samba/svr4-startup
-@dirrm share/examples/samba/thoralf
-@dirrm share/examples/samba/tridge
-@dirrm share/examples/samba/validchars
-@dirrm share/examples/samba/wins_hook
-@dirrm share/examples/samba
-etc/rc.d/samba.sh.sample
-etc/smb.conf.default
-etc/codepages/codepage.437
-etc/codepages/codepage.737
-etc/codepages/codepage.775
-etc/codepages/codepage.850
-etc/codepages/codepage.852
-etc/codepages/codepage.861
-etc/codepages/codepage.866
-etc/codepages/codepage.932
-etc/codepages/codepage.936
-etc/codepages/codepage.949
-etc/codepages/codepage.950
-etc/codepages/codepage.1251
-etc/codepages/unicode_map.437
-etc/codepages/unicode_map.737
-etc/codepages/unicode_map.850
-etc/codepages/unicode_map.852
-etc/codepages/unicode_map.861
-etc/codepages/unicode_map.866
-etc/codepages/unicode_map.932
-etc/codepages/unicode_map.936
-etc/codepages/unicode_map.949
-etc/codepages/unicode_map.950
-etc/codepages/unicode_map.ISO8859-1
-etc/codepages/unicode_map.ISO8859-2
-etc/codepages/unicode_map.ISO8859-5
-etc/codepages/unicode_map.ISO8859-7
-etc/codepages/unicode_map.KOI8-R
-@dirrm etc/codepages
-share/doc/samba/COPYING
-share/doc/samba/Manifest
-share/doc/samba/NT4_PlainPassword.reg
-share/doc/samba/NT4-Locking.reg
-share/doc/samba/README
-share/doc/samba/README.FreeBSD
-share/doc/samba/README.swat
-share/doc/samba/Read-Manifest-Now
-share/doc/samba/Roadmap
-share/doc/samba/THANKS
-share/doc/samba/WHATSNEW.txt
-share/doc/samba/Win2000_PlainPassword.reg
-share/doc/samba/Win95_PlainPassword.reg
-share/doc/samba/Win98_PlainPassword.reg
-share/doc/samba/Win9X-CacheHandling.reg
-share/doc/samba/WindowsTerminalServer.reg
-share/doc/samba/announce
-share/doc/samba/faq/Samba-Server-FAQ-1.html
-share/doc/samba/faq/Samba-Server-FAQ-2.html
-share/doc/samba/faq/Samba-Server-FAQ.html
-share/doc/samba/faq/Samba-Server-FAQ.sgml
-share/doc/samba/faq/Samba-meta-FAQ-1.html
-share/doc/samba/faq/Samba-meta-FAQ-2.html
-share/doc/samba/faq/Samba-meta-FAQ-3.html
-share/doc/samba/faq/Samba-meta-FAQ-4.html
-share/doc/samba/faq/Samba-meta-FAQ-5.html
-share/doc/samba/faq/Samba-meta-FAQ-6.html
-share/doc/samba/faq/Samba-meta-FAQ.html
-share/doc/samba/faq/Samba-meta-FAQ.sgml
-share/doc/samba/faq/Samba-meta-FAQ.txt
-share/doc/samba/faq/sambafaq-1.html
-share/doc/samba/faq/sambafaq-2.html
-share/doc/samba/faq/sambafaq-3.html
-share/doc/samba/faq/sambafaq-4.html
-share/doc/samba/faq/sambafaq-5.html
-share/doc/samba/faq/sambafaq.html
-share/doc/samba/faq/sambafaq.sgml
-share/doc/samba/faq/sambafaq.txt
-share/doc/samba/history
-share/doc/samba/htmldocs/DOMAIN_MEMBER.html
-share/doc/samba/htmldocs/NT_Security.html
-share/doc/samba/htmldocs/lmhosts.5.html
-share/doc/samba/htmldocs/make_smbcodepage.1.html
-share/doc/samba/htmldocs/make_unicodemap.1.html
-share/doc/samba/htmldocs/nmbd.8.html
-share/doc/samba/htmldocs/nmblookup.1.html
-share/doc/samba/htmldocs/samba.7.html
-share/doc/samba/htmldocs/smb.conf.5.html
-share/doc/samba/htmldocs/smbclient.1.html
-share/doc/samba/htmldocs/smbd.8.html
-share/doc/samba/htmldocs/smbmnt.8.html
-share/doc/samba/htmldocs/smbmount.8.html
-share/doc/samba/htmldocs/smbpasswd.5.html
-share/doc/samba/htmldocs/smbpasswd.8.html
-share/doc/samba/htmldocs/smbspool.8.html
-share/doc/samba/htmldocs/smbrun.1.html
-share/doc/samba/htmldocs/smbsh.1.html
-share/doc/samba/htmldocs/smbstatus.1.html
-share/doc/samba/htmldocs/smbtar.1.html
-share/doc/samba/htmldocs/swat.8.html
-share/doc/samba/htmldocs/testparm.1.html
-share/doc/samba/htmldocs/testprns.1.html
-share/doc/samba/htmldocs/wfw_slip.htm
-share/doc/samba/textdocs/smbmount.txt
-share/doc/samba/textdocs/NT-Guest-Access.txt
-share/doc/samba/textdocs/Application_Serving.txt
-share/doc/samba/textdocs/BROWSING-Config.txt
-share/doc/samba/textdocs/BROWSING.txt
-share/doc/samba/textdocs/BUGS.txt
-share/doc/samba/textdocs/CRLF-LF-Conversions.txt
-share/doc/samba/textdocs/CVS_ACCESS.txt
-share/doc/samba/textdocs/DHCP-Server-Configuration.txt
-share/doc/samba/textdocs/DIAGNOSIS.txt
-share/doc/samba/textdocs/DNIX.txt
-share/doc/samba/textdocs/DOMAIN.txt
-share/doc/samba/textdocs/DOMAIN_CONTROL.txt
-share/doc/samba/textdocs/DOMAIN_MEMBER.txt
-share/doc/samba/textdocs/ENCRYPTION.txt
-share/doc/samba/textdocs/Faxing.txt
-share/doc/samba/textdocs/File-Cacheing.txt
-share/doc/samba/textdocs/GOTCHAS.txt
-share/doc/samba/textdocs/HINTS.txt
-share/doc/samba/textdocs/INSTALL.sambatar
-share/doc/samba/textdocs/MIRRORS.txt
-share/doc/samba/textdocs/Macintosh_Clients.txt
-share/doc/samba/textdocs/NTDOMAIN.txt
-share/doc/samba/textdocs/NT_Security.txt
-share/doc/samba/textdocs/NetBIOS.txt
-share/doc/samba/textdocs/OS2-Client-HOWTO.txt
-share/doc/samba/textdocs/PRINTER_DRIVER.txt
-share/doc/samba/textdocs/PROFILES.txt
-share/doc/samba/textdocs/PROJECTS
-share/doc/samba/textdocs/Passwords.txt
-share/doc/samba/textdocs/Printing.txt
-share/doc/samba/textdocs/README.DCEDFS
-share/doc/samba/textdocs/README.jis
-share/doc/samba/textdocs/README.sambatar
-share/doc/samba/textdocs/Recent-FAQs.txt
-share/doc/samba/textdocs/RoutedNetworks.txt
-share/doc/samba/textdocs/SCO.txt
-share/doc/samba/textdocs/SMBTAR.notes
-share/doc/samba/textdocs/SSLeay.txt
-share/doc/samba/textdocs/Speed.txt
-share/doc/samba/textdocs/Speed2.txt
-share/doc/samba/textdocs/Support.txt
-share/doc/samba/textdocs/Tracing.txt
-share/doc/samba/textdocs/UNIX-SMB.txt
-share/doc/samba/textdocs/UNIX_INSTALL.txt
-share/doc/samba/textdocs/UNIX_SECURITY.txt
-share/doc/samba/textdocs/Win95.txt
-share/doc/samba/textdocs/WinNT.txt
-share/doc/samba/textdocs/cifsntdomain.txt
-share/doc/samba/textdocs/security_level.txt
-share/doc/samba/yodldocs/DOMAIN_MEMBER.yo
-share/doc/samba/yodldocs/NT_Security.yo
-share/doc/samba/yodldocs/lmhosts.5.yo
-share/doc/samba/yodldocs/make_smbcodepage.1.yo
-share/doc/samba/yodldocs/make_unicodemap.1.yo
-share/doc/samba/yodldocs/nmbd.8.yo
-share/doc/samba/yodldocs/nmblookup.1.yo
-share/doc/samba/yodldocs/samba.7.yo
-share/doc/samba/yodldocs/smb.conf.5.yo
-share/doc/samba/yodldocs/smbclient.1.yo
-share/doc/samba/yodldocs/smbd.8.yo
-share/doc/samba/yodldocs/smbmnt.8.yo
-share/doc/samba/yodldocs/smbmount.8.yo
-share/doc/samba/yodldocs/smbpasswd.5.yo
-share/doc/samba/yodldocs/smbpasswd.8.yo
-share/doc/samba/yodldocs/smbspool.8.yo
-share/doc/samba/yodldocs/smbrun.1.yo
-share/doc/samba/yodldocs/smbsh.1.yo
-share/doc/samba/yodldocs/smbstatus.1.yo
-share/doc/samba/yodldocs/smbtar.1.yo
-share/doc/samba/yodldocs/swat.8.yo
-share/doc/samba/yodldocs/testparm.1.yo
-share/doc/samba/yodldocs/testprns.1.yo
-@dirrm share/doc/samba/faq
-@dirrm share/doc/samba/htmldocs
-@dirrm share/doc/samba/textdocs
-@dirrm share/doc/samba/yodldocs
-@dirrm share/doc/samba
-share/swat/help/welcome.html
share/swat/help/DOMAIN_MEMBER.html
share/swat/help/NT_Security.html
share/swat/help/lmhosts.5.html
@@ -257,6 +238,7 @@ share/swat/help/smbtar.1.html
share/swat/help/swat.8.html
share/swat/help/testparm.1.html
share/swat/help/testprns.1.html
+share/swat/help/welcome.html
share/swat/help/welcome.ja_JP.ujis.html
share/swat/images/globals.gif
share/swat/images/home.gif
@@ -329,10 +311,6 @@ share/swat/using_samba/ch08_07.html
share/swat/using_samba/ch09_01.html
share/swat/using_samba/ch09_02.html
share/swat/using_samba/ch09_03.html
-share/swat/using_samba/index.html
-share/swat/using_samba/inx.html
-share/swat/using_samba/licenseinfo.html
-share/swat/using_samba/this_edition.html
share/swat/using_samba/figs/sam.0101.gif
share/swat/using_samba/figs/sam.0102.gif
share/swat/using_samba/figs/sam.0103.gif
@@ -427,14 +405,36 @@ share/swat/using_samba/gifs/samba.s.gif
share/swat/using_samba/gifs/txthome.gif
share/swat/using_samba/gifs/txtnexta.gif
share/swat/using_samba/gifs/txtpreva.gif
-@dirrm share/swat/help
-@dirrm share/swat/images
-@dirrm share/swat/include
-@dirrm share/swat/using_samba/figs
+share/swat/using_samba/index.html
+share/swat/using_samba/inx.html
+share/swat/using_samba/licenseinfo.html
+share/swat/using_samba/this_edition.html
@dirrm share/swat/using_samba/gifs
+@dirrm share/swat/using_samba/figs
@dirrm share/swat/using_samba
+@dirrm share/swat/include
+@dirrm share/swat/images
+@dirrm share/swat/help
@dirrm share/swat
+@dirrm share/examples/samba/wins_hook
+@dirrm share/examples/samba/validchars
+@dirrm share/examples/samba/tridge
+@dirrm share/examples/samba/thoralf
+@dirrm share/examples/samba/svr4-startup
+@dirrm share/examples/samba/simple
+@dirrm share/examples/samba/printing
+@dirrm share/examples/samba/printer-accounting
+@dirrm share/examples/samba/misc
+@dirrm share/examples/samba/dce-dfs
+@dirrm share/examples/samba/autofs
+@dirrm share/examples/samba
+@dirrm share/doc/samba/yodldocs
+@dirrm share/doc/samba/textdocs
+@dirrm share/doc/samba/htmldocs
+@dirrm share/doc/samba/faq
+@dirrm share/doc/samba
+@dirrm etc/codepages
+@exec cat %D/share/doc/samba/README.FreeBSD
@exec mkdir %D/private ; if [ ! -f %D/private/smbpasswd ] ; then chown -R root.wheel %D/private ; cat /etc/passwd | grep -v "^#" | %D/bin/make_smbpasswd > %D/private/smbpasswd ; chmod 500 %D/private ; chmod 600 %D/private/smbpasswd ; fi
@exec mkdir -p /var/spool/samba ; chmod 1777 /var/spool/samba
-@exec cat %D/share/doc/samba/README.FreeBSD
@unexec rm -rf /var/spool/samba