aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2001-11-05 22:58:39 +0800
committerjmz <jmz@FreeBSD.org>2001-11-05 22:58:39 +0800
commitc8a0c7b3032d3e241804744202116aee4b43d6db (patch)
treedf052b61995848bc4c318d114df1649fd7dc0406 /net
parent69df44bda70add454b74ab506b6adabe1b745983 (diff)
downloadfreebsd-ports-gnome-c8a0c7b3032d3e241804744202116aee4b43d6db.tar.gz
freebsd-ports-gnome-c8a0c7b3032d3e241804744202116aee4b43d6db.tar.zst
freebsd-ports-gnome-c8a0c7b3032d3e241804744202116aee4b43d6db.zip
pancho - A perl script useful to configure Cisco devices via TFTP
PR: ports/31734 Submitted by: Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pancho/Makefile40
-rw-r--r--net/pancho/distinfo1
-rw-r--r--net/pancho/files/patch-aa11
-rw-r--r--net/pancho/files/patch-ab10
-rw-r--r--net/pancho/pkg-comment1
-rw-r--r--net/pancho/pkg-descr14
-rw-r--r--net/pancho/pkg-plist3
8 files changed, 81 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6c75d449cd78..74cce1316aef 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -309,6 +309,7 @@
SUBDIR += p5-URI
SUBDIR += p5-XPC
SUBDIR += p5-perl-ldap
+ SUBDIR += pancho
SUBDIR += passlogd
SUBDIR += pathchar
SUBDIR += pchar
diff --git a/net/pancho/Makefile b/net/pancho/Makefile
new file mode 100644
index 000000000000..c70867e8ba36
--- /dev/null
+++ b/net/pancho/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: pancho
+# Date created: november 2nd, 2001
+# Whom: Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pancho
+PORTVERSION= 2.6
+CATEGORIES= net
+MASTER_SITES= http://pancho.lunarmedia.net/
+DISTNAME= pancho-v2.6
+
+MAINTAINER= Nicolas.Jombart@hsc-labs.com
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/SNMP.pm:${PORTSDIR}/net/p5-Net-SNMP
+
+NO_BUILD= YES
+
+pre-patch:
+ @${MV} ${WRKSRC}/pancho ${WRKSRC}/pancho.old
+ @${SED} -e '1,1s:/usr/bin/perl:${PERL5}:' \
+ < ${WRKSRC}/pancho.old > ${WRKSRC}/pancho
+.if defined(WITH_PANCHO_LOGGING)
+ @${MV} ${WRKSRC}/pancho ${WRKSRC}/pancho.old
+ @${SED} -e '35,1s:logging = "":logging = "1":' \
+ < ${WRKSRC}/pancho.old > ${WRKSRC}/pancho
+.endif
+ @${RM} ${WRKSRC}/pancho.old
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pancho ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/pancho
+.for i in README LOGGING
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/pancho
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pancho/distinfo b/net/pancho/distinfo
new file mode 100644
index 000000000000..6300ade0f036
--- /dev/null
+++ b/net/pancho/distinfo
@@ -0,0 +1 @@
+MD5 (pancho-v2.6.tar.gz) = b806b9cdca03247a1200595254711dea
diff --git a/net/pancho/files/patch-aa b/net/pancho/files/patch-aa
new file mode 100644
index 000000000000..302d0f26475d
--- /dev/null
+++ b/net/pancho/files/patch-aa
@@ -0,0 +1,11 @@
+--- pancho.orig Sat Nov 3 16:12:13 2001
++++ pancho Sat Nov 3 16:13:03 2001
+@@ -34,7 +34,7 @@
+
+ my $logging = ""; # set this to "1" to enable logging
+
+-my $logfile = ""; # full path to your logfile
++my $logfile = $ENV{HOME}."/pancho.log"; # full path to your logfile
+
+ ############ NO FURTHER EDITING SHOULD BE REQUIRED. ############
+ ############ DOING SO IS AT YOUR OWN RISK. ############
diff --git a/net/pancho/files/patch-ab b/net/pancho/files/patch-ab
new file mode 100644
index 000000000000..79ef97212ce2
--- /dev/null
+++ b/net/pancho/files/patch-ab
@@ -0,0 +1,10 @@
+--- LOGGING.orig Sat Nov 3 16:26:20 2001
++++ LOGGING Sat Nov 3 17:31:18 2001
+@@ -69,3 +69,7 @@
+
+ % touch /var/log/pancho
+ % chmod 600 /var/log/pancho
++
++Note: The FreeBSD port compiled with -DWITH_PANCHO_LOGGING enables
++logging into ~/pancho.log so the setuid bit isn't set.
++
diff --git a/net/pancho/pkg-comment b/net/pancho/pkg-comment
new file mode 100644
index 000000000000..f2259e2c34e1
--- /dev/null
+++ b/net/pancho/pkg-comment
@@ -0,0 +1 @@
+Perl script useful to configure Cisco routers via TFTP
diff --git a/net/pancho/pkg-descr b/net/pancho/pkg-descr
new file mode 100644
index 000000000000..ca9959cf4262
--- /dev/null
+++ b/net/pancho/pkg-descr
@@ -0,0 +1,14 @@
+Pancho was written with the goal of allowing network
+admnistrators make a change to a group of Cisco routers
+without being required to log into each host.
+
+Pancho also provides the flexibility to allow admins to
+use its function against a single host, a select group
+or the entire whole. In addition to changes to current
+configurations on remote routers, pancho is also capable
+of archiving router configurations manually or through
+automated runs.
+
+WWW: http://pancho.lunarmedia.net/
+
+--Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
diff --git a/net/pancho/pkg-plist b/net/pancho/pkg-plist
new file mode 100644
index 000000000000..a5e94a3d5058
--- /dev/null
+++ b/net/pancho/pkg-plist
@@ -0,0 +1,3 @@
+bin/pancho
+%%PORTDOCS%%share/doc/pancho/README
+%%PORTDOCS%%share/doc/pancho/LOGGING