aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordvl <dvl@FreeBSD.org>2017-05-22 20:10:42 +0800
committerdvl <dvl@FreeBSD.org>2017-05-22 20:10:42 +0800
commitca04baea7dab9b0cbc2446cd10380a146db08588 (patch)
tree659a5c983731873bca4e11932218fbdd77fab029 /net
parent938863f725af7a7c52bd715e2701d99680e088ca (diff)
downloadfreebsd-ports-gnome-ca04baea7dab9b0cbc2446cd10380a146db08588.tar.gz
freebsd-ports-gnome-ca04baea7dab9b0cbc2446cd10380a146db08588.tar.zst
freebsd-ports-gnome-ca04baea7dab9b0cbc2446cd10380a146db08588.zip
Include rrsync with net/rsync
This script can be used to restrict rsync to subdirectory declared in ~/.ssh/authorized_key bump PORTREVISION Approved by: ehaupt (maintainer) Differential Revision: https://reviews.freebsd.org/D10851
Diffstat (limited to 'net')
-rw-r--r--net/rsync/Makefile7
-rw-r--r--net/rsync/pkg-plist1
2 files changed, 6 insertions, 2 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index f0ec030e4df9..ba17181c99c4 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -4,7 +4,7 @@
PORTNAME= rsync
PORTVERSION= 3.1.2
CATEGORIES= net ipv6
-PORTREVISION= 6
+PORTREVISION= 7
MASTER_SITES= http://rsync.samba.org/ftp/rsync/ \
ftp://ftp.samba.org/pub/rsync/ \
ftp://ftp.sunet.se/pub/unix/admin/rsync/ \
@@ -18,7 +18,8 @@ COMMENT= Network file distribution/synchronization utility
LICENSE= GPLv3
-USES= cpe
+USES= cpe shebangfix
+SHEBANG_FILES= support/rrsync
CPE_VENDOR= samba
CPE_PRODUCT= rsync
@@ -101,11 +102,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|perl.*|${DO_NADA}|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's:/etc/:${ETCDIR}/:g' \
${WRKSRC}/rsync.h ${WRKSRC}/rsync.1 ${WRKSRC}/rsyncd.conf.5
+ @${REINPLACE_CMD} -e 's|/usr/bin/rsync|${PREFIX}/bin/rsync|g' ${WRKSRC}/support/rrsync
post-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${FILESDIR}/rsyncd.conf.sample ${STAGEDIR}${ETCDIR}/
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/support/rrsync ${STAGEDIR}${PREFIX}/sbin
.include <bsd.port.post.mk>
diff --git a/net/rsync/pkg-plist b/net/rsync/pkg-plist
index 6c5a3e18597c..a361a8063c06 100644
--- a/net/rsync/pkg-plist
+++ b/net/rsync/pkg-plist
@@ -1,4 +1,5 @@
bin/rsync
+sbin/rrsync
man/man1/rsync.1.gz
man/man5/rsyncd.conf.5.gz
@sample %%ETCDIR%%/rsyncd.conf.sample